Forum / Devolutions Password Server - Support

Migration from PVM to PVS

  • Create an Issue
  • Cancel

Hello,

We are testing/evaluating the use and migration from PVM to PVS. We have a PVS in trial mode currently running.

I exported all entries from PVM and imported those into PVS, this went fine, however all settings about Security Groups are gone, so for the moment I see all entries (being admin) but when I create a normal user he sees nothing.

I saw that in PVS the security group notion is being phase out. So we should use roles. How do I go about this? I tried to create a role but assigning this role to all entries will be quite a task.

Could you inform how I should proceed on this? I tried to setup permission on the Default Vault but got an error.

Thx

Clock2 mths


Hello,

With the role based security as with the legacy security groups, there is no need to set permissions on all entries. We recommend to set permissions on folders as entries will by defeult inherit the parent folder security (permissions or security groups).

That being said, could you please send us the detailed error message you get when you try to set permission with a role?

Best regards,



Érica Poirier

signaturesignature

Clock2 mths

For now what I did, export all entries in old PVM

Imported those into default Vault in PVS, by default only administrator can view entries. So wanted as a test to allow normal user to see those entries also.

Then on Top Vault right-click and select properties then Security, on the Permisson field I see "Never"

Try to select "Custom" and then button "UPDATE" - window stays open and after a few seconds got an erro window "e.data is undefined"


hMU2/c</e.prototype.validatePwned/<@https://xxx/dps/main.b39eae15145d7862218e.js:1:3529788
q3Kh/l</t.prototype._next@https://xxx/dps/main.b39eae15145d7862218e.js:1:5174228
FWf1/c</t.prototype.next@https://xxx/dps/main.b39eae15145d7862218e.js:1:1207537
67Y//l</t.prototype._next@https://xxx/dps/main.b39eae15145d7862218e.js:1:321385
FFOo/d</t.prototype.next@https://xxx/dps/main.b39eae15145d7862218e.js:1:988516
VnD//l</t.prototype._next@https://xxx/dps/main.b39eae15145d7862218e.js:1:2840934
FFOo/d</t.prototype.next@https://xxx/dps/main.b39eae15145d7862218e.js:1:988516
psW0/d</t.prototype.notifyNext@https://xxx/dps/main.b39eae15145d7862218e.js:1:5169477
zotm/o</t.prototype._next@https://xxx/dps/main.b39eae15145d7862218e.js:1:5498607
FFOo/d</t.prototype.next@https://xxx/dps/main.b39eae15145d7862218e.js:1:988516
FFOo/d</t.prototype._next@https://xxx/dps/main.b39eae15145d7862218e.js:1:988845
FFOo/d</t.prototype.next@https://xxx/dps/main.b39eae15145d7862218e.js:1:988516
FFOo/d</t.prototype._next@https://xxx/dps/main.b39eae15145d7862218e.js:1:988845
FFOo/d</t.prototype.next@https://xxx/dps/main.b39eae15145d7862218e.js:1:988516
xMyE/u</t.prototype._next@https://xxx/dps/main.b39eae15145d7862218e.js:1:5464860
FFOo/d</t.prototype.next@https://xxx/dps/main.b39eae15145d7862218e.js:1:988516
u@https://xxx/dps/main.b39eae15145d7862218e.js:1:5280153
0TWp/</</u</t.prototype.invokeTask@https://xxx/dps/polyfills.78dbaa1015e713cf5cb0.js:1:10564
onInvokeTask@https://xxx/dps/main.b39eae15145d7862218e.js:1:654678
0TWp/</</u</t.prototype.invokeTask@https://xxx/dps/polyfills.78dbaa1015e713cf5cb0.js:1:10485
0TWp/</</o</e.prototype.runTask@https://xxx/dps/polyfills.78dbaa1015e713cf5cb0.js:1:5744
0TWp/</</s</e.invokeTask@https://xxx/dps/polyfills.78dbaa1015e713cf5cb0.js:1:11678
y@https://xxx/dps/polyfills.78dbaa1015e713cf5cb0.js:1:22642
b@https://xxx/dps/polyfills.78dbaa1015e713cf5cb0.js:1:22884

By the way I replaced my server address by xxx


Clock2 mths

In addition, I got this error on any folder in the Vault where I try to setup custom permissions!

Clock2 mths


Hello,

I am unable to reproduce this issue. I will ask an engineer to have a look on this error message.

In the meantime, do you get the same issue if you set the Permission to Default?

image

Best regards,



Érica Poirier

signaturesignature

Clock2 mths

Yes we have the same error.

Permission in my case is set to "Never" and so I cannot change it.

Clock2 mths


Hello,

Could you please send us the error message using the Send to Support button to get the whole error message?

Best regards,



Érica Poirier

signaturesignature

Clock2 mths

Hum,

Seems it gives an Error when trying to do so, I then tried downloading the zip but I got an error also!?

Clock2 mths


Hello,

That's definitely strange!

Are you available for a remote session now?

If so, please send a email to ticket@devolutions.net and will send you the GotoMeeting link.

Best regards,



Érica Poirier

signaturesignature

Clock2 mths

done

Clock2 mths


Hello,

Session link sent from ticket DEVO-5430.

Best regards,



Érica Poirier

signaturesignature

Clock2 mths


Hello,

@everyone, the issue is now resolved. It was related to the Pwned check feature enabled and a proxy or firewall that prevent DPS to reach the Pwned check cloud service.

If the server where DPS is hosted doesn't have access to internet, please set the Pwned check feature to None in Administration - System Settings - Password Policy.

image

For more information about the Pwned check feature, please see this blog article.
https://blog.devolutions.net/2018/11/remote-desktop-manager-14-feature-pwned-password-check

Best regards,



Érica Poirier

signaturesignature

Clock2 mths