Forum / Devolutions Password Server - Support

Problem logging into DPS using Office365

  • Create an Issue
  • Cancel

We've set up Office365 authentication in DPS, but we can't log in using Office 365.
When we click on the Office 365 Log In button this adress is shown in the adressbar and we're returned to the Login page:
https://mysitename/dps/login#error=unsupported_response_type&error_description=AADSTS700054%3a+response_type+%27id_token%27+is+not+enabled+for+the+application.%0d%0aTrace+ID%3a+7471bcca-1a8c-4f9d-94ef-8f27f4a37500%0d%0aCorrelation+ID%3a+c9dd171c-74be-4aac-971d-bdc2fe106a13%0d%0aTimestamp%3a+2019-07-16+13%3a21%3a24Z&error_uri=https%3a%2f%2flogin.microsoftonline.com%2ferror%3fcode%3d700054&state=80a23e46-2f96-479f-8dbd-6ace93aca389

Clock2 mths

The version we're using is:
2019.1.17.0
This is the guide we've tried to follow:
https://helpserver.devolutions.net/index.html?kb_azureauthconfig.htm
But the choices we get in Azure AD is not exactly as they are in the guide.

Clock2 mths


Hello,

To be able to use the Office365 authentication with DPS, you need to create the Apps using the App Registrations (Legacy) in Azure AD. Our engineering team is working on this to be able to use the latest Azure AD App and once it will be available, we will updtae this thread.

Sorry about that!

Best regards,



Érica Poirier

signaturesignature

Clock2 mths

Ok, after using the legacy registrations I'm able to log into the webinterface.
But when I try to set it up in RDM I get this error:
AADSTS50011: The reply url specified in the request does not match the reply urls configured for the application: '71c5519c-4932-46cd-b648-0d435d27c0aa'.

Clock3 mths


Hello,

For both DPS data source in RDM and the Azure app, could you please verify that you are using the same URL without the /login at the end?

Best regards,



Érica Poirier

signaturesignature

Clock3 mths

Yes, I use the same URL without the /login at the end.
The webapp DPSWeb is the only app that has /login at the end of the URL.

Clock3 mths


Hello,

Do you have any relevant error messages in the DPS Logs about this issue?
Please see this page about DPS Logs.
https://helpserver.devolutions.net/configure_dvlslogs.htm

If there is nothing interesting in the DPS logs, we can verify what is happening on your environment during a remote session. Please send an email to ticket@devolutions.net to book an appointment.

Best regards,



Érica Poirier

signaturesignature

Clock3 mths

I have opened a ticket with support regarding issues with office365 not syncing the users, groups correctly.

Clock2 mths

Wrong thread, we had similar issue with office 365 authentication but were able to resolve it by registering the application in azure using the app registrations (legacy). The support ticket i mentioned above is on a a separate issue with groups not syncing.

Clock2 mths


Hello,

@everyone, the main issue of that thread was that a typo has been made for the Redirect URI and the information wasn't the same in the DPS Office365 settings and the Azure App settings.

About the user and groups sync issue, please consult this DPS support topic for more information about it.

Best regards,



Érica Poirier

signaturesignature

Clock2 mths


Hello,

@jon-arne For your information, the online documentation about the Office365 authentication configuration has been updated to use the new AzureAd user experience interface.

There is no need to create new AzureAD Apps. Just check if all parameters are correctly set on Azure side.

Best regards,



Érica Poirier

signaturesignature

Clock28 days