Forum / Remote Desktop Manager - Support (Français)

Terminal SSH défilement

  • Create an Issue
  • Cancel


Bonjour,

Depuis plusieurs version de RDM, je rencontre un problème de défilement avec mes sessions SSH. En effet, lorsque j'atteins le nombre lignes prévues dans l'historique (2000 par défaut), le défilement ne se fait plus correctement. Je dois cliquer avec la souris sur la fenêtre SSH active pour que le rafraichissement puisse se faire.

Merci de votre aide.

Clock4 mths

Bonjour,


J'ai aussi le même problème. j'utilise RDM 2019.1.36 avec SQL serveur.
Exemple un ls ou un yum install, l'écran ne se rafraichit pas.
J'ai fais un vidéo. Est-ce possible de vous l'envoyer via un lien sécurisé?


merci

Clock4 mths

Bonjour,

Il est possible de nous envoyer votre video via le lien suivant:
https://devolutions.sharefile.com/filedrop

Cordialement,



Jeff Dagenais

signaturesignature

Clock4 mths

Bonjour,
le vidéo à été déposé. Regarder à partir 16-17 à 25 secondes lors du LS.
merci

Clock4 mths

Bonjour,

Merci pour cet enregistrement!

Cela étant dit, est-ce que vous utilisez une session SSH Shell avec ses valeurs par défaut? Avez-vous changer le "Max Scrollback Lines" ?

De plus, est-ce que l"option "Use Legacy terminal" est coché sous File -> Options -> Types -> Terminal? si oui, serait-il possible de tester sans cette option?

Cordialement,



James Lafleur

signaturesignature

Clock4 mths

Bonjour,


je viens de remarquer que mon mac scrollback est a 256 je n'ai jamais touché vraiment à cette valeur, Par contre c'était tous des sessions putty que j'ai converti. Quand je créer un nouvelle entré ssh shell j'ai 2000. Alors je vais devoir changer le tout en batch.
Je vais tester l'option Legacy et je vous reviens.


merci

Clock4 mths

Je vous confirme que quand on converti une session putty en SSH shell le scrollback se met a 256. Même si dans mon putty c'est 2000.

Clock4 mths

Bonjour,
je ne trouve pas d'options pour changer la valeur du scrollback en batch. J'ai 1000 entrées SSH shell, je ne voudrais pas les changer 1 par 1.
merci de votre aide

Clock4 mths

Bonjour,
l'option Use Legacy terminal semble corriger le problème de refresh. Nous allons vous revenir si le problème revient encore…
Par contre j'aimerais bien augmenter mon scrollback à 2000... en batch.
merci de votre aide


Clock4 mths

Bonjour,

Pour appliquer ce changement sur de multiples sessions, vous allez devoir utiliser le fonctionnalité "Edit -Special Action Selection" -> "Custom Powershell Command" pour lancer la commande ci-dessous:


$connection.Terminal.MaxScrollbackLines = "2000"
$RDM.Save();


Pour plus d'informations a ce sujet, veuillez consulter le lien ci-dessous:
https://help.remotedesktopmanager.com/batch_actions.htm#settings

Cordialement,



James Lafleur

signaturesignature

Clock4 mths

Parfait merci.
J'ai une autre datasource que nous allons convertir des sessions putty en ssh shell. Est-ce que vous allez corriger le scrollback lors de la conversion de 256 a 2000?

Clock4 mths

Bonjour,

Serait-il possible de me fournir le type d'entrée exact que vous utilisez? J'ai effectué des tests dans notre environement et je ne suis pas en mesure de reproduire ce comportement. Une entrée de type Putty convertit en SSH Shell passe d'un scrollback de 256 a un de 2000 sans aucun problemes.

Cordialement,



James Lafleur

signaturesignature

Clock4 mths

Putty à ssh shell.


Je viens d'envoyer un video sur sharefile.


https://devolutions.sharefile.com/filedrop


Clock4 mths

Bonjour

Merci pour cet enregistrement. Ce dernier m'a permis de constater que vous utilisez Edit (Special Actions) -> Convert Putty/Rebex Session To SSH/Telnet/PortForward Session -> SSH Shell. En utilisant cette méthode, je suis en mesure de reproduire ce problème.

Lors de mes tests, j'utilisais Edit (Special Actions) -> Change type -> SSH Shell directement. Avec cette méthode la valeur du "ScrollBack" passait de 256 à 2000.

Un billet à ce sujet a été assigné à nos développeurs pour voir ce qui peut etre fait à ce sujet. Je vous contacte dès que j'aurai plus d'informations à ce sujet.

Cordialement,



James Lafleur

signaturesignature

Clock4 mths


Bonjour,

J'ai testé avec l'option "Use Legacy terminal" est coché sous File -> Options -> Types -> Terminal et le comportement du terminal semble être redevenu normal.

Merci de votre aide.
Cordialement.

Clock4 mths

Bonjour,

Merci pour votre retour!

Cela signifis que cette erreur se produit uniquement avec notre nouvel engin "SSH Shell". En cochant l'option "Use Legacy Terminal" vous avez retourner a l'ancien engin "Putty". Je vous informerai des que ce probleme sera réglé dans notre nouvel engin.

Cordialement,



James Lafleur

signaturesignature

Clock4 mths


Bonjour,

Nos développeurs viennent de m’informer qu'un correctif pour le problème avec le « MaxScrollBack lines" lors de la conversion a été ajouté à l'interne et qu'il devrait être disponible dans RDM 2019.1.37.0.

Cordialement,




James Lafleur

signaturesignature

Clock4 mths