Forum / Remote Desktop Manager - Feature Request

Shortcut for closing a session doesn't work

  • Create an Issue
  • Cancel

Hello,

we want to use STRG + W to close a session, like you know it from modern web browsers.

We set up the keyboard shortcut in the settings:

2019+07+05+11+56+27+Remote+Desktop+Manager

But the only thing that's working is to set up as global hotkey. The disadvantage is that this setting is system wide, so it breaks the hotkey in other programs like Google Chrome.

Greets
Daniel


2019-07-05 11_56_27-Remote Desktop Manager.png
Clock4 mths


Hello Daniel,

We will move this thread in the feature request which is more related.

Best regards,



David Grandolfo

signaturesignature

Clock4 mths

Hello,

Is there a reason why you can't put the shortcut as "default"? It seems to work well for me when set in that mode.

Regards,

Hubert Mireault

signaturesignature

Clock4 mths

Hello,

no, default doesn't work, too. I tried another shortcut keys like STRG + ALT + W, but nothing changed.

Clock4 mths

Hello Daniel,

Which version of RDM are you having the issue with?
Also, which type of entry/browser are you using?

I tested with a Web Browser (http/https) and Chrome in Embedded mode and it seems to work. But only when the key is set to Default.

Best regards,



David Grandolfo

signaturesignature

Clock4 mths

Hello David,

currently I'm on 2019.1.35.0.

STRG + W does work for me in Browser Sessions, too, because i activated the Browser Keyboard Shortcuts.

2019+07+10+14+28+03+Remote+Desktop+Manager+++heise.de+(c%27t+Artikel+Archiv)+%5bRDM%5d

But I want to use STRG + W for other sessions like RDP, too.

2019-07-10 14_28_03-Remote Desktop Manager - heise.de (c't Artikel-Archiv) [RDM].png
Clock4 mths

Hello,

Thank you for this information, I successfully reproduce the issue if CTRL + W is set to two differents function. If you do not have many personalized keyboard shortcuts. Could you Reset Default the keyboard shortcut and try again the Close option (as default)

reset+keyboard

Best regards,



David Grandolfo

signaturesignature

reset_keyboard.png
Clock4 mths

Hello David,

no sorry, that this still doesn't work. After resetting and restarting RDM I tried other shortcuts like "STRG + ALT + W", but nothing happens.

Is there a restriction when using RDP? Which session type did you try?

Clock4 mths

I tried with both RDP and Web browser, but the main test was with Web Browser (http/https). I open a ticket with the QA department (QA-1004), if they are able to reproduce this issue.



David Grandolfo

signaturesignature

Clock4 mths

Hello,

After a few tests without successfully reproduce the issue. Could I ask, where the focus is when you try to close those sessions?

If the shortcut is set to ‘'When not in session'', please focus on the Dashboard.

A video of your Keyboard shortcuts settings and trying to close sessions with it would help us understanding if it’s because of where the focus is and with what setting.


Please use the secure link below to send us the requested file(s);
https://devolutions.sharefile.com/filedrop


Best regards,



David Grandolfo

signaturesignature

Clock4 mths

Hello David,

I made a video and uploaded it to sharefile.

Clock4 mths

Hi Daniel,

Thanks for the video, it was useful. If you look in the bottom right of RDM you will see a little white magnet. Could you please click on it. It should switch in RED.


Enable+Magnet


And then now the Grab the keyboard input should works.

Best regards,



David Grandolfo

signaturesignature

Enable_Magnet.png
Clock4 mths

Hi David,

ah ok that did it for me! I've ever wondering what will this magnet do. smile

Clock4 mths

Hi Daniel,

I'm glad it fixed the issue, and now we know wink

Regards,



David Grandolfo

signaturesignature

Clock4 mths