Forum / Remote Desktop Manager - Support

Unable to login to RDM Free or cloud.devolutions.com when proxy used

  • Create an Issue
  • Cancel


In the office I have proxy which performs SSL interception. The proxy certificate is loaded into Windows 10 as a Trusted Root CA by GPO and I have to manually load into Firefox as it does not use the Windows certificate store.

When I launch RDM Free I am now being prompted to login and this always fails. I am also prompted regularly on startup to accept a certificate which I presume is the proxy certificate for SSL interception.

If I attempt to access https://cloud.devolutions.com in IE11 my login fails but if I use Firefox with the proxy disabled then login works OK. This makes me think it is the SSL interception that is causing the login to fail.

I changed the options in RDM Free to not use a proxy but when I restarted RDM Free it was enabled again. The config file (RemoteDesktopManagerFree.cfg) showed the proxy setting was default.

I've installed the update from 17/06/2019 and it now seems to remember that proxy has been disabled in options butTCPView shows that the proxy is still being used and under the Help - Application Logs I can see that there is a 407 authentication request being received from the proxy. There is no longer anything present in the config file for proxy.

This didn't used to be an issue. I have cloud backup but this is dated March 2019.

Clock5 mths

Hello,
I will verify why No proxy does not work and let you know. Do you use IE11 outside of RDM? Do you know which proxy you have?

Regards

David Hervieux

signaturesignature

Clock5 mths

I have verified the code for the proxy and the settings are not applied for the embedded IE. It's only for the web request done by RDM. I'm not sure what we can do but we will continue to investigate.

Regards

David Hervieux

signaturesignature

Clock5 mths


I do use IE11 but mainly Firefox and my proxy is Blue Coat (now Symantec).

I am only using RDM for RDP and nothing with IE11.


I have a GPO applied which prevents me from changing the proxy in my IE11 or Edge (the option is greyed out) but as you can see from the attached screenshot, "No Proxy" has been selected within RDM.

I also attached a screenshot showing the error I get when trying to login to https://cloud.devolutions.net/ in IE11 (using proxy) but it is OK using Firefox (without proxy).

RDM Free - Proxy Configuration.png
Devolutions - Login.png
Clock5 mths

I don't think RDM is able to bypass the GPO with the No Proxy. Does the print screen is from IE or from embedded IE in RDM?

Regards

David Hervieux

signaturesignature

Clock5 mths


The expected behaviour would be for "No Proxy" to ignore the IE proxy setting and for "System Default" to use the proxy settings configured for IE. That is the behaviour I've had in other applications such as Firefox.


The print screen is from RDM. I go to File - Options - General - Proxy (Web) - Proxy Settings. I don't know what is meant by "embedded IE in RDM".

Clock5 mths


Hi,


We are looking into your issue. As I understand, when the login is prompted, the page renders correctly but the login action don't work properly. Neither in RDM nor in IE11. By following the step in this link : https://support.umbrella.com/hc/en-us/articles/230903888-capturing-network-data-with-internet-explorer-s-developer-tools you will be able to export a network capture of the login page. Before exporting the data, please make sure you tried to log in, this way we will have all the information we need.

In addition to the capture, a screenshot of the console (if available) could also be insightful.

Regards


Richer Archambault

signaturesignature

Clock5 mths

I am also behind a bluecoat proxy and have also posted the following in another thread.

I am having the same issue as well. I am currently on the latest version 2019.1.33 and even though I have my email, serial, and it says it is registered, I keep receiving the cloud login page.

I can login online but not through this prompt which I believe may be blocked by the proxy. Until this version I have never been prompted by the cloud login after adding the serial. I have also had to turn off the certificate prompt as that started popping up a few versions ago but was not able to update because of the proxy.

I am able to cancel the cloud login and use Remote Desktop Manager as usual but he login prompt on startup is becoming quite annoying.

I have been using your product for over 10 years now and would just like it fixed.

Thanks,

Mike

Clock5 mths

Hello Micheal,
I think there is an easy fix for you. Just go to the section File->Devolutions Account and uncheck Automatically sign-in at startup

We are working on the proxy problem.

Regards

David Hervieux

signaturesignature

Clock5 mths


Hi @james15,

We just updated our login page with some compatibility fixes for IE, could you try again and see if this work for you.
If not, could you provide some information to help us debug you issue (see my last post : https://forum.devolutions.net/topic32053-unable-to-login-to-rdm-free-or-clouddevolutionscom-when-proxy-used.aspx?lastpage=1#post129855)

Regards

Richer Archambault

signaturesignature

Clock5 mths