Forum / Remote Desktop Manager - Feature Request

SecureCRT Session tab name

  • Create an Issue
  • Cancel

Hi,

Could you please create an option in the SecureCRT session to adopt the session name from Remote Desktop manager to the tab name of SecureCRT.
With the option "/N "name"" is used after the "/T" option you can set the tab name.

If there are any further questions please don't hesitate to contact me.

Kind regards,

Wesley

Clock6 mths

Hello,
I will assign this to one of our dev.

Regards

David Hervieux

signaturesignature

Clock6 mths

Hello Wesley,

Can you try putting "/N $NAME$" in the other parameter field and see if it works? The $NAME$ variable resolves to the session name.

Regards,

Hubert Mireault

signaturesignature

Clock6 mths

Hi Hubert,

Sorry for my late response.
When I use -n "$NAME$" this parameter it seems to be workings, unfortunately secureCRT also use this name to make a connection(DNS resolving).
Error message "Hostname lookup failed: host not found"

Can you see what the command sequence is?

If there are any questions please don't hesitate to contact me.

Kind regards,

Wesley Pronk

Clock2 mths

Hello,

If you would like to see the order of the parameters, you could use a tool we made called CommandLineRegurgitator (I attached it to this post). It simply outputs whatever it receives through command line. You would need to rename it to the same name as the SecureCRT executable and configure RDM to use that executable instead of the real SecureCRT one.

With the following settings:

2019+10+01+10+08+50

It would output the following:

2019+10+01+10+08+56

Which means that we send /T, then the user+host, then the /Password, then the "other parameters".

Regards,

Hubert Mireault

signaturesignature

CommandLineRegurgitator.zip
2019-10-01_10-08-50.png
2019-10-01_10-08-56.png
Clock2 mths

Hi Hubert,

Is it possible for you to insert the "-n 'entryname" after the /T parameter?

Kind regards,

Clock2 mths

Hello,

Yes, if that's the reason why it doesn't work, there's no problem. We'll open a ticket to add a field for the session tab name that will be sent after the /T parameter.

Regards,

Hubert Mireault

signaturesignature

Clock2 mths

Hi Hubert,

I've test some parameters and think the below order is correct.
.\SecureCRT.exe /N "test" /T admin@192.168.220.254 /Password abc123

I've used this website to test some commands.
http://www.mathewjbray.com/securecrt/securecrt-command-line-options/

If there are any further questions please don't hesitate to contact me.

Kind regards,

Wesley Pronk

Clock2 mths

Hello!


Thanks for bringing this issue to our attention. We've added the Session tab name field where you can enter the desired information. As per showcased in your latest reply, this will be placed before the /T.

image

We hope this will fix your situation!

Regards,

Jafran Majeau

signaturesignature

Clock2 mths

Good evening Jafran,

Thank you very much for the quick fix.
When can we update our "add-on".

Kind regards,

Wesley Pronk

Clock2 mths

Hello,

As add-ons are now integrated within RDM releases, the fix will be available starting with RDM version 2019.2.10.0.

Regards,

Hubert Mireault

signaturesignature

Clock2 mths

Hi Hubert,

I've also created a ticket but unfortunately I didn't receive any response.(Ticket e-mail wpronk@efteling.com)
When I use the new option there comes an error "invalid command line option /T".

The current RDM version send:
securecert.exe /N "test" /T admin@192.168.2.254 /Password abc123

For some reason SecureCRT wants the option /T first in the command string.
securecrt.exe /T /N "test" admin@192.168.2.254 /Password abc123

Is it possible to change this addon?

Kind regards,

Wesley Pronk

Clock12 days

Hello,

No problem, we will change this.

Regards,

Hubert Mireault

signaturesignature

Clock12 days

Hello w03,


As per your last request, I've moved the parameter -n "test" after the /T. Hopefully you will now get the expected behavior. This should take hold for the next patch!

Regards,


Jafran Majeau

signaturesignature

Clock9 days