Forum / Remote Desktop Manager Mac - Bug Report

Jump host credentials not working on SSH Shell Session

  • Create an Issue
  • Cancel

Hi,

I use RDM Enterprise Edition for Mac 2019.1.4.0 with MySQL data source. Since I have upgraded to this latest version my setup using Jump Host on SSH Shell sessions stopped working. It only works if the Jump Host credentials is saved in the SSH Shell session (Jump Host tab) itself. I have separate credentials session which stores the username/password linked on the Jump Host tab of the SSH Shell session that was working before the upgrade. Now I get an error message ("Error: FAIL_PERMISSION_DENIED, Code -3"wink whenever I try to connect with these SSH sessions. Can I get some help on this please?


Thanks,

Felipe


Clock9 days

Hello,


On what OS are you connecting to? And what authentication method are you using (Password, Private Key, etc.)?

Out of curiosity, could you try the Experimental engine and tell me if you have the same issue? You can find the option in the Preferences windows under the Session Type -> SSH Shell tab in the General box.

Could you also set Verbose to 4 and enable logging (to a file) and provide the resulting file? You can find those settings in your session under the Advanced tab.

Best regards,




David Grandolfo

OFFICE CLOSURE!
Although our various support queues will be monitored for emergencies, Devolutions' offices will be closed on June 24 and July 1st, 2019.

signaturesignature

Clock8 days

Hi David,

I'm using MacOS Mojave 10.14.5. The authentication method is user/password. I don't see the Experimental engine option in Preferences -> Session Type -> SSH Shell -> General Box (the only option in there is "Copy mode" ). I have set the verbose mode to 4 but there's no much output as I get disconnected before, when trying to connect to the Jump Host.

The output I get is:

Setting up connection
Using jump host: "ip_address"
Connecting as "username"
Disconnecting


Thanks.

Clock8 days


Hi,

For the Experimental Engine, this is our mistake, there is no longer an Experimental Engine setting.

I'm assuming "ip_address" and "username" are placeholder with which you replaced your actual address and username?

This is weird, I can't reproduce. Under the SSH Gateway tab, I set the host on which I want to jump. I then select "Credential repository" and choose my repository with the right credentials. I launch the session afterwards and it properly connect.

Are you sure that your credential repository still hold the right credentials?

Best regards,

Xavier Fortin

signaturesignature

Clock8 days

Also, can you properly SSH to your Jump host using the same Username/Password Credential repo that you set in your SSH Gateway tab?

Xavier Fortin

signaturesignature

Clock8 days

You're correct, "ip_address" and "username" are placeholders. Yes, I can connect to the jump host using the same repo. Also, I can connect successfully to the target host through the jump host if I enter the credentials directly in the SSH Gateway tab.

Clock6 days


Hi,

I've tried everything I could think of (wrong host credentials, wrong jump host credentials, wrong port, wrong jump port, wrong hosts) and I can't get an output log similar to yours. The only thing that gave me a FAIL_PERMISSION_DENIED was the wrong password on the host (not the jump host) and even then, I add many more lines in my session log between the 'Connecting as "username"' and 'Disconnecting' lines.

At this point, I'm assuming I've missed something with your configuration. Could you get me screenshots of the General, SSH Shell -> General an SSH Shell -> SSH Gateway (jump host) tabs of your entry? Just obfuscate any sensitive information, I just want to check which settings are used and what field are filled.

Also, what version of RDM Mac were you using before updating to RDM 2019.1.4.0?


Best regards,

Xavier Fortin

signaturesignature

Clock6 days

Apparently, my SSH sessions that use the jump host are somehow corrupted. I created a SSH session from an existent one (duplicate) which also failed to connect. But when I created a new SSH session using the same parameters it worked. I wonder if there's anyway to fix this, otherwise I will have to re-create all the 60 sessions.

Clock6 days


Hi,

We might be able to find a way to resolve this. First, we would need to discover what in the non-functioning sessions causes the issue. You can export a functioning session and a non-functioning one. This will give your 2 .rdm files (which are actually xml file) that you can compare using any file compare tool (or manually if the files are not too complex). This way you should be able to identify the setting that causes the issue.

Best regards,

Xavier Fortin

signaturesignature

Clock6 days

Hi Xavier,

I found the culprit. There's an URL entered in the session description (More -> Description tab -> URL). This URL contains the variable $NAME$ on it. When I remove the variable from the URL everything works as before. Would you mind check if you can replicate this please?

Thanks,

Felipe

Clock6 days


Hi Felipe,

I can reproduce! Thanks a lot for taking the time to find this.

I'll see what's up with this and come up with a fix.

Best regards,

Xavier Fortin

signaturesignature

Clock6 days

Thanks for your prompt attention. I appreciate your help.

Clock6 days


Hi,

I've fixed the bug internally. This will be available in the next release of RDM Mac.

Best regards,

Xavier Fortin

signaturesignature

Clock6 days


Perfect, Xavier! Thank you again for your excellent support.

Best,

Felipe

Clock6 days