Forum / Devolutions Password Server - Support

Add as Subconnection in Remote Desktop Manager doesn't work and more problems..

  • Create an Issue
  • Cancel

Hi there,

first I tried RDM and found it quite impressing.. Now I wanted to try Password Server and installed on Windows Server 2019 with SQL Server 2017.. I don't run a domain, just workgroup..

Installation worked without a hassle but after importing the structure from the local datasource I discovered a problem..

When I click some elements on the fourth level of the tree (e.g. Datasource > Software-Licences > Adguard > Licence 01) I get an unexpected exception.. I discovered it on the mobile app and then it happened in Remote Desktop Manager on PC also.. Now the problem is gone on the PC (don't know why??) but if I right click on an element and click new entry it doesn't ask if I want to add a subconnection like it does if I work in the local Data-Source.. Maybe this has something to do with the problem?

Also I wonder why there is no export feature for the whole structure including attachments.. What if I have a structure with a lot of attachments at many different places and want to migrate so Passwort Server?

I'm not a native english speaker, so please be kind smile

Thanks and Best Regards
Stefan

Clock4 mths

Hello,

Thank you for your positive feedback!


Could you please open RDM on your Windows workstation and go under Administration -> Data Source Settings -> General and set "Allow sub" to "True" and see if this issue persist?

As for the exportation of attachments, sadly this cannot be achieved using the "Export" option.

Best regards,



James Lafleur

signaturesignature

Clock4 mths

That being said, I forgot to mention that you can go under File -> Export -> Export All Documents. The only drawback of this feature is that all of your attachments/documents will be exported in a single file.



James Lafleur

signaturesignature

Clock4 mths

Thanks for your quick answer! Enabled sub connections as you suggested and I can now add them.. But If I try to view such element in Android App it throws an exception.. I can edit the entry, I can view the password but if I click on "View" the error occurs.. This only happens on sub connections.. I have to admit I'm using Android 10 beta on my Essential Phone so I have to test with another phone to eliminate this as a cause..

Edit:
Tried with my S7 Edge (Android 9) and it behaves the same..

Here's a screenshot from the error message:

image
image
image

Clock4 mths

Hello,

Thank you for this information! We have been able to reproduce this issue . A ticket has been assigned to our engineering department on that matter.
I will contact you as soon as I will have an update on this situation.

Best regards,



James Lafleur

signaturesignature

Clock4 mths