Forum / Remote Desktop Manager - AddOns

SQL Server Management AddOn

  • Create an Issue
  • Cancel

Hello,

This addon doesn't work with Management studio 2018 and sql authentication since MS removed -P command line parameter.
Does anyone know is there any workaround for this or do you have plans to upgrade this addon.

Thank you

Clock7 mths

Hello,

Our add-on is build with the command line offer by Microsoft.
If Microsoft removed it, it would not be possible for us to offer it.

Microsoft probably remove this command line parameter for security reasons.

Best regards,



Jeff Dagenais

Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 24th, 2019, to January 1, 2020, inclusively.

signaturesignature

Clock7 mths

@everyone,

Here's the article regarding the parameters that have been removed in SSMS 18
https://cloudblogs.microsoft.com/sqlserver/2019/04/24/sql-server-management-studio-ssms-18-0-released-for-general-availability/

On our side, we will eventually add the support of "[-G] Use Azure Active Directory for authentication".

Best regards,



Jeff Dagenais

Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 24th, 2019, to January 1, 2020, inclusively.

signaturesignature

Clock7 mths


Any word on this. We recently upgraded to 18 and now none of my connections work. I get this dialog whenever I try to open a connection:

image

Clock5 mths

@nathan02,

I have opened a ticket to our engineering department regarding this.
The ticket number is RDMW-3220.

Best regards,



Jeff Dagenais

Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 24th, 2019, to January 1, 2020, inclusively.

signaturesignature

Clock5 mths


Thanks Jean-Francois!

I'm installing the previous version until then. What is the method to change where the add-on looks for SSMS.exe?

Clock5 mths

File > Options > Path > Configure Installation Path

2019+07+10+16+18+01

Stefane Lavergne

signaturesignature

2019-07-10_16-18-01.png
Clock5 mths

Ah ha! Thank you!

Clock5 mths


The next RDM build will have "support" for SSMS 18.

"support" what does that mean? Well, since we can't pass the password via command line in v18 the entire command line is more or less useless.

Example: start ssms with this command line:

ssms.exe -S myserver -d master -U myuser "c:\scripts\myscript.sql"
One would expect SSMS to start and prompt for the password. Well no, it will first throw an error then prompt you with the login window BUT populated with the last server/data/user from your last good connection, completely ignoring the (-S -d -U) values. But why Microsoft?

So my suggestion:

1 - Use Integrated Security (-E) or Azure Active Directory Integrated Security (-G) (now implemented)
2 - Keep SSMS v17.9.1 installed (side-by-side with v18) and configure RDM to use that version and all will keep on working.

Stefane Lavergne

signaturesignature

Clock5 mths

thank you guys very mush

Clock4 mths