Forum / Remote Desktop Manager - Bug Report

2019.1.21.0 crash after opening Wayk Now session

  • Create an Issue
  • Cancel

Hello,

we receive the following event viewer entry when RDM (sporadically) crashs by opening a Wayk Now session:
(no entry in the RDM Application log)

Name der fehlerhaften Anwendung: RemoteDesktopManager64.exe, Version: 2019.1.21.0, Zeitstempel: 0x5ce352fe
Name des fehlerhaften Moduls: DevolutionsWayk.dll, Version: 3.1.0.0, Zeitstempel: 0x5c7da842
Ausnahmecode: 0xc0000005
Fehleroffset: 0x000000000010ac00
ID des fehlerhaften Prozesses: 0x383c
Startzeit der fehlerhaften Anwendung: 0x01d50ffed0766324
Pfad der fehlerhaften Anwendung: C:\Program Files (x86)\Devolutions\Remote Desktop Manager\RemoteDesktopManager64.exe
Pfad des fehlerhaften Moduls: C:\Program Files (x86)\Devolutions\Remote Desktop Manager\x64\DevolutionsWayk.dll
Berichtskennung: 85305904-3a0c-44cf-9a28-34b61ca3a239

Thanks!

Regards,
Min

Clock6 mths

Hello Min,

We will take a look at the issue, thank you.

Regards,

Hubert Mireault

signaturesignature

Clock5 mths

I am seeing the same issue. This is happening frequently, which makes Wayk Now unusable. I will be in the middle of a session with a user, and it will crash all of a sudden. The user then has to reboot their computer to be able to open a session again. Very frustrating issue, and hopefully there is a fix soon.

Clock2 mths

Hi Min and dhumiston!

Sorry about the delay. I've been looking into this issue lately and couldn't find anything. I'm not able to reproduce the issue either. Can you provide a little bit more information that would help me pin-point the issue or reproduce it?

1. I'm curious to know if this happens with the first session you open (after opening RDM).
2. Are there any particular settings you changed in the entry or in RDM's global config?
3. After how long does this happen?
4. What's the Wayk Now version installed on the remote machine?

Best regards,

Philippe Paré

signaturesignature

Clock2 mths

1. This always happens with the first session after opening RDM, but it is rare for me to have multiple remote sessions in the time I have RDM open.

2. The way we configure Wayk Now clients in RDM is we use the hostname as the Name, the display is undocked, the Wayk Den source is default, and we use SRD for authentication. We also input the Unique ID on the advanced tab. Not sure if this answers your question, but not doing anything more advanced than the options we are given.

3. There are times a connection only lasts a minute, and times it lasts more than 20 minutes. You never know, and it will just crash in the middle of a session. I would say more often it happens in a shorter amount of time.

4. The remote machine has 3.3.0 installed on their machine. I try to update often, but am a version behind for all our machines.

One thing I want to note is this seems to be more of a problem with our remote machines that have less than optimal internet bandwidth. It still happens with users here in our office that have great internet bandwidth, but not as often. It is a little frustrating because I had to install our old remote product to help somebody out, and even with poor internet, it never dropped.

Clock2 mths

Hi dhumiston,

Thanks for the info. I'll try to reproduce the issue on my side and get back to you as soon as I have more info.

Regards,

Philippe Paré

signaturesignature

Clock2 mths

Hi again!

I've talked with a couple of people in the office and this seems to be an issue with how your network handles WebRTC traffic. We don't exactly know what the issue is, but we do have a solution for it. In you entry (in RDM) try enabling "Prefer relay" and see if that helps. This fixed the issue for the clients that had ths issue.

Hope this help, Regards,

Philippe Paré

signaturesignature

Clock2 mths

I will give that a try when I get a chance with one of my remote employees.

Clock2 mths

Hello Philippe,

it's a while ago but I guess my config was as follows:

Sub Entry from an RDP Entry
Display: Embedded
Credentials: Inherited - Standard
Wayk Den Source: Local
Authentication: Ask for permission

Prefer relay (was) not checked.

The remote Wayk version was the latest at this time - unfotunately I can't remember the exact version number upset

Thanks!

Regards,
Min

Clock2 mths

Hi Min and dhuminston!

It's been a few weeks, just wanted to check in that the solution worked for you. If you're still having the issue, please let me know so that I can investigate further.

Regards,

Philippe Paré

signaturesignature

Clock22 days

It seems to have made things much more stable. There are no longer sessions where it just crashes RDM. Much less frustrating to use. Thanks for the help.

Clock21 days

Hey Philippe,

same for me - the application doesn't crashed anymore - if it happens again I'll post it here.

Thanks!

Regards,
Min

Clock21 days