Forum / Remote Desktop Manager - Support

SSH "interactive authentication in terminal" now broken in 2019.1.20.0

  • Create an Issue
  • Cancel

Today we upgraded our environment to 2019.1.20.0 with the requisite DB upgrades which make downgrade difficult. Now I am unable to launch an SSH session when interactive auth in terminal is set. Unfortunately, that's all of our configured SSH connections, so in order to fix it I would have to go around and reapply the template to a couple hundred connections, for my sub-team anyway.

Please advise if this is a new bug or perhaps an upgrade bug somewhere along the line.

Thanks

Clock3 mths

I forgot to actually include the error, I suppose that would help.

The box says (because screenshots are hard):

An unknown SSH error was encountered.
Disconnecting

Clock3 mths

Hi,

I would need the logs of the connection: in the "Advanced" tab, check "Verbose", check "Enable logging", set "Log path" to where you want the log to be saved, "Log mode" must be set to "Event".
Please, attempt a connection and post the resulting log. It would also be helpful if you could tell me what is the server you're connecting to.

After that, you can go to "File -> Options -> Terminal" and check "Use legacy terminal" at the bottom of the page. This should get you going while I find the problem. We are in the midst of changing our SSH implementation in order to get more control over it. It has been running for a while on RDM for Mac, but it seems it hasn't encountered all scenarios yet.

Regards

Denis Vincent

signaturesignature

Clock3 mths

I am connecting to a CentOS 7 system, pretty standard config. Here's the log from a failure:


[5/15/2019 9:57:03 AM] Setting up connection
[5/15/2019 9:57:03 AM] Connecting as paugie
[5/15/2019 9:57:03 AM] SSH banner: SSH-2.0-OpenSSH_7.4
[5/15/2019 9:57:03 AM] Sending kex init
[5/15/2019 9:57:03 AM] Received kex init
[5/15/2019 9:57:03 AM] Selected algorithms: curve25519-sha256, ssh-ed25519, chacha20-poly1305@openssh.com, chacha20-poly1305@openssh.com, implicit by cipher, implicit by cipher, none, none
[5/15/2019 9:57:03 AM] Sending Ed25519 kex init
[5/15/2019 9:57:03 AM] Received Ed25519 kex reply
[5/15/2019 9:57:03 AM] Successfully authentified server
[5/15/2019 9:57:03 AM] Sending new keys message
[5/15/2019 9:57:03 AM] Sending userauth service request
[5/15/2019 9:57:03 AM] Received new keys message
[5/15/2019 9:57:03 AM] Received service accepted message
[5/15/2019 9:57:03 AM] Sending userauth init request
[5/15/2019 9:57:03 AM] Received userauth failure: publickey,gssapi-keyex,gssapi-with-mic,password
[5/15/2019 9:57:03 AM] No authentication method available
[5/15/2019 9:57:03 AM] The server does not accept interactive authentication
[5/15/2019 9:57:03 AM] Disconnecting

And the 'pertinent' part of the logs from a successful login with the interactive option turned to default:


[5/15/2019 9:59:46 AM] Received userauth failure: publickey,gssapi-keyex,gssapi-with-mic,password
[5/15/2019 9:59:46 AM] Starting password authentication
[5/15/2019 9:59:46 AM] Sending userauth password request
[5/15/2019 9:59:46 AM] Received userauth success
[5/15/2019 9:59:46 AM] User authenticated successfuly by password
[5/15/2019 9:59:46 AM] Sending session channel open request: 0/-
[5/15/2019 9:59:46 AM] Received global request: hostkeys-00@openssh.com , no need to reply
[5/15/2019 9:59:47 AM] Received channel open confirmation: 0/0 WS 200000/0 MPS 32000/32768
[5/15/2019 9:59:47 AM] Sending pty request: 0/0 xterm
[5/15/2019 9:59:47 AM] Received channel success: 0/0
[5/15/2019 9:59:47 AM] Sending environment variable request: 0/0
[5/15/2019 9:59:47 AM] Received channel success: 0/0
[5/15/2019 9:59:47 AM] Empty X display name
[5/15/2019 9:59:47 AM] Cancelling X forwarding
[5/15/2019 9:59:47 AM] Sending shell request: 0/0
[5/15/2019 9:59:47 AM] Received channel success: 0/0
[5/15/2019 9:59:49 AM] Sending channel close request: 0/0
[5/15/2019 9:59:49 AM] Received channel exit signal: 0/0 HUP
[5/15/2019 9:59:49 AM] Received channel close request: 0/0
[5/15/2019 9:59:49 AM] Channel is closed: 0/0
[5/15/2019 9:59:49 AM] Disconnecting

Looks like RDM doesn't like it when SSH key auth fails and it doesn't revert to password auth.

Clock3 mths

Ok, I think I understand the problem, it might take me a few days to fix this. I'll inform you when it's done.

Regards

Denis Vincent

signaturesignature

Clock3 mths

Hi,

In the last version of RDM (2019.1.25.0) if interactive authentication is enabled and the server does not support it we will try to connect to the server with an alternative connection type. The same as Putty is doing.

Regards,



David Grandolfo

signaturesignature

Clock2 mths