Forum / Remote Desktop Manager Mac - Support

Keyboard layout RDP switch PC layout to MAC layout

  • Create an Issue
  • Cancel

Hi,

On RDP connections we have the problem that the MAC keyboard layout switching to PC Layout. For example, i use Hungarian MAC keyboard on my macbook pro, and if I login to RDP we have set Hungarian keyboard on windows, that works well. We have also set invert for "í" to '0," work too.
But all others ALT combined keys works as PC keyboard layout, not MAC as layout. How can i set on windows to use MAC layout for ALT key combinations?

On MAC Hungarian layout Option + Q = @, but on RDP we get "\" instead (This is Hungarian PC layout, not MAC layout).

Thanks for any help.

Clock6 mths

Hello,

I have moved your thread in the RDM Mac support section.

About your issue, in the properties of your RDP session, in the Local Resources tab, have you checked the Windows Key Passthrough option?

Best regards,



Jeff Dagenais

OFFICE CLOSURE!
Although our various support queues will be monitored for emergencies, Devolutions' offices will be closed on October 14th 2019.

signaturesignature

Clock6 mths

Hi,

The default behavior of the RDP session is to use the Keyboard Layout of the remote session. Hence why you are getting result corresponding to a Windows Hungarian keyboard layout.

If you really want your local keyboard layout to be used, you might have some luck with the "Send Input as Unicode" option. You can enable this on a per session basis in the RDP configuration under Microsoft Remote Desktop (RDP) -> Local Resources -> Keyboard.

I'm working at this moment in adding a global setting for this option in the Preferences.

Please tell me if this resolves your issue.


Best regards,

Xavier Fortin

signaturesignature

Clock6 mths

Hi

I have tried both options "end Input as Unicode" and "Windows Key Passthrough" but not work. On RDP i have PC layout.


Any other options?


Thanks.

Clock6 mths

Hi,

Can you tell me the layout your using on both your Mac and your remote Windows? And a combination of keys you are using that do not behave as expected? I'd like to properly reproduce the issue. This might be a limitation.

Best regards,

Xavier Fortin

signaturesignature

Clock6 mths

Hi Xavier,

We use Macbook pro 2018 Vega 20 with Hungarian keyboard, on remote site (RDP) we use Windows Server 2012-2016 with Hungarian Keyboard settings as default.

Keyboard combinations for example:

Option + "Q" = "@" on RDP is this "\"

Option + "." = "" on RDP is this ">"

On RDP we have Hungarian PC keyboard Layout.

Clock6 mths

Hi,

The characters inputted through an Option + Character combination were not handled by the "Send input as unicode" option. This has been fixed.

Please note that keys sending stand alone accent characters (´, `, ˆ, etc.) will not work with the "Send input as unicode" option because of limitation in the way macOS handle such characters.

Also, the "Send input as unicode" option only works with the modern engine of RDP.

You can expect this fixed in the next release of RDM Mac.
Best regards,

Xavier Fortin

signaturesignature

Clock6 mths