Forum / Remote Desktop Manager - Beta

RDM 2019.1 bugs

  • Create an Issue
  • Cancel

It is - sorry for not mentioning that. Thanks David.

Clock8 mths

some weird graphical artifacts in 2019.1.9.0 / text getting cut off.
image

Clock7 mths

Hello,
I've made some fixes for that.

Thank you.

Regards

David Hervieux

signaturesignature

Clock7 mths

I'm having an issue in 2019.1.9.0 where the entire interface locks. I can still work within the RDP session with the current focus, but nothing else works. I have to open Task Manager and force Remote Desktop Manager closed and open it new. I've had this happen 3 times in the last 30 minutes.

Clock7 mths

@zim2323,

Do you have something relevant in Help -> Application Logs?

Do you have something in Event Viewer regarding those locks?

Best regards,



Jeff Dagenais

signaturesignature

Clock7 mths

Yes!

I have the following in 6 separate events from today. Listed as type "Error Silent".


System.Reflection.ReflectionTypeLoadException: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.
at System.Reflection.RuntimeModule.GetTypes(RuntimeModule module)
at System.Reflection.Assembly.GetTypes()
at Devolutions.RemoteDesktopManager.Managers.AddOnManager.Load()

I've also noted that I only seem to get these locks when opening more than 1 RDP session. I've had a single session open for several hours without issue so far.

Thanks!
Chris

Clock7 mths

@zim2323,

Are your RDP session embedded or Undocked in a separate window?

Regards,

Alexandre Roy

signaturesignature

Clock7 mths

Always embedded.

Clock7 mths

@Zim2323

Just a quick question, which version did you update RDM from and which theme were you using before?

regards,

Alexandre Roy

signaturesignature

Clock7 mths

Upgraded from 14.1.3.

Theme is same I've used for the last 3-4 years. Default - Light

Clock7 mths

@zim2323,

I've reproduced the issue you have but in a different scenario, if you uncheck the option *Use Manual tab activation* in File > Option > Advance, It might just solve your issue.

Regards,

Alexandre Roy

signaturesignature

Clock7 mths

This change seems to have worked. I'll continue to test and if there are any additional issues I will report back.

Clock7 mths

the message box is to small at least for the german text.

gs01327

https://www.gpunktschmitz.com

gs01327.png
Clock7 mths

Thank you. This is now fixed internally.

David Hervieux

signaturesignature

Clock7 mths

Here's the About screen on 2019.1.11.0:

image

Clock7 mths

This is strange. It was supposed to be fixed. I will double check what could be the problem.

Regards

David Hervieux

signaturesignature

Clock7 mths

Really strange - here is everything fine:
image

Regards,
Min

Clock7 mths

@Min
I pushed a fix in the meantime smile

David Hervieux

signaturesignature

Clock7 mths

@Alexandre Roy

I have had another hard lockup of RDM this morning. I upgraded to 2019.1.11.0 prior to this issue. I have been working fine with multiple embedded RDP sessions open until this mornings update. I verified that Manual Tab Creation is still checked in Advanced settings.

Chris

Clock7 mths

@Zim2323

So the option reactivated after the update ? if so we're gonna correct that for the next update.

Regards,

Alexandre Roy

signaturesignature

Clock7 mths

@Alexandre

No, options stayed activated through upgrade. You had me enable that option, which seemed to help until the latest update. I have had 2 more lockups since my last msg.

Clock7 mths

@Zim2323

I think we misunderstood each other, I assumed the option was *Checked*, so I asked you to uncheck it. I guess that did not fixed the issue after all...

Sorry I should have been more clear.

I'll keep investigating.

Regards,

Alexandre Roy

signaturesignature

Clock7 mths

@Alexandre

Ah, sorry I misunderstood. I'll uncheck and see if that helps in this newer version.

Clock7 mths

The issues with the 'About' screen appear to be resolved in 2019.1.12.0 and the UI issues with the add-ons interface.

Clock7 mths

Hi,

i have many issues with all 2019.1 Beta Versions:

- SSH is very slow every Keystroke have 1 second delay ( can only use putty as SSH Session without issues).

- active Agent-Key / Agent Forwarding and Setting Repository Credentials in a SSH Shell Sessions i got an error and i cant connect (unknown Error Disconnecting). If i remove Agent Settings in the Session, Login is possible

- In Rebex SSH every Key-Stroke will show 2 times ( Type "htop" on the terminal i see "hhttoopp" but with ENTER htop is running), and is also slow..


The most Settings are default

in 14.X all is working.

Done:
- reset RDM
- create new sessions

- Test on another computer

same behavior


Regards,
Sebastian Mendyka

Clock7 mths

@systemadministration,

Could you test an option for us please. If you go in File -> Options -> Types -> Terminal and check the Use Legacy Terminal option, is it like in RDM 14?

Best regards,



Jeff Dagenais

signaturesignature

Clock7 mths

@Alexandre

I am now seeing intermittent lockups with only a single embedded RDP session open. I have tested on 2019.1.11 and 2019.1.12. I've tried with manual tab activation both on and off. Definitely worse with it CHECKED.

Chris

Clock7 mths

@Zim2323

I'm sorry to hear that, I personally did not encounter the issue yet. Could you send me your remotedesktopmanager.cfg file at aroy@devolutions.net?

Follow these instruction before sending it to me. https://help.remotedesktopmanager.com/howto_configurationfile.htm

I want to reproduce this issue as fast as possible to get it fixed.

Regards,

Alexandre Roy

signaturesignature

Clock7 mths

Jean-Francois Dagenais wrote:

@systemadministration,

Could you test an option for us please. If you go in File -> Options -> Types -> Terminal and check the Use Legacy Terminal option, is it like in RDM 14?

Best regards,


Thanks, yes all is working now like RDM 14

Clock7 mths

@systemadministration,

I had a chat with our engineering department and we would like to test something for us if possible.
Please note that you would need to unchecked the Use Legacy Terminal option in File -> Options to accomplish this.

Firstly, we would like you to enable the Verbose option and Enable Logging option in the Advanced tab of your SSH Shell session.
When this is done, could you reproduce the slowness connection issue. Then, send us the logs please.

Secondly, could you enable the same settings for the ssh session that is falling with the agent settings and for the connection that is working without agent setting.
Then, send us the logs please.

In conclusion, for SSH Shell Rebex issue, is it possible that the Local Echo option is set to On? Could you uncheck it?
2019+04+02+11+22+03

Best regards,



Jeff Dagenais

signaturesignature

2019-04-02_11-22-03.png
Clock7 mths