Forum / Remote Desktop Manager - Support

Restrict permission on Open Session

  • Create an Issue
  • Cancel

Hi,
Here is my problem.

I have a SSH connection defined in RDM. This SSH is using Credential based in the repository and everyting is working fine.

If I have a different user that don't have access to the credential (Cannot view the credential), if he try to open the session he is getting message to provide the username and password. So this is correct.

But if I have a user that can see the credential but can not view the password he can still use the SSH session. I would like to be able to prevent someone to use "Open Session" if he don't have permission to view the password of the attached credential.

Is it someting possible?

Regards,

Martin

Clock6 mths

Hello,
Have you tried to remove the Execute right on the credential entry?

Regards

David Hervieux

signaturesignature

Clock6 mths

Yes,
Even when setting "execute" permission to Never i am still able to use "Open Session"


Regards,

Martin

Clock6 mths

Hello,

Thank you for the information, we'll take a look at the issue.

Regards,

Hubert Mireault

signaturesignature

Clock6 mths

Hi,
I solved my problem.

The problem was that the server I was using to run some test was running RDM version 13.6
After upgrading it to version 14 I am now getting error message "You don't have enough rights to perform this action" when I set the execute permission to "never".


Regards,

Martin

Clock6 mths

Thank you for the information, if you encounter any other issue, please let us know.

Regards,

Hubert Mireault

signaturesignature

Clock6 mths