Forum / Wayk Now - Bug Report

Wayk Now 3.0.3 Connection is just a black screen

  • Create an Issue
  • Cancel

I have both versions at 3.0.3 and when i try to connect, unattended mode, the screen is just black, it is connected but I do not see anything.
Thanks!!

Clock8 mths

Hello

As a first troubleshooting step, can you try the connection without using the unattended service?

Login to the remote machine, and stop the unattended service - either by running `net stop wayknowservice` from an elevated command prompt, or stopping the "Wayk Now Unattended Service" from Services.msc.

Then open the Wayk Now client (or restart it, if it was already running). Once it comes online, it will have a new Wayk ID to connect to.

Now try to connect to the remote machine again.

To be clear, I am not proposing this as a solution to your issue, but I would like to understand if the problem lies in the client, or the capture from the unattended service.

If the issue still occurs, you can capture a log file from both the local and remote machines by setting the log level to "Debug" (in the Options window > Advanced > Logging Level). Then recreate the problem (by opening a new connection). The log will be saved in %APPDATA%/Wayk/logs, and it will be helpful if you can share them - for both the client and server - either here, or via support@devolutions.net.

Thank you, and sorry for any inconvenience

Richard Markievicz

signaturesignature

Clock8 mths

Hello

I saw that you posted in both the Bug Report and Support forums - to save on confusion, I merged the two threads into this one.

Thanks.

Richard Markievicz

signaturesignature

Clock8 mths


Hi,

I am having the same problems logging into the remote machine is a black screen.

Please let me know what I can do.

Thanks!
Erick

Clock2 mths

Hi Erick

Sorry to hear about the problem.

Can you tell us some more about your remote machine? Is it running Windows, or some other platform? Did you run the installer, or are you using the portable .exe?

Following the advice given to the original poster would help us diagnose the problem - if you can follow the instructions and capture a log file, it will be very helpful.

Thanks and kind regards,

Richard Markievicz

signaturesignature

Clock2 mths


Hi,

The remote machine is running windows 8. Currently, I have the portable .exe running on the remote machine.
I am running both end points on unattended mode.

Please find attached, the log I have from my local machine.

I have no access to the remote machine log just yet.

Thanks!
Erick

WaykNow.log
Clock2 mths

Hello

Can you confirm that the remote machine was installed using the .msi? (The unattended mode specifically has to be installed, rather than using the standalone .exe).

As I expected, the log from the local machine doesn't show much. The issue is at the remote end.

I see a couple of possibilities here; but it seems likely we are failing to capture the remote machine's desktop. If you have command-line access to the remote machine, you can try to disable hardware accelerated capture. From an administrator command prompt:

net stop wayknowservice
wayk-now config --global DxgiCaptureEnabled false
net start wayknowservice

Of course, once you have access to the machine, you can use an administrator command prompt to enable logging:

net stop waynowservice
wayk-now config --global LoggingLevel 1
net start wayknowservice

Reproduce the issue, and send us the logs from %PROGRAMDATA%\Wayk\NowService.log, as well as %TEMPDIR%\NowSession.log (if it exists, it may not).

It is also possible the logging onto the machine and restarting the service may resolve the problem, if it is just a transient issue. In this case you can leave the logging enabled and if the issue reoccurs, we will have a log file. LoggingLevel 1 is equivalent to setting DEBUG in the UI, and the log should not grow too large. You can turn it off again by setting LoggingLevel 6.

Thanks and kind regards,

Richard Markievicz

signaturesignature

Clock2 mths


Hi,

I just installed the .msi on the remote machine and I have teh same black screeen issue.

Please find attached the log in the remote machine.

Thanks!

WaykNow.log
Clock2 mths

Hello

Thanks for providing that. It doesn't offer much insight, since the capture is hosted in a separate process.

Can you check for the file C:\Windows\Temp\NowSession.log (I apologise - I mistakenly wrote the wrong path in my earlier post), and if it exists, post it here?

Can you try to disable the hardware accelerated capture and see if that resolves the issue? From an administrator command prompt on the remote machine:


net stop wayknowservice
wayk-now config --global DxgiCaptureEnabled false
net start wayknowservice


Thanks and kind regards,

Richard Markievicz

signaturesignature

Clock2 mths


Please find attached the file:


NowSession.log
Clock2 mths

Hello

Thank you for sending that. There is a message logged relating to the graphics capture, which may or may not be related, but we need to rule it out as the cause of the problem.

Can you follow the steps in my previous post to disable hardware accelerated capture, and see if the problem persists?

If the problem does persist after following those steps, please provide the updated NowSession.log file.

Thank you and kind regards,

Richard Markievicz

signaturesignature

Clock2 mths


The problem went away after I followed those steps. I was able to see the remote machine. However the remote machine was unresponsive when I try to control it. maybe I had a slow connection. Then I got a timeout error on the screen and got diconnected.

Please see attached log.

NowSession.log
Clock2 mths

Hello

Thanks for that information and your continued patience while we debug the issue.

It does appear that there is an issue with hardware accelerated capture on your remote machine. However, I would expect things to work well with that setting disabled, as that was the default prior to 3.3.0.

What is the display configuration of the remote machine? Does it have multiple monitors attached? What are their resolutions?

Can you try to see if changing the codec on your (client) side has any effect? In your Wayk Now Options, navigation to "Performance". The "Preferred Codec" is probably set to "Automatic". Try changing it to "JPEG". Please also check that the quality mode is "Low" or "Medium".

Thanks again and kind regards,

Richard Markievicz

signaturesignature

Clock2 mths