Forum / Devolutions Password Server - Support

DVLS 5.0.2 Upgrade Procedure

  • Create an Issue
  • Cancel

Hi,

as I was Out-Of-Office for a year, nobody in our company touched RDM & DVLS Hammer Time


Guys, can you plz tell me how much steps are needed to upgrade our system to latest DPS & RDM?
(Because maybe you remember my last upgrade problems causing db-corruption & v-folders & performance-breakdown - Erica does for sure)

Our systems:
Win 2012 R2
DVLS 5.0.2
DomAuth with UPN

Clients: RDM 13.5.6.0

I'll try your suggestions on test-environment first.

thx!

Best Regards
Markus

======================

Clock8 mths

Hello,

We strongly recommend following the instructions on this online help page: Upgrading Devolutions Password Server

We also offer free remote session to assist you during the upgrade process of your DPS instance. In regard of the previous upgrade issue you had, if you would like to book a session, please send us an email at ticket@devolutions.net and we will send you a calendar link.

Best regards,



David Grandolfo

signaturesignature

Clock8 mths

Hi David,

thank you for your response.

I already read the help page, but it doesn't clearly answers my question.Read Report

Do I have to upgrade step-by-step through every release mentioned or can I upgrade from 5.0.2.0 directly to 6.1.x.x

Help page only says upgrading TO, not explaining upgrading FROM Quiet

Best Regards
Markus

======================

Clock8 mths

Hi,

You can upgrade DPS from 5.0.2.0 to 6.1.3.0. We recommend, as any update, to perform/test a backup before.

Installing .Net Framework 4.7.2 on the servers and computers before the upgrade will also save you a lot of time.

Best regards,



David Grandolfo

signaturesignature

Clock8 mths

Hi,

David, thx.

Is RDM 14.1.3.0 fully supported with DVLS 5.0.2.0?

If it is, I can upgrade Clients first and then directly update Server to DPS 6.1.3.0.

If not, which version of RDM is the last with full support for DVLS 5.0.2.0?

Best Regards
Markus

======================

Clock8 mths

Hi Markus,

The latest version for 5.0.2.0 is RDM 13.5.6. But RDM 13.5.6 is not recommend running with DPS 6.1.3.0. While it might work, it's not recommended

Due to the large gap between DPS 5.0.2.0 and 6.1.3.0, we can't recommend any RDM client supporting both DPS 5.0.2.0 and 6.1.3.0.

If you cannot upgrade DPS and RDM in a single maintenance period, multiple options are available. Two of them are:

  • Upgrade RDM and DPS twice, by using versions that work fine together.
  • Another option could be to push on each computer a portable version of RDM 14.1.3
  • -- Then update Devolutions Password Server.
  • --When DPS is updated to the latest version, the users received an email that now they need to use the portable version (probably a shortcut on the desktop).
  • --And as a final step which can be on multiple weeks is to replace the old installed version with the portable edition.

The second options require a good preparation and we can help you for this.

Also a good trick to be sure user never use not autorize version is to use the Version Manager feature under Administration-- Data Source Settings.
Further detail at https://help.remotedesktopmanager.com/datasourcesettings_versionmanagement.htm

Best regards,



David Grandolfo

signaturesignature

Clock8 mths

Hi David,

thank you for your guidance. It is very helpful, as my boss wanted to do the one step upgrade, but I was sure it won't be compatible.

Yes, it's bad that they. haven't updated the releases, so I'll have to prepare for the mentiined options...

I'll get back to you if there is anythink unclear.

Best Regards
Markus

======================

Clock8 mths