Forum / Remote Desktop Manager - Support

RDP connection resize when switching windows monitors

  • Create an Issue
  • Cancel

Hi,

we have the problem, that when using rdp connections with a fixed screen size,
RDM automatically changes the screen size, when resizing the rdm window or moving the RDM window to another monitor.

2019 01 10 15 22 49 Remote Desktop Manager

On the first connect the rdp window has the right screen size.
After maximizing or minimizing the RDM window it automatically reconnects the rdp session and changes the display resolution.

We need the rdp session to keep it's display resolution, even on moving the RDM windows.

Thank you.

RDM 14.0.6.0 MariaDB

RDM 14.0.6.0 64-bit - MariaDB - Windows 10

Best Regards
Jonas

2019-01-10 15_22_49-Remote Desktop Manager.png
Clock3 mths

Hello,

I suspect that the option selected in the Screen Sizing mode field is Scrollbar.

Have you tried Smart Reconnect or Smart Sizing to see if it's the same behavior with these options?

Best regards,



Jeff Dagenais

signaturesignature

Clock3 mths

Hi,
when using Smart Reconnect it resizes the window and changes the screen resolution.
When using Smart Sizing it stretches and shrinks the screen image of the rdp session.

So, Scrollbar is not working as expected.

RDM 14.0.6.0 64-bit - MariaDB - Windows 10

Best Regards
Jonas

Clock3 mths

Hello,

I had a chat with one of our expert, Min Destens, and it looks like there's a little bug.

We suspect that the option Screen Size located in File -> Options -> Types -> RDP overwrites the session configuration.
As a workaroun, could you select Scrollbar in that area as well. I think with this configuration, the resolution will now work as expected.

I have opened a ticket to our engineering department to see if something can be done.
The ticket number is DEVO-1524.

Best regards,



Jeff Dagenais

signaturesignature

Clock3 mths

Hello,

FYI, I had a chat with our engineering department and the workaround of selecting Scrollbar in File -> Options -> Types -> RDP proposed in my previous post would be the thing to do for the moment.

They are evaluating what can be done, but it's not easy task to find an appropriate solution for everyone.

Best regards,



Jeff Dagenais

signaturesignature

Clock3 mths

Hi Jeff,

thanks for your reply.
I had a look at the Settings, but there is no option Scrollbar....


2345

RDM 14.0.6.0 64-bit - MariaDB - Windows 10

Best Regards
Jonas

2.png
3.png
4.png
5.png
Clock3 mths

Hello,

You would need to upgrade your RDM to version 14.1.1.0 to get this option.
You can download this latest release here https://remotedesktopmanager.com/home/download

You may have to upgrade the database, so make sure the account that you are using to authenticate on the database the first time after the upgrade has enough priviliges to perform the database upgrade.

Best regards,



Jeff Dagenais

signaturesignature

Clock3 mths

Hi Jeff,
I will do this next weeks.

Are there any news about the bugfix?

RDM 14.0.6.0 64-bit - MariaDB - Windows 10

Best Regards
Jonas

Clock2 mths

Hello,

The solution is to select Scrollbar in File -> Options -> Types -> RDP. As of now, there's no other thing that I can propose.

Best regards,



Jeff Dagenais

signaturesignature

Clock2 mths