Forum / Remote Desktop Manager - PowerShell Repository

Duplicate root creation

  • Create an Issue
  • Cancel

Hi,

Getting the following error since ive upgraded to the latest version:

I have tried CTRL F5 to update the local cache but this hasnt worked.


Devolutions.RemoteDesktopManager.Business.Exceptions.RootException: Duplicate root creation detected!
at Devolutions.RemoteDesktopManager.Business.DataSources.DatabaseConnectionDataSource.DetectDuplicateRoots(Connection root, IDbTransaction dbTransaction, String repositoryId, Boolean update)
at Devolutions.RemoteDesktopManager.Business.DataSources.DatabaseConnectionDataSource.c0cc7f9d508f1ec50318abae3c37f1fc0(Connection cbdc2310dae04de179a24c6e62a14e6e8, IDbTransaction c5a0ca8eaa594113c2f0b3cfe13dedff9, Nullable`1 c6c7922f70bc4ad6a683a9f6baa3f4b7d, Boolean c6d1e4c3cd1ebd972b34fc4a6a144a4e1)
at Devolutions.RemoteDesktopManager.Business.DataSources.DatabaseConnectionDataSource.SaveConnections(IEnumerable`1 connections, IDbTransaction dbTransaction, ISecurityProvider provider, Nullable`1 repositoryID)
at Devolutions.RemoteDesktopManager.Business.DataSources.DatabaseConnectionDataSource.SaveConnection(Connection connection)
Devolutions.RemoteDesktopManager.Business.Exceptions.RootException: Duplicate root creation detected!
at Devolutions.RemoteDesktopManager.Business.DataSources.DatabaseConnectionDataSource.DetectDuplicateRoots(Connection root, IDbTransaction dbTransaction, String repositoryId, Boolean update)
at Devolutions.RemoteDesktopManager.Business.DataSources.DatabaseConnectionDataSource.c0cc7f9d508f1ec50318abae3c37f1fc0(Connection cbdc2310dae04de179a24c6e62a14e6e8, IDbTransaction c5a0ca8eaa594113c2f0b3cfe13dedff9, Nullable`1 c6c7922f70bc4ad6a683a9f6baa3f4b7d, Boolean c6d1e4c3cd1ebd972b34fc4a6a144a4e1)
at Devolutions.RemoteDesktopManager.Business.DataSources.DatabaseConnectionDataSource.SaveConnections(IEnumerable`1 connections, IDbTransaction dbTransaction, ISecurityProvider provider, Nullable`1 repositoryID)
at Devolutions.RemoteDesktopManager.Business.DataSources.DatabaseConnectionDataSource.SaveConnection(Connection connection)

Clock2 yrs

Hello,

What data source type are you connected to? If it is Devolutions Password Server, what version are you using?

Best regards,



Érica Poirier

signaturesignature

Clock2 yrs

Hi
It is a MariaDB datasource, we don’t use a password server.

Clock2 yrs

Hi
It is a MariaDB datasource, we don’t use a password server.

Clock2 yrs

Hello,

Thank you for the information.

Are you using RDM Windows version?

If so, is there a Security Provider configured on your MariaDB data source?

Best regards,



Érica Poirier

signaturesignature

Clock2 yrs

Hi Erica,

Yes we are using the windows version. I am unsure what you mean by security provider?

Clock2 yrs

Hello,

The Security Provider allows to encrypt the data source content. You will find more information about it on the following online help page.
https://help.remotedesktopmanager.com/administration_securityproviders.htm

Are you aware if a Security Provider has been set on your data source?

If there is not Security Provider configured, could you please go in File - Data Sources and create a new MariaDB data source to see if this will resolve your issue?

Also, I will move this thread in the support section as it's not related to PowerShell.

Best regards,



Érica Poirier

signaturesignature

Clock2 yrs

Hi Erica,

Ok i created a new data source ( all datasources are using the standard/default security provider settings).

I have made sure that i am using the correct data source with in powershell. I now get the following error new-rdmsession : Connection has invalid group specified.

If i put it back to the original data source the above error doesnt occur.

Clock2 yrs

Hello,

Do you still get the Duplicate root creation error with the original data source?
If so, within PowerShell, could you please run the Update-RDMUI cmdlet? This cmdlet will refresh the local cache file.

About the Connection has invalid group, you must specify an existing folder in the -Group parameter when you try to create an entry with New-RDMSession.

Best regards,



Érica Poirier

signaturesignature

Clock2 yrs

Hi Erica,

I have never had to create the folder first with new-rdmsession command. Is this something new? Or do i also have an issue with virtual directories?

Clock2 yrs

Hello,

It is a new option that creating virtual folders has been disabled by default because those folders are creating some issues in RDM.

We recommend to create folder entry instead of using virtual folders.

But if you want to allow virtual folders, you need to enable the Allow virtual folders option in Administration - Data Source Settings - General.


image

Best regards,



Érica Poirier

signaturesignature

Clock2 yrs