Forum / Remote Desktop Manager - Support

Issues with screen not refreshing.

  • Create an Issue
  • Cancel

Hi,
We are currently testing Devolutions Remote Desktop manager Free edition in our environment as an evaluation with the team in anticipation of purchasing it. However, we are running into a few issues.

I have used this product at previous companies and I have had really good results with it. However the issue I am having now seems to be new and is making it difficult to get the teams buy off on the purchase.
When working within the application using just a standard RDP session to a remote host, we are having issues with the screen not refreshing the change that we just made. Meaning, if I have a dialog up with (yes, no, cancel) and I click yes, the dialog box doesn't go away. I have to switch off to another tab, and then back for that window to disappear. I have tried changing the RDP version from "Latest", however the issue still happens.


Remote Desktop Manager Free
Version 5.0.5.0 (64 Bit).

Suggestions?

Clock4 mths

Hello,

Would you be able to update to the latest version of Remote Desktop Manager Free and tell us if the issue persist?
https://remotedesktopmanager.com/home/download

Best Regards,



Etienne Lord

signaturesignature

Clock4 mths

Try to use latest version. You might be using old version which is causing this issue.

Clock3 mths

So I have been up to date on the firmware for this product and it is still having the same problem.

As of this morning I have installed 5.1.3.0, however i am not very optimistic as to this problem going away. I have had this issue through, probably, the last 5 updates.
What could I provide to you that would explain the issue so that I could get a resolution?

thanks,
BC

Clock3 mths

Hello,

Would you be able to send us a video of the behavior? I've sent you a link in Private Message, you can use it to send us your video.

Best Regards,



Etienne Lord

signaturesignature

Clock3 mths

I just uploaded a couple Videos.

Clock3 mths

Hello,

Just to let you know, we are still investigating your issue!

Best Regards,



Etienne Lord

signaturesignature

Clock2 mths

Hello,

One thing that I would like yo to test is setting the engine to RDP (FreeRDP 7.0). It's our developped Remote Desktop Protocol that doesn't use the ActiveX. Maybe this could be a solutions for you.
To activate this RDP engine you simply have to go in File -> Options -> Types -> RDP >RDP Drop down menu at the top and switch it to RDP (FreeRDP 7.0).
Let me know if this works for you!

Best Regards,



Etienne Lord

signaturesignature

Clock2 mths

Etienne,
I haven't had a chance to test what you suggested, however I did find an issue on our end that resolved the issue roughly 50%. We were load balancing our Remote Desktop Gateway through HAProxy, which doesn't include UDP traffic. So essentially all the UDP traffic was being blocked, and was potentially causing the issue.
The issue does still arise from time to time, so I will go ahead and test using the FreeRDP.

thanks,
Brian

Clock2 mths