Forum / Remote Desktop Manager Android - Feature Request

WebDAV XML with Encryption Password

  • Create an Issue
  • Cancel

Hello,

I wanted to try to setup a connection to my sharepoint server via WebDAV, but I saw that there isn't a possibility to open a encrypted XML file, because I can't enter a password like for the local XML file.

Could this be implemented soon?

Clock10 mths

Hi,

Just to confirm, you would like us to add a master key to the WebDav data source like Dropbox, DOD, XML?

Best Regards,

Nicolas Dufour

signaturesignature

Clock10 mths

Indeed.

Clock10 mths

Hi,

It has been added to our todo list.

Best Regards,

Nicolas Dufour

signaturesignature

Clock10 mths


Hey, I see now it is possible to enter a encryption key when selecting WebDAV, but it's not possible to open a XML file from SharePoint or I don't know how to.
Where to enter the path, at the file name field? Already tried with / and without before the path

Can you give me advice?

Clock4 mths

Hi,

Can you try to enter a new file name (a file that does not exist) without
a path, save the datasource and add a dummy entry?
The new file should then be created on your server.
We are no SharePoint experts. However, the file location
can help you figure out the correct path to enter.

Please let us know if the new file was created or not.

Also, have you tried to enter /webdav//filename.xml

Best Regards,

Nicolas Dufour

signaturesignature

Clock4 mths


The new file won't be created, it looks like the connection to the WebDAV server isn't working.

(With ES file Explorer it's possible to connect to the server and see my directories.)

Is it possible to connect to a HTTPS (443) WebDAV server?

Is it possible to get a connection log from the phone to see what's the problem?

Clock4 mths


Hi,

When connecting to a HTTPS WebDAV server, please check the following :

-do not include "https://" in the host name (i.e. if the host is "https://myssl.host", simply enter "myssl.host" as the host name)

-make sure that the option "Use SSL" is checked and that the port is 443


image

Best Regards,

Benoît Racine

signaturesignature

Clock4 mths


You can get a connection log by creating a WebDAV session that connects to the server and checking "enable logging" in the entry. Again please make sure the host, port and "Use SSL" option are all correctly configured in the entry. When you open this session, go to the menu at the top right of the screen and select "Show Logs".

image
image
image

Best Regards,

Benoît Racine

signaturesignature

Clock4 mths


My settings looks like yours, but the Master key is under advcanced, I am wondering which version you are using, I am using 2019.1.2.0.
I can't see "Show Logs" because the connection isn't established with the host and this is the problem, so why I cn only show logs if the connection is already successful?

The things I see under Connections is Quick refresh, Refresh and Force refresh.

By the way the quoting link directly over a post is not working, a page comes with: "Sorry, you are not allowed to edit this post" URL: https://forum.devolutions.net/addpost.aspx?TopicID=31016&Quote=129260

Clock4 mths


Hi,


The image that was posted is from our development build. The master key has been moved to the connection tab and it should be available in version 2019.1.3.0. It does not change anything, the functionality is the same.


Quick Connect, Refresh and Force Refresh are all items that are available through the data source. Show Logs is not available from that menu. Benoît suggested that you could try to create a WebDAV session (using the + button at the bottom of the connections' screen and selecting the webDAV entry type). Once the session is configured, save it and open it. The Show logs item will then be available. When you configure the webDAV session, set the verbose level to 1. This will add more information to the logs.


Best Regards,

Nicolas Dufour

signaturesignature

Clock4 mths

If I create a webdav session in a local datasource the connection is established successfully and I can browse the folders and files, but using webdav as datasource is not working with the same settings.

So what now?

Clock4 mths


Hi,

Can we try to connect to your server? That would really help us figure this out (we could use our development tools).
If it is possible, you can send the connection info at: ndufour@devolutions.net

Best Regards,

Nicolas Dufour

signaturesignature

Clock4 mths


Update: The client is now able to connect. The problem was probably related to the data source configuration or to a server setting that was changed.

Nicolas Dufour

signaturesignature

Clock4 mths