Forum / Remote Desktop Manager - Bug Report

14.0.4.0 Variables for $PASSWORD$ and $TOOL_PASSWORD$ doesn't work anymore

  • Create an Issue
  • Cancel

Hello,

since the upgrade to v14 the both mentioned variables doesn't work anymore.

Here the output from RDM 13.6.6.0
image

and here from RDM 14.0.4.0
image

My test strings was:
parrot.bat SITE_DOMAIN: $SITE_DOMAIN$ ; DOMAIN: $DOMAIN$ ; USERNAME: $USERNAME$ ; PASSWORD: $PASSWORD$ ; DOMAIN_DOMAIN: $DOMAIN_DOMAIN$ ; TOOL_USERNAME: $TOOL_USERNAME$ ; TOOL_PASSWORD: $TOOL_PASSWORD$ ;; TENANT: $tenant$

Regards,
Min

Clock2 yrs

Hey Min!

Could you send me the session that you have created to test this behavior? It would be easier for us to test smile

Thanks!



Jeff Dagenais

Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 24th, 2019, to January 1, 2020, inclusively.

signaturesignature

Clock2 yrs

Hi Jeff!

Of course! wink

Based on this article you'll find the session attached smile

Regards.
Min

Variable Test.rdm
Clock2 yrs

Hello,

Does the entry you execute your macro against link to a credential entry? In RDM 14 you have to make sure both your entry as well as the credential entry have the "allow password in variable" option checked. For credentials this is in the "advanced" tab and for entries it's in the "security" tab.

Let me know if this works.

Regards,

Hubert Mireault

signaturesignature

Clock2 yrs

Hi Hubert,

yes exactly - the session credential is set to "Inherited Credential" and on the Parent folder it is linked to a credential entry.
The tools credentials are directly linked to a credential entry

For the credential in the tools section the Allow password variable is already enabled ; for the session credential not - I enabled it but unfortunately it doesn't work either

Regards,
Min

Clock2 yrs

Did you also make sure to enable it on the entry itself (for example your RDP session)? I attached an export of my own setup so you can see what I do. Please note the "allow password in variable" on the two credentials as well as on the RDP entry.

Regards,

Hubert Mireault

signaturesignature

HM Variable Test.rdm
Clock2 yrs

For information, I discussed with Min and there isn't an issue: the VPN on the entry used a credential and that credential had to have the "allow password in variable" option checked.

Regards,

Hubert Mireault

signaturesignature

Clock2 yrs

What He Said

Thanks again for your investigation! wink

Regards,
Min

Clock2 yrs