Forum / Remote Desktop Manager - Bug Report

Logon as another user does not work after update to version 14.0.1.0

  • Create an Issue
  • Cancel

My notebook is not a member of the domain. After the update to 14.0.1.0, RDM try to login with my local account. We always start RDM as administrator with the follow script: "%systemroot%\system32\runas.exe" /netonly /user:domain\%USERNAME% "C:\Program Files (x86)\Devolutions\Remote Desktop Manager\remotedesktopmanager.exe".
But RDM use the local account instead, NOTEBOOKNAME\Jasper. Result: A deny to our SQL datasource.
After downgrade RDM tot 13.5.6.0, everything works as expected.

Can you please fix this issue. Thanks.

Clock25 days

Hi Jasper,

Could you send us print screen ( it could also be by email at ticket@devolutions.net ) of the data source configuration.

Data Source Config

Best regards,



David Grandolfo

signaturesignature

Data_Source_Config.png
Clock25 days

Hi David,

Thanks for your quick reply, I've send you an e-mail with the printscreen of our data source.

Clock25 days

Hi,

Thanks, after a look of your email, I tested on my side and with the command line it doesn't start properly. Even if I have to type my password.

I tried directly with Microsoft "Run As different user" feature and with this it's work properly.

Run AS

After few tests, /netonly is the culprit. Could you try with this command line below:


"%systemroot%\system32\runas.exe" /user:domain\%USERNAME% "C:\Program Files (x86)\Devolutions\Remote Desktop Manager\remotedesktopmanager.exe"

Best regards,



David Grandolfo

signaturesignature

Run_AS.png
Clock25 days

When i try the option " Run as different user", the system gives me the error username or password incorrect. It is not possible to start a program with domain credentials while my notebook is outside the domain. Also, modify the script in "%systemroot%\system32\runas.exe" /user:domain\%USERNAME% "C:\Program Files (x86)\Devolutions\Remote Desktop Manager\remotedesktopmanager.exe" gives the same error, username/password incorrect. The only way to start RDM is with the switch /netonly in the script.
Strange thing: I've downgrade to version 13.6.7.0 and everything works good. When I update to version 14.0.1.0, RDM try to login to the database with my local credentials and gives an error. PC's that are places in the domain works good. On domain PC's, I can modify the script as you described and I can start RDM as a different user. It looks like the problem only appears on PC's outside the domain.

Clock25 days

Thanks for the details, I will investigate the issue on a computer outside of the domain.

I inform you soon.



David Grandolfo

signaturesignature

Clock25 days

Hi,

I made multiple tests and on my Windows 10 (build 1803 - 17134.345) your command (with /netonly) work for RDM 14.0.1 and 14.0.2.

I'm not sure where the issue is coming from but I would like to do more tests. Could you answer the questions below please:

  • Which version of Windows are you running? (Run -- Execute -- type Winver)
  • Could you try with the 64 bits version, in your command just replace remotedesktopmanager.exe for remotedesktopmanager64.exe
  • Could you remove the %USERNAME% variable and type the full domain account you want to connect with (domain\Jasper and please test Jasper@domain)

Best regards,



David Grandolfo

signaturesignature

Clock23 days

Hi David,

Thanks for your reply.

- My Windows 10 version is: version 1803 build 17134.345
- I've try the 64bit version, this makes no difference.
- I've try the following scripts:
"%systemroot%\system32\runas.exe" /netonly /user:j.peursem@domain.nl "C:\Program Files (x86)\Devolutions\Remote Desktop Manager\remotedesktopmanager64.exe"
"%systemroot%\system32\runas.exe" /netonly /user:domain\j.peursem "C:\Program Files (x86)\Devolutions\Remote Desktop Manager\remotedesktopmanager64.exe"
"%systemroot%\system32\runas.exe" /netonly /user:j.peursem@domain.nl "C:\Program Files (x86)\Devolutions\Remote Desktop Manager\remotedesktopmanager.exe"
"%systemroot%\system32\runas.exe" /netonly /user:domain\j.peursem "C:\Program Files (x86)\Devolutions\Remote Desktop Manager\remotedesktopmanager.exe"
In version 13.6.7.0 everything works as expected. In version 14.0.x.x, I receive the error.
DOMAIN\j.peursem is my name for our internal domain.

Thanks for your investigation.

Clock17 days

Hi,

We open an internal ticket for further test and investigation.

For further reference our case number is RDMW-1491

Best regards,



David Grandolfo

signaturesignature

Clock17 days

Hi!
Any news yet? I'm experiencing the same problem since the update to v14 (I'm currently on 14.0.4.0).

Clock12 days

Hi,

Our QA department just sent me note about this case and we aren't able to reproduce the issue internally. We think that it could be a corruption of the data source configuration.

Could you recreate the Data Source Configuration and select the Login type as Integrated security.
Further details in this help topic, https://help.remotedesktopmanager.com/datasource_sqlserver.htm

Regards,



David Grandolfo

signaturesignature

Clock12 days

Hi David,
Here is more info: I added the new datasource and it was working! But then I closed RDM and now it is no longer working.

Here is a screenshot of my user which is added after the update the v14:
image

Clock11 days

Any news on did yet? It is annoying that if need to connect to a domain joined server to have RW access to the DB. With a lot of daily changes, this will be a problem more and more. I already installed 14.0.5.0 but still have the same problem.

I also found another problem with Windows Authentiction problems: https://forum.devolutions.net/topic30681-windows-authentication-feature-not-working-with-dps-rdm-.aspx
But I'm not sure this is the same problem?

Clock9 days

We have also test to add an new datasource, but unfortunately the same problem. Computers in the domain, no problem. Outside the domain, the RDM try to login to the database with my local credentials instead of the domain credentials.

Clock9 days

Do you use Devolutions Password Server or SQL Server data source? I'm asking the question because the related link is onnly for DPS.

Regards

David Hervieux

signaturesignature

Clock9 days

We are using SQL Server data source. OK, then just forget my mention.

Clock9 days

We also using SQL Server.

Clock9 days

@all

Can you please try a few test for me?

1 - Multiple Instances - Make sure RDM allows for multiple instances. File > Options > Advanced > Check "Allow multiple instances". If, on the machine you have v13.x and v14.0.x installed do it to both. Close all RDM, start using runas command.
2018 11 09 7 43 24

2 - Start RDM with your runas commands, make sure to use the /netonly option it's required. Go to File > My Data Source Information, it should look like this.
2018 11 09 7 51 19

3 - Can you please test the runas /netonly using SSMS (SQL Server Management Server) on the machine(s) that are having the issue? Something like (adjust SSMS path as needed):

"%systemroot%\system32\runas.exe" /netonly /user:user@domain "C:\Program Files (x86)\Microsoft SQL Server\140\Tools\Binn\ManagementStudio\Ssms.exe"
Once SSMS started execute the following:
SELECT SUSER_NAME();
You should get the username of the runas user.

2018 11 09 7 58 34

Stefane Lavergne

signaturesignature

2018-11-09_7-58-34.png
2018-11-09_7-43-24.png
2018-11-09_7-51-19.png
Clock9 days

OK, I enabled 'allow multiple instances' and started RDM (with runas /netonly), here is a screenshot:
image
As you can see, it is still using my local credentials.

I do not have SSMS, but I'm using SQL Operation Studio. Here a screenshot of the query:
image

This looks as expected.

In RDM 13 it was working as expected, so it seems something with v14.

Many thanks for working on this!

Clock9 days

Very odd, I can reproduce the issue now... No clue what's changed. Will get back to you when I found out more.

Stefane Lavergne

signaturesignature

Clock9 days

The bug has been resolved locally. We are currently performing validation tests on the version which should be released, as a beta build, this weekend.

Best regards,

Stefane Lavergne

signaturesignature

Clock9 days

That's great news, take your time to fix it and many thanks for your time.

Clock9 days

It is working now! Thanks for your effort!

Clock8 days

I've install 14.0.6.0 beta en confirmed working! Thanks for your support!

Clock6 days

@all thank you for the update

Stefane Lavergne

signaturesignature

Clock6 days