Forum / Wayk Now - Support

Wayk Now : problem with lan proxy

  • Create an Issue
  • Cancel

I got the type of our proxy it is: Symantec SSG900

Clock10 mths

Hi Mario

The 3.1 release is now available for download, and includes the option of using a TCP relay server.

The setting can be found under the "Connectivity" section - you need to enable "Prioritize relay servers for peer-to-peer connections". Note you only need to enable the setting on one "side" of the connection (you do not have to instruct the remote user to change anything).

I would recommend you to give this a try in your environment smile

Thank you for your patience.

Richard Markievicz

signaturesignature

Clock9 mths

Hi, jsut to add: for me 3.1 was still not working.
But I expect I need "explicit proxy support" so I will have to wait a bit longer then.
Let me know if there is something new to test.

Clock8 mths

Hi,

The "Prioritize relay servers for peer-to-peer connections" has explicit proxy support and requires port TCP/8080 outgoing to be allowed through the proxy on both sides. This new peer-to-peer connectivity option requires both the client and server to be using 3.1.0. If it still doesn't work, the first step would be to collect the logs to see if we correctly detected the proxy settings from the system: https://helpwayk.devolutions.net/index.html?kb_logs.htm

Best regards,

Marc-André Moreau

signaturesignature

Clock8 mths

Tried last 3.1 release but I'm still not able to connect via proxy with Wayk, I tried also the new "Prioritize relay servers for peer-to-peer connections" option but with no success.
Here the captured log.

I think you should add a specific proxy option in your program, so we'll be able to "force" some settings here like proxy address, port to use, authentication, socks, etc......

Thanks for your support.

Regards

WaykNow.log
Clock8 mths

Hi,

Looking at the logs, the detected proxy url ("https://" with no hostname and port) appears to be incorrect, causing a connection failure to the proxy. Can you provide more details on what version of Windows (or other OS) you are using, and how exactly the proxy settings have been configured?

Wayk Now searches for "Software\\Microsoft\\Windows\\CurrentVersion\\Internet Settings\\ProxyServer" under HKEY_CURRENT_USER and then HKEY_LOCAL_MACHINE, and parses the registry key value to figure out where the proxy server is. Can you extract both registry keys (if available) such that we can figure out what possibly went wrong with the proxy settings detection?

Best regards,

Marc-André Moreau

signaturesignature

Clock8 mths

The machine is a win10 pro 64 bit pc, my proxy is 192.168.2.232:8080 for web and 192.168.2.232:1080 for socks, our proxy don't use authentication, it checks machine mac address to authorize or not.


Please find attached registry export and internet settings screenshot.

Regards

HKCU.reg.txt
HKLM.reg.txt
win10_internet_settings_proxy.jpg
Clock8 mths

Hi,

I think I can see what the problem is. We currently check for the presence of the ProxyServer registry key in HKEY_CURRENT_USER and then HKEY_LOCAL_MACHINE, and pick the first one available. However, your real settings are stored in HKEY_LOCAL_MACHINE but you have a bogus registry key in HKEY_CURRENT_USER ("ProxyServer"="").

A quick workaround would be to rename "ProxyServer" to something else like "ProxyServerOld" under [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings] such that the ProxyServer registry key from HKEY_CURRENT_USER won't get picked up by Wayk Now.

Best regards,

Marc-André Moreau

signaturesignature

Clock8 mths

OK, I understand, effectively is strange that there's no proxy setting under HKCU, I manually modify the HKCU registry key with my correct proxy setting, enabled the "Prioritize relay servers for peer-to-peer connections" option in Wayk and not it works perfectly !

One suggestion : probably in next Wayk releases is better to check both registry location (HKLM and HKCU) and if one of these locations contain a value for the ProxyServer key (is not empty like in my case....) you should use it for Wayk.

However you make a great program !

Thanks again for your support.

Regards

Clock8 mths

I'm testing Wayknow free 3.2.0 but I get problems using it with proxy, I'm running it on a win7 prof machine, same proxy, same settings, but it's not able to get a valid ID; the message is "Connecting to Waykden......."

I check proxy key in registry and they are ok (HKCU has proxy, HKLM no), I attach here log for debug.
I make also a try with a direct internet connection (no proxy) and the new release works, I remember that old one 3.1.x worked with proxy....


To solve this proxy problems probably is better to explicit proxy setting in Wayknow parameters and use standard TCP protocol to get out, example http, https, etc.....


I have also another bug / feature request : when you connect to a remote machine and the disconnect, on host machine the Wayknow password change immediately, instead with Teamviewer a dynamic generated password doesn't change until you force a manual change or you close and re-run the program.
Probably is better TV in this way because if you lost connection (for example for poor internet connection) then you'll never be able to re-connect to wayknow host because in the meantime the password is changed ! The dynamic generated password for an ID should change only forced or when you run the program with a new istance.


Thanks, regards

HKCU.jpg
HKLM.jpg
WaykNow.log
Clock6 mths

Hello

To answer your question regarding the password auto-reset - this is a security feature, however it is possible to opt-out of that behaviour in two ways:

1 - Set a custom password in the Options window (under Security > Password Type)
2 - There is an undocumented setting to control this as well. You need to add the key "GeneratedPasswordAutoReset" to the configuration file, with a value of false.

You can add the key directly to the config file (%APPDATA%\Wayk\WaykNow.cfg for the standalone client, %PROGRAMDATA%\Wayk\WaykNow.cfg for the unattended service) or execute the following command:

[path-to-wayk-now]\WaykNow.exe config GeneratedPasswordAutoReset false

If you have installed the unattended service, you can use the alias 'wayk-now' and pass the --global switch to configure it system-wide. So, for example:

wayk-now config --global GeneratedPasswordAutoReset false

Note that will require you to run from an elevated command prompt.

I hope that helps, if you have any questions please let us know!

Richard Markievicz

signaturesignature

Clock6 mths

Hello again

With regard to the connection issue, the problem is caused by stricter certificate validation in 3.2 which we didn't test with proxies afterwards. I've opened a ticket for that and will post back here once we have some more information.

In the meantime, the best option will be to continue with 3.1.1. I'm sorry for the inconvenience.

Richard Markievicz

signaturesignature

Clock6 mths

Hello again

We've fixed this issue internally and that will be available in the next release. I'll post back here once that's available. We will validate future certificate validation changes using a proxy server.

Sorry again for any inconvenience,

Richard Markievicz

signaturesignature

Clock5 mths

Hello

Version 3.2.1 is now available and includes a fix for this issue.

Please let us know if you have further questions or problems!

Best regards,

Richard Markievicz

signaturesignature

Clock6 mths

Sorry, but there're still problems with proxy and last release 3.2.1, no connection, no wayk source ID generated, here the log.....

Regards

Clock5 mths

Hi,

Did you forget to attach the logs to your last reply? We did find an issue with the proxy certificate validation (we tested with ccproxy) but it sounds like you are encountering another problem.

Marc-André Moreau

signaturesignature

Clock5 mths

Sorry, here the log

WaykNow.log
Clock5 mths

Hello

Thanks for sending the log through.

Indeed, as Marc suggested, it looks like you are encountering another problem than the one we fixed in 3.2.1.

We did validate 3.2.1 using ccproxy on a test LAN, and it worked well for us. Are you still using ccproxy at your end, or something else?

It's possible that we configured something to prevent breakage on our side, or you are using ccproxy differently to us.

Is your proxy / configuration doing anything like replacing TLS certificates?

What would be really helpful is a Wireshark capture while you reproduce the issue (i.e. start the Wayk Now client, wait a few moments while it tries to connect to Wayk Den a couple of times). If possible, you can send the capture to support@devolutions.net.

Let me know if you have further questions or comments, and sorry once again for the inconvenience. We do appreciate your help while we improve our proxy support.

Thanks,

Richard Markievicz

signaturesignature

Clock5 mths

Hello

We suspect this issue was caused by a proxy server using a custom root TLS certificate. Wayk Now 3.3.0 is now available, and should load custom root certificates from the system certificate store. If you continue to experience issues with the latest version, please let us know.

Thanks and kind regards,

Richard Markievicz

signaturesignature

Clock4 mths