Forum / Remote Desktop Manager - Support

Regular/super users not able to import in root

  • Create an Issue
  • Cancel

Hi all,

I am trying to provide a small group of users more security permissions in Devolutions RDM, lets call them key users. Thinks that they should be able to do are among other import items and add item in Root of a repository/data source.

I have added an Active Directory security group in RDM and tried setting the needed permissions in Role Management screen, Root (Settings) screen and Data Source Permissions. No mater what I set, a user is not able to import or create new items in the root. The only way to add items to root is to promote a user to Administrator privileges.

Also, I was wondering why are there so many places where I can change the permissions for the same item? It's possible to set the same settings in 3 different places.

Clock2 mths

Hello,

which RDM version do you use? Which datas source?

It should work if you

  • create an User
  • create or use a Role (Priviliges Import = Allowed)
  • assign the User to this Role
  • Administration => Root (Settings) => Security => Permissions
  • set Add in Root to Custom and add the Role
If I'm not wrong the permission pyramid looks like following

Data Source Permissions
||
Root (Settings)
||
Roles

So the steps above should work when in

  • Data Source Permissions the Import permission is set to Default or Custom and the Role assigned
  • Data Source Permissions Add in Root permission is set to Default or Custom and the Role assigned
You could assign the permissions also on the Data Source Permission level only and set in Root (Settings) to Default

If the User have RDM already open, CTR+F5 to force the changes - now the Add in Root permission should be available for the User(s) with the attached Role

Tested it on RDM 13.6.6.0 on a SQL data source and it worked as expected

Regards,
Min

Clock2 mths