Forum / Remote Desktop Manager - Support

Chrome and Firefox slowness embedded mode after installing Windows 10 1809

  • Create an Issue
  • Cancel

@everyone,

It may be possible that you encounter slowness issues at the opening of Firefox or Chrome embedded after installing Windows 10 1809.

We have been able to reproduce this issue internally, but we are still investigating for a possible solution.

We will keep you post in this topic on further development on that subject.

Best regards,



Jeff Dagenais
Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 25th, 2018, to January 1, 2019, inclusively.

signaturesignature

Clock3 mths

it's more than slowness. RDM completes freezes and/or crashes when attempting to open chrome embedded sessions.
I have to resort to ending the RDM process in task manager to clear the issue.

Clock3 mths

This has completely disabled my ability to use RDM for the purposes I need it for. RDP and such work, but now all of my browser sessions have stopped working 100% and I can't do anything about it.

Clock3 mths

1809 is full of bugs anyway, otherwise MS wouldn't have pulled it to fix their mess. Always keep a backup of everything.

Always using the latest beta RDM x64 version.
Local data source.

Clock3 mths

After upgrading to Windows 1809 , RDM freezes / crashes.
Solution for me till now : execute RemoteDesktopManager.exe not the RemoteDesktopManager64.exe
Works on latest stable and beta on Windows 1809.
Problem ist known somewhere else in the forum.
EDIT : Link for my solution > https://forum.devolutions.net/topic28929-beta---badmoduleinfo.aspx

Clock3 mths

@everyone,

RDM Beta 13.9.11.0 has been released and this version contain a workaround regarding the google chrome slowness issue in embedded mode on Windows 10 1809.

This latest beta release can be downloaded here
https://remotedesktopmanager.com/home/download#Beta

Once installed, go in File -> Options -> Types -> Web and check the Disable RunDLL32.exe usage option in that area.

Best regards,



Jeff Dagenais
Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 25th, 2018, to January 1, 2019, inclusively.

signaturesignature

Clock3 mths

you mention this is a workaround. Has a root cause been identified and a solution being worked on in a future release?

Clock3 mths

Hello Hazen,

This is actually a good question.

As some of you knows, RDM use a third party library to open Chrome in embedded mode. The library is named EssentialObjects as known as Chromium.

This library uses rundll32.exe and this file is the culprit of the issue on Windows 10 1809.

EssentialObject are working to remove this file from being used in a future version, so when this will be done, no more issues related to rundll32.exe should occur.

Best regards,



Jeff Dagenais
Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 25th, 2018, to January 1, 2019, inclusively.

signaturesignature

Clock3 mths

Interesting. So when they fix their side.. will the "disable rundll32.exe" checkbox disappear in RDM?
Hoping for a quick resolution from EssentialObjects
They seem to be pretty on top of things when I look at their own support forum.

Clock3 mths

Hello,

I cannot confirm if the option will be kept or removed, but I suspect that we will leave it there.

Best regards,



Jeff Dagenais
Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 25th, 2018, to January 1, 2019, inclusively.

signaturesignature

Clock3 mths

Confirming that this workaround works for me.

Clock3 mths

It seems that tabs in Chrome does not open. When you click on a link that opens a new tab, only white window appears.

Clock2 mths

@Nazar,

What version of RDM are you running?

Are you on Windows 10 1809?

Best regards,



Jeff Dagenais
Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 25th, 2018, to January 1, 2019, inclusively.

signaturesignature

Clock2 mths

13.9.14.0 and same issue here (64 bit), 1809

Clock2 mths

@Eric Pelezo,

Could you go in File -> Options -> Types -> Web and enable the Disable RunDLL32.exe option to see if that help.

Best regards,



Jeff Dagenais
Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 25th, 2018, to January 1, 2019, inclusively.

signaturesignature

Clock2 mths

Jeff Dagenais wrote:

@Nazar,

What version of RDM are you running?

Are you on Windows 10 1809?

Best regards,


Yes. Windows 10 1809, RDM 13.9.11.0

Clock2 mths

@everyone,

RDM 14 is now available and can be downloaded here
https://remotedesktopmanager.com/home/download

When this version is installed and that you are on Windows 10 1809, please go in File -> Options -> Types -> Web and enable the Disable RunDLL32.exe option.

Best regards,



Jeff Dagenais
Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 25th, 2018, to January 1, 2019, inclusively.

signaturesignature

Clock2 mths

Nazar Tareyev wrote:

It seems that tabs in Chrome does not open. When you click on a link that opens a new tab, only white window appears.

Same issue. 13.9.14.0
Already have the disable rundll32 option checked.
Don't see the need to upgrade to 14.0 unless there is a definitive fix for this specific issue.

Clock2 mths

Is this being addressed? This is more than just slowness.

New tabs aren't opening. The page opens in the same tab and is just a blank white page. Doesn't matter what site I'm on.
Also, the 'chrome' logo in the tab doesn't spin or give any indication that activity is happening when you click a link. When you click a link (new tab or not) it feels like nothing is happening for a couple seconds until the page link you clicked on begins to load.

Clock2 mths

Hello,

We're currently working on the issue of the tabs not opening properly. I'll let you know once we have a fix.

Regards,

Hubert Mireault

signaturesignature

Clock2 mths

Hello,

We made the fix and now tabs open properly in embedded Chrome. We should have a new version out soon, hopefully tonight.

Regards,

Hubert Mireault

signaturesignature

Clock2 mths

Does this also address the 'chrome logo' spinning during activity?

Clock2 mths

Not for the moment but we're working on this too as well as a few other issues with the Chrome embedded browser.

Regards,

Hubert Mireault

signaturesignature

Clock2 mths

We should have something out for the loading icon in Chrome embedded in 14.0.3.0.

Regards,

Hubert Mireault

signaturesignature

Clock2 mths

Hubert Mireault wrote:

We should have something out for the loading icon in Chrome embedded in 14.0.3.0.

Regards,


Hubert,

Chrome slowness/locked-up issues still exist with RDM 14.0.6.0 and Windows 10 1809 - still having to having set Disable Rundll32.exe Usage.

Any progress on having this fully resolved?

Cheers,
Dale.

Clock28 days

Hello,

Unfortunately, we don't have any news on that. We use a third party for chrome embedded, and our ticket regarding this problem is still opened.

Regards,

Hubert Mireault

signaturesignature

Clock28 days

Hi,

As it has now been over 3 months with the issue what are the plans to correct this issue, is it just to wait for the third party to respond or is there something that you can do like get another plugin or push for a resolution?

My computer automatically updated to the latest version of windows and I did not know about this issue and I used to use the browser functions all day every day, it was the reason I move over to Remote Desktop Manager from other products. I have tried to turn off the rundll32 but all I get is a white page and eventually RDM crashes

Any news welcomed.

Clock2 days

@MR,

I will ask hubert tomorrow if we have some news regarding this from our third party, but I don't think so.

The solution proposed of turning off the rundll32 option is the solution for the moment or you can also open your websites in external mode and use our browser extension to send the credential to the website to get the authentication process done automatically.

Best regards,



Jeff Dagenais
Happy Holiday Season!
Although our various support queues will be monitored during the coming holiday season, Devolutions' offices will be closed from December 25th, 2018, to January 1, 2019, inclusively.

signaturesignature

Clock2 days

Hello,

Unfortunately, the third party's workaround is still to disable the usage of RunDLL32. I'll ask them again to see if they have an update on the real fix and on when they plan to release a new version.

Regards,

Hubert Mireault

signaturesignature

Clock1 day

Hi,

For some reason, the RunDDL32 option does not work for me I just get blank white pages on any chrome or firefox pages which then crash RDM.

I have hundreds of connections that would require me to change them all to external and I haven't been able to get the extension to pass credentials for some reason so a real fix would really help.

Clock1 day