Forum / Remote Desktop Manager - Support

prompted for credentials when using RDP gateway

  • Create an Issue
  • Cancel

Hi,

I am trying to setup an RDP connection using keepass or thycotic stored credentials.

- When connecting directly the connection works perfectly using the credentials stored in keepass and thycotic.
- When seting up a RDP gateway the connection is prompting for the password.


Version 13.5.6.0

Regards
Cédric Jolivet

Clock10 mths

Hello,

How the RD Gateway is configured in your RDP session? Could you post a screenshot of the Connection tab?

Does the RD Gateway use the same credential configured in the remote session to establish the connection?

Best regards,



Jeff Dagenais

signaturesignature

Clock10 mths

Hi Jeff,

I attached the requested screenshot.

Regards
Cédric

rdp_GW.png
Clock10 mths

Hi Jeff,

I found the solution. I will let you tell me if it is a bug or not ;-)

if the RDP connection is setup with display=external and the connection is open using the "open (embedded tab)" button then it works correctly I am not prompt for credentials, if I use the "Open (External)" button I am prompted for credentials

if the RDP connection is setup with display=embedded or undocked and the connection is open using the "open (embedded tab)" or "Open Session" button then it works correctly I am not prompt for credentials, if I use the "Open (External)" button I am prompted for credentials.

I tested it in another environment with the latest version 13.6.7 and the results are the same.

Is it a bug?
Best Regards
Cédric

Clock10 mths

Hello,

It seems to be a bug with the Open External button.

I have opened a ticket and asked our QA department to try to reproduce this issue internally.
The ticket number is DEVO-598

Best regards,



Jeff Dagenais

signaturesignature

Clock10 mths

Hello,

I would like you to test something for us if possible.

Could you go in File -> Options -> Types -> RDP and check/uncheck the Use RDP Gateway generic credentials option to see if that help.

Best regards,



Jeff Dagenais

signaturesignature

Clock10 mths

Hi Jeff,

check/uncheck this option does not change the result with the "Open External" button.

Regards
Cédric

Clock10 mths

Hello,

Thank you for your feedback.

FYI - We are still waiting for our QA department to reproduce your issue.



Jeff Dagenais

signaturesignature

Clock10 mths

Hello,

Could you please open your Windows Credential Manager and verify that no credentials regarding this entry are located under the "Windows Credentials" section? If you find any, please delete them and try to establish your connection once more.
WindowsCredential

Best regards,



James Lafleur

signaturesignature

WindowsCredential.jpg
Clock10 mths

Dear,

Could you give an update concerning this issue?
We are experiencing the same issue when using keepass2 with RD Gateway

Clock6 mths

Hello,

This issue have been solved in the last versions of RDM. Which version of RDM and what type of Data Source are you currently using?
Also, would it be possible for you to provide us a recording of this behavior along with an overview of the configuration of your troublesome entries? This video can be sent to us securely by using the following sharefile link: https://devolutions.sharefile.com/filedrop

Best regards,



James Lafleur

signaturesignature

Clock6 mths

Hi,

We are using the entreprise edition 14.1.3.0.
The datasource we are using is a SQL database.
It looks like RDM can only handle one keepass entry for passwords? So there is no differentiation for TS-password and RD gateway password when both are provided by a keepass?

Clock6 mths

Hello,

Thank you for your reply.

The KeePass credential entry should not act differently than the other types of credentials entries. That being said, I would need to see your current configuration in order to confirm this. Would it be possible for you to record an overview of your entries and also the steps leading to this issue? This video can be sent to us using the following sharefile link: https://devolutions.sharefile.com/filedrop

Best regards,



James Lafleur

signaturesignature

Clock6 mths