Forum / Remote Desktop Manager - Support

$DYNAMIC_PORT$ is always 0

  • Create an Issue
  • Cancel

Versions 4.6.0 64-bit and 4.9.1 64-bit


Hi,

the session variable $DYNAMIC_PORT$ doesn't work correctly. It always resolves to 0 when using a SSH VPN (tunnel) instead of the actual random port.

For testing purposes I used a command line session with the command line "cmd /k echo $DYNAMIC_PORT$".

Regards, Thorsten

Clock2 yrs

Hi Thorsten,

I tested the same scenario as you and the $DYNAMIC_PORT$ refer to port 0 and doesn't take care of the random port. I will have a chat with the engineering department, as I'm not sure about the Command line entry and the variable.

I will do a follow up soon.

Regards,



David Grandolfo

signaturesignature

Clock2 yrs

I had a chat with the engineering department and we were able to confirm the variable $DYNAMIC_PORT$ refers correct results.

That being said, the variable is not in the "Command Line (External Application)" entry. Could you please explain how are you using this variable or where, so we could solve the issue?

If it's easier to send us sessions, let me know and I will send you a secured link by email.

Best regards,



David Grandolfo

signaturesignature

Clock2 yrs

David,

every session has a VPN/SSH/Gateway entry which - when you choose SSH as VPN type - exposes the "use dynamic port" option. The dynamic SSH VPN (= SSH tunnel) works well. Just the variable seems not to get filled. See my screenshot...

SSH VPN settings.png
Clock2 yrs

This is exactly how I reproduce the issue. We could solve the variable resolution, on the other hand, we want to be sure how you use it.

What is the final usage of this variable?

Best regards,



David Grandolfo

signaturesignature

Clock2 yrs

David,

the designated usage of the variable is to "feed" it to a database manager application that we call via command line. The database manager (DBeaver) creates the neccessary connections on the fly (https://github.com/dbeaver/dbeaver/wiki/Command-Line). The database is not accessible from the outside as it is considered best practice. Thus we need a SSH tunnel (VPN) to access the database from the outside.

Regards, Thorsten

Clock2 yrs

Thanks for the precision, I just create a support ticket to solve this issue with the command line entry.

For further follow up our internal ticket is WIN-1300.

Regards,



David Grandolfo

signaturesignature

Clock2 yrs

Hi Thorsten,

In the latest beta of RDM 13.9.8, the $DYNAMIC_PORT$ resolve the proper value.

Beta version could be download from https://remotedesktopmanager.com/home/download , please read the warning of installing a beta version here (https://forum.devolutions.net/topic30381-rdm--beta.aspx ) .

Best regards,



David Grandolfo

signaturesignature

Clock2 yrs