Forum / Remote Desktop Manager - AddOns

VMWare Horizon Client

  • Create an Issue
  • Cancel

Hello,


I'm trying to setup the VMWare Horizon Client, I managed to connect to the server successfully but the remote connection take the whole screen. I checked the Remote Desktop Size in Display option and it is set to Full screen and I cannot change it.


How can I change this setting please?


Thank you,
Tong

VMWareHorizon.jpg
Clock2 mths

Hello,

Which RDM version are you using?
I just tested in RDM 13.6.7 and the option is changeable.

Best regards,



David Grandolfo

signaturesignature

Clock2 mths

Hello,


It's 13.6.7.0 64-bit. Is there any options I have to enable first to get it changeable?


Best Regards,
Tong

Clock3 mths

Hi,


By default the entry is editable, probably something in the configuration block this.
If you create a new entry is the size cannot be change?
What type of data source are you using? (File – My Data source information, use the "send to support" button.)

Best regards,



David Grandolfo

signaturesignature

Clock3 mths

Hello,


Even I create a new entry, the size still cannot be changed.
Using File - My Data source information and then "Send to support" and save it to file, it shows Data source type: RDMS


Best Regards,
Tong

Clock3 mths

Hello,

Could you please send us the report. Because it includes several details that cen help us diagnose.

Best regards,



David Grandolfo

signaturesignature

Clock3 mths

Hello,


I just send the report to you. Thank you for your help.


Regards,
Tong

Clock2 mths

Hi,

Thanks for the report, I found the issue.

With the new VMware Horizon Add-on 2.3.0 (update 2018-09-19), an option block the Full Screen.

If under the Details tab, Star in unattended mode is check the desktop size isn't changeable.
Full Screen Disable

Please uncheck the box and the desktop size should now be good.
Full Screen Enable

Best regards,



David Grandolfo

signaturesignature

Full_Screen_Enable.jpg
Full_Screen_Disable.jpg
Clock2 mths

Hello,


It is now perfectly working. Thank you very much.


Best Regards,
Tong

Clock2 mths

Hi,

Do you have any pop-up with an error? or any error under help -- application log of RDM?

Best regards,



David Grandolfo

signaturesignature

Clock2 mths

Hello,

I had the same problem with the full screen and unchecked the "start in unattended mode" but then the connection doesn't succeed (it works when unattended mode is checked).
Here are the versions I'm using :

image

There isn't anything in the application logs.

Best regards,
Sebastien

Clock12 days

Hello Sebastien,

Initially the full screen option was grey out if unattended mode is check.

I understood that even with the option uncheck the option is still grey out and cannot be modify?

Furthermore it doesn't connect?

Could you detail where RDM disconnect or doesn't connect on the horizon server?

If you have servers/computers log that could help in our diagnostic.

Best regards,



David Grandolfo

signaturesignature

Clock9 days

Hello David,

If the option is unchecked I can modify the remote desktop size option, however it doesn't connect, the connection seems initiated (the open session icon goes green) but then fails.

There wasn't an error in the application log nor in the windows event viewer.

I found a workaround using the "command line (external application)" and the usual command ("C:\Program Files (x86)\VMware\VMware Horizon View Client\vmware-view.exe" -standalone -desktopName "*****" -serverURL ***** -userName ***** -password "*****") I had as shortcuts.

Best regards,

Clock6 days

Hi Sebastien,

Thanks for the explanation, base on your command line here is the way to configure Horizon View entry.

Horizon view

Under General tab you just need to fill (Host, Username and Password)
The major configuration is under Details tab. Here uncheck everything except Standalone, then you fill the desktop name.

That should work properly, could you test it on your infrastructure and let me know?

Regards,



David Grandolfo

signaturesignature

Horizon_view.png
Clock4 days

Thanks David, that works.

Is there a way to choose which client is launched ?
My shortcut went to "C:\Program Files (x86)\VMware\VMware Horizon View Client\vmware-view.exe" but the default for the horizon addon seems to be "C:\Program Files\VMware\VMware View\Client\bin\wswc.exe".

(this would be a bonus rather than a missing functionality)

Clock3 days

Hi Sebastien,

Glad that it's work, regarding the shortcut you can change it in File --> Options --> Path and then change the Vmware Horizon View Path

Best regards,



David Grandolfo

signaturesignature

Clock3 days