Forum / Remote Desktop Manager Mac - Bug Report

High load CPU in the authentication window

Hello.

The problem is always reproduced in iMac 5k 2017. When the authentication window pops up, the operating system starts to run very slowly, processor load 100-130%. After authentication, a large processor load is lost and holds around 20-30%.

P.S.
The problem will not be reproduced on the Mac mini 2012, the processor load is always around 20-30%.


Hardware: iMac 5k 2017
OS: High Sierra (10.13.6)
App: Remote Desktop Manager Free (5.5.1.0)

Снимок экрана 2018-09-14 в 16.05.13.png
Clock7 days

Hi,

This is weird. Especially the fact that it only happens on a iMac and not a Mac Mini.

If you keep the authentication view there without doing anything, does the CPU keep this level of usage? Do you need to close it for it to become normal again?

Best regards,

Xavier Fortin

signaturesignature

Clock7 days

Given the fact that the iMac is much more powerful than the Mac mini, this is very weird. smile

High CPU usage starts immediately after the authentication window. As well as it disappears immediately after I enter the login / password or cancel.


I tried to reinstall the software, but it does not help.
I did installs from both the brew and the dmg image from the site.
The problem is always reproduced.

Clock7 days

Do you have the exact same settings between your Mac Mini and your iMac? More specifically, the settings in the Preferences window under the Session Type -> RDP tab? Could you compare them and tell me of any differences?

Best regards,

Xavier Fortin

signaturesignature

Clock7 days

When connected from iMac, I pre-set the VPN connection using a tunnelblick.
When connected from Mac mini, the local network is used.
But I think that for the RDM application there should be no difference. Or not?

The settings should be the same, I'll take screenshots a little later.

Clock7 days

Well at this point, I'm thinking that what's sending the authentication callback is somehow the issue. So, the VPN might be related (though that's a big might, at this point, I have no clue). Maybe the entire authentication process is more processor intensive in that situation, but that's speculation and would still look weird to me.

When you'll look at the screenshots, could you take the occasion to confirm with me which RDP engine is set (Legacy or Modern).

Best regards,

Xavier Fortin

signaturesignature

Clock7 days

I use only Legacy.
In Modern I do not like the quality of the picture.

Clock7 days

Oh? This is also interesting.

I know I'm nagging a lot here, but could you also provide a comparison of the images between Legacy and Modern when you have a chance (screenshots of both of them)? I'd like to investigate this too.

Best regards,

Xavier Fortin

signaturesignature

Clock7 days

The image on the modern engine seems to me more cloudy. After 10 minutes my eyes start to hurt.
In the settings only the engine parameter was changed: Modern or Legacy.


While I was making screenshots, I noticed one more problem:
After opening and closing the settings and attempting to connect to the server, the authentication window hides behind the main window of the RDM and it can not be called. I had to kill the process.

Legacy.png
Modern.png
Settings.png
Clock7 days

I think I can see what you mean, I actually also see an obvious (when comparing the two side by side) tint differences. I'll take a note to look into this.

For the bug of the authentication window being hidden. Do you have exact steps on how to reproduce it? I can't seem to reproduce it.

Best regards,

Xavier Fortin

signaturesignature

Clock7 days

Yes, yes, the image is different.


For the bug of the authentication window being hidden:

1. Open the application;
2. Switch to full screen mode (^⌘F);
3. Try to connect to the server - there will not be a problem;
4. Open the settings (⌘,);
5. Close the settings;
6. Try to connect to the server - the authentication window does not appear;
7. Using the mission control, drag the application to the desktop and notice the hidden authentication window that can not be called.


I recorded the video for you.

Clock7 days

Hi,

Thanks for those steps! Now I can reproduce. I'll see what's up with that.

Another thing I just thought of (about the high CPU usage). Is Sandboxing enabled in both of your Mac? You can find the setting at the same place you can find the RDP Engine one.

Best regards,

Xavier Fortin

signaturesignature

Clock4 days

Hi,

On both computers set: Activate sandboxing = True

Clock4 days

Hi,

I was forgetting to reply but the authentication window being hidden when the main window is fullscreen and the preferences window was closed is now fixed.

Best regards,

Xavier Fortin

signaturesignature

Clock4 days

Hi,

That's great! Thank you.

When will the updated version be available for download?
I prefer to install the software with a HomeBrew, so I'll wait for the release.

Clock3 days

Hi,

This is a good question. I was waiting for a fix on performances in the RDP Modern engine before going forward with the release. But I might release a version before this, since there is a couple of things in it that users are waiting for. I don't have an exact time yet. It should be somewhere in the next two weeks.


Best regards,

Xavier Fortin

signaturesignature

Clock3 days