Forum / Remote Desktop Manager - PowerShell Repository

Set-RDMSession : Connection has invalid group specified (13.6.2.0)

  • Create an Issue
  • Cancel

I am not able to create new sessions from templates.


$session = New-RDMSession -Group ("Customers\" + $app.customer) -Name ("Customers\" + $app.customer + "\" + $app.name) -TemplateID "8F04F52A-B976-44C8-B819-3996B1D6F2F5" -Type "TemplateGroup"
Update-RDMUI;
Set-RDMSession $session;


Throws: Set-RDMSession : Connection has invalid group specified


Yes the folder for ("Customers\" +$app.customer") exists, I am trying to make new sessions within that folder.

I've seen the thread dealing with this from here https://forum.devolutions.net/topic29416-setrdmsession-throw-connection-has-invalid-group-specified-.aspx
But nothing said there is working for me. As you can see I am using the Update-RDMUI command.
I also do not see the Allow virtual folders option in the Data Source Settings pane.


Is there a different workaround?

Clock2 yrs

Hello,

I reproduced this behavior on my side, I need to see if it's by-design or a bug. I'll get back to you next week

Regards,



Alex Belisle

signaturesignature

Clock2 yrs

Thanks,

A piece to note is this script had worked in the past and was last successfully run without any changes about 2 months ago, so it's likely related to an update that was installed.

Clock2 yrs

Hello,

I realize it's been a while and I haven't gotten back to you. I retried lately, with a newly created template and got it to work. I could not point out the difference between my older template vs my newer one. Do you still experience this issue int RDM 13.6.7?
Have you tried to recreate a template and try to call the same routine?
Sorry again for the delay.
Best regards,



Alex Belisle

signaturesignature

Clock2 yrs

hi!
I just had the very same error using RDM 14.1.3.0

works:
New-RDMSession -Group 'ASDF' -Name 'example.org' -Type 'RDPConfigured' | Set-RDMSession


also works:
New-RDMSession -Group 'ASDF\QWER' -Name 'example.org' -Type 'RDPConfigured' | Set-RDMSession

does not work:
New-RDMSession -Group 'ASDF\QWER\jkl' -Name 'example.org' -Type 'RDPConfigured' | Set-RDMSession
New-RDMSession -Group 'ASDF\QWER\jkl\UIOP' -Name 'example.org' -Type 'RDPConfigured' | Set-RDMSession

how can I work around this issue?

I want to create sessions in 'ASDF\QWER\jkl' and 'ASDF\QWER\jkl\UIOP'

KR
Guenther

https://www.gpunktschmitz.com

Clock12 mths

I've found a workaround:


$session=New-RDMSession -Name 'example.org' -Type 'RDPConfigured'
Set-RDMSession $session
Update-RDMUI
Set-RDMSessionProperty -ID $session.ID -Property 'Group' -Value 'ASDF\QWER\jkl\UIOP'


This works for now, but please let me know if this will be possible with future versions of RDM like:

New-RDMSession -Group 'ASDF\QWER\jkl\UIOP' -Name 'example.org' -Type 'RDPConfigured' -SetSession

KR
Guenther

https://www.gpunktschmitz.com

Clock12 mths

Hello,

I am unable to exactly reproduce your issue if the destination folder already exist in the data source. But if the destination folder doesn't exist, I will get the same error message. Could you please try again the entry creation when all folders exist in the data source?

If I run your working solution when the destination folder doesn't exist, I won't get any error messages but the entry will not move in the destination folder.

For your information, few versions back, we have disabled by default the possibility to create Virtual Folders. Those virtual folders exist in session's properties but don't exist as a record in the database. RDM will still build the folder structure based on the entry's properties. But because these folders don't exist in the database, this can cause some unwanted behavior and/or performance slowness.

We do not recommend this but if you want to use Virtual Folders in your data source, you can enable the Allow virtual folders option in Administration - Data Source Settings - General.

image


Best regards,



Érica Poirier

signaturesignature

Clock12 mths

hi Erica,
virtual folders there were ...


The option to allow virtual folders was not set, but the database was just recently upgraded (from 11.0.5.0).

I found your other post (https://forum.devolutions.net/topic28811-convert-virtual-folders-to-physical-folders.aspx) and ran that script.

Now that there are no more virtual folders the cmdlet works as expected.

Thanks again for your help!

Maybe you could create an internal ticket to convert virtual folders automatically when the database is updated with future versions of RDM.


KR
Guenther

https://www.gpunktschmitz.com

Clock12 mths

Hello Guenther,

Thank you for your feedback and glad that converting virtual folders resolves your issue.

I will definitely transfer your suggestion to the engineering team about automatically converting virtual folders.

Best regards,



Érica Poirier

signaturesignature

Clock12 mths