Forum / Remote Desktop Manager IOS - Support

Apple iPad Smart Keyboard doesn’t work in a VNC session unless the keyboard is selected

  • Create an Issue
  • Cancel

I have an iPad Pro with an Apple Smart Keyboard.

The keyboard is dead unless you press on the keyboard button (bottom right.)

Also the [tab] key is dead.

It would be usefull if the “extra keys” keyboard was much smaller - e.g. keys the
same size as the on-screen keyboard. In a situation where you have a Smart
or a Bluetooth keyboard a much smaller “extra keys” keyboard could be left
onscreen without loosing too much screen real estate. And for the Apple
Keyboard having an escape key easily accessible is a boon for “vi”

...which leads to the next “wish list” item - re-mappable keys. I would re-map
The “`” key to Escape for sure!...

It would be nice if the [Option] key would act as it does on a Mac and gives you
a “right click”. Similarly [Command]C for copy and [Command]V for paste...


I have an Apple Pencil too - if that could be used as the pointing device that would
be super usefull as well (which seems to work to some extent, with my testing so
far.)


Linux supports username and password VNC authentication with TigerVNC (with
the TLSplain security type and PAM) - are you planning to support that?


Thanks for RDM on iOS!

Thanks again,
Tony

Clock2 yrs

Hi Tony,

When opening a remote session if there's any physical keyboard connected to the device the keyboard button will be enabled without the need to toggle it. Could you tell me on which session it was happening?

I've added your key remapping feature to my todo.

I agree the extended keyboard could be a little smaller too.

I've added your features requests to my todo.

Unfortunately, we don't have access to the option key and the tab key on our side. I'll investigate more on this.

When you use the apple pencil are you in touch pad mode in the remote session?

It should be supported I'll try to reproduce your issue.

Best regards

Mathieu Morrissette

signaturesignature

Clock2 yrs

>When opening a remote session if there's any physical keyboard connected to the device the keyboard button will be enabled without the need to toggle it. Could you tell me on which session it was happening?

I connected the keyboard, restarted RDM, opened an "SSH port forward"
then opened a VNC connection over the SSH tunnel. i.e. this is in a VNC
connection.
The keyboard button (bottom left) is selected and the smart keyboard does work.
If I press the "extra keys" button the smart keyboard still works - all good!

...but if I go full screen the keyboard button is unselected & the smart
keyboard is dead. Pressing the keyboard, or "extra keys" button gets the Smart
keyboard working again. If you press the "extra keys" button twice (i.e.
turn on & off) the extra keys screen keyboard the the the keyboard button
is unselected & the smart keyboard is dead again, untill the keyboard button
is pressed.
Exiting full screen also unselects the keyboard button.


> [...]
> When you use the apple pencil are you in touch pad mode in the remote session?

Yes - turning that off made things much better :-)

I wonder if pressing and holding a window (i.e. pencil down and press/hold down)
could enable drag & drop (as opposed to double click & hold down the pencil which
is a lot harder to do!)


Is there a way to stop the connections from dropping as soon as
the iPad screen locks - maybe a background data option for the
app or similar?

Many thanks for help!

Clock2 yrs

Hi,

Thank you for your feedback.

Indeed going into fullscreen or exiting fullscreen resets the keyboard button and it is not supposed to, seems like a bug I'll investigate.

I also added to my todo to add a setting to change the double click to a long press to move a window.

Unfortunately, when locking the device iOS puts the app in pause to save battery which cause the remote session to lose connection and I don't we have the control over that.


Best regards

Mathieu Morrissette

signaturesignature

Clock2 yrs

Dear Mathieu,

It may be possible to get round the disconnections by registering
the App for background fetch

ref:

https://developer.apple.com/library/archive/documentation/iPhone/Conceptual/iPhoneOSProgrammingGuide/BackgroundExecution/BackgroundExecution.html#//apple_ref/doc/uid/TP40007072-CH4-SW23
https://stackoverflow.com/questions/4579810/ios-application-background-downloading

to keep ssh tunnels (and gateways) alive
e.g. sending an SSH "Sever Alive" packet...

VNC updates could be ignored, just request a screen refresh
(ctrl-r maybe?) when the app goes foreground again
I would imagine there is an "opposite" call to applicationDidEnterBackground(_smile
to tell you the app is in the foreground....
https://developer.apple.com/documentation/uikit/core_app/managing_your_app_s_life_cycle/preparing_your_app_to_run_in_the_background


[unrelated] is there a way to have touch pad mode off by default?

Thanks, thanks, and thanks some more :-)
Tony

Clock2 yrs

Hi,

I will investigate on this but I don't think we are able to keep a TCP connection alive when locking the device. The VoIP-Services could be used as a workaround but the app would be rejected by Apple.

What I could do is maybe try to reconnect your remote sessions when coming back from background?

I'll add an option to disable the touch pad mode by default.

Best regards

Mathieu Morrissette

signaturesignature

Clock2 yrs

Dear Mathieu,

Thanks for all your help.

Tony

Clock2 yrs

I am seeing an odd issue with VNC over an ssh tunnel (though the issue may be unrelated to the tunnel)
Characters only appear on screen (remove is an xterminal) when I type two characters i.e. there
are no characters displayed when I type the first character, then both are displayed when I type the
second - any ideas?

Thanks,
Tony

Clock2 yrs

Hi,

It looks like a screen refresh issue. What type of vnc server are you connecting to?

Best regards

Mathieu Morrissette

signaturesignature

Clock2 yrs

Dear Matthieu,

After upgrading to fc28 (for the latest VNC server version) it turns out to be an issue
With xfce-terminal - running a “normal” xterm under the xfce window manager has
normal response. I suspect there is an xfce session option I need to fix to get the
xfce-terminal to behave...

Thanks,
Tony

Clock2 yrs

Hi,

I just released RDM iOS 4.8 which contains a feature to remap ` to Escape and to disable touchpad mode by default in the app settings. (Settings->Sessions)

I also fixed the keyboard stopping working when entering or exiting fullscreen in a remote session.

Best regards

Mathieu Morrissette

signaturesignature

Clock2 yrs

Dear Matthieu,
When I enable the ` to escape keyboard remapping I lose the use of all keys on the keyboard except [return]
This is true of both the Apple smart keyboard and the software keyboard.

WIth the Smart keyboard, if I press the “extra keyboard” button I get the extra keys as expected,
But if I press it again, the “keyboard” button is unselected - this should be selected if the Smart
Keyboard Is connected.

Many thanks,
Tony

Clock2 yrs