Forum / Remote Desktop Manager - Support

How to run Synchronizers automatically?

  • Create an Issue
  • Cancel

I have synchronizers set up to pull in servers from vSphere. They are set to "Synchronize automatically". However, they don't seem to sync when I do a refresh in RDM. I end up having to double-click these to synchronize them. Am I missing something?

Clock10 mths

Hello,

In File -> Background Services, have you enabled the execution of synchronizers?
https://help.remotedesktopmanager.com/background-services.htm


Best regards,



Mark Beausejour

signaturesignature

Clock10 mths

"Enable the execution of synchronizers" is checked,
"Automatic sync" is checked for each synchronizer
"execute automatic synchronize every X minutes" is NOT checked


Does that bottom option need to be checked?

Clock10 mths

Hello,

Yes, if you want your synchronizers to run after a certain period of time automatically, you must enable that option.


Best regards,



Mark Beausejour

signaturesignature

Clock10 mths

Great. I have set that option. Now, is there a way to refresh all other machines (outside of the synchronized ones) on a certain timeframe?

Clock10 mths

Hello,

I'm not sure I understand your question.

Are you looking to refresh the navigation pane to see that new machines are added from the synchronizer?


Best regards,



Mark Beausejour

signaturesignature

Clock10 mths

Nope - ones that the synchronizers add show up fine for ME. My team is using a SQL Server source to share server lists. I am trying to figure out how to get everyone's navigation pane to update AUTOMATICALLY for all servers in the navigation pane, both servers that came from synchronizers, and servers that have been added manually.

Clock10 mths

Hello,

We recommend creating a scheduled task with the command line parameter in the Advanced tab of the Synchronizer.

So in the Advanced tab as you can see below, you can copy the command line and use it in the scheduled task.

image

Please let us know if you need anything else.


Best regards,



Mark Beausejour

signaturesignature

Clock10 mths

Mark,

What is the difference between running a scheduled task on the synchronizer and enabling the "execute automatic synchronize every X minutes" on the background services screen?

Clock10 mths

Hello,

The main difference between both is performance.


The scheduled task is to avoid performance issues since running a synchronizer (especially if you have many) can cause latency and would affect your workflow and all your users.

This is why it's best choose a time with a scheduled task so you can avoid this.


Best regards,



Mark Beausejour

signaturesignature

Clock10 mths

Hi Mark,

In setting up the scheduled task, does the user running the task have to be logged into RDM during the task execution or do only have to have access?

We are wanting a scheduled task to run at 3AM to avoid any performance issues, and were thinking of creating a service account to run the task.

Regards,

Josh

Clock3 mths

Hello,

Sorry for the late reply.

What you can do is create a task in the Task Scheduler that will run a command line.

That command line will in turn make use of our Protocol Handler to execute the process in RDM.

Here's an article on the Protocol Handler in RDM;

https://help.remotedesktopmanager.com/kb_webprotocolhandler.htm

Best regards,



Mark Beausejour

signaturesignature

Clock3 mths

Hey Mark,

I am running this as a scheduled task. However, the synchronization is not working. We believe it is prompting for login in order to sync.

Regards,

Josh

Clock3 mths

Hello,

Thank you for your reply.

If you run the task manually, are you prompted for credentials?

Also, is the user performing the task an Administrator? If not, you can enable the option Enable synchronization by non-administrators in Administration -> Data Source Settings -> Application -> Type Settings;
image

If that doesn't help, Could you please go in File -> My Data Source Information and send us the report? You will see a blue envelope in the report;
image


Best regards,



Mark Beausejour

signaturesignature

Clock3 mths