Forum / Remote Desktop Manager - Support

RDM Agent issue

  • Create an Issue
  • Cancel

@Ron van Elteren

It looks like the issue might be with RDM on the jump server. Could you please enable debug logging on the RDM Jump server, clear the log file and try the jump again.

- File > Options > Advanced > Debug Level > set it to 1025
- Help > Application Logs > Clean Up > Delete all > Delete
- Jump
- send log entries

If this doesn't help, we might have to do a remote session to figure out what the issue is.

Best regards,

Stefane Lavergne

signaturesignature

Clock3 mths

Hi Stefane,

First of all, thank you very much for the extensive help.

Short inventory of our environment :

We have 14 virtual machines (Windows 10) configured as jump hosts, to set up VPN connections to our customers.
These VPN connections can be of any kind, any client (Cisco, SonicWall, Citrix, etc).
These VPN clients are all installed on the virtual machines.

When I set up an entry, using VPN of any kind, I make sure that I am able to manually connect to the customer using the VPN client itself.
Secondly I add the RDP session to the customers's server and test it again.
Once that is working correctly, last change I make is set up the jump to the correct jump server/virtual machine.
Even then I test the connection.
If it works, I move the session entry to another folder within RDM to be visible to our agents/consultants.

Mind you that I have RDM in autostart on the virtual machines/jump hosts AND RDMagent starts automatically.
Each consultants who uses the jump host, will get RDM opening automatically and RDMagent starting automatically.

I have done what you asked me and tested even a little further.

This time I left RDM open on the jump host and simply disconnected, so my session is still there.
From my laptop I started the session entry. It jumped again to the jump host.....and it started the session correctly.

Then I completely logged of the jump host and started again the same session....this time it jumped but wouldn't start the session.

So I have 2 sessions : first one at 15:45:24 where I start the session to the jump host picking up my disconnected session --> it worked
Second one was at 15:46:45 where I started from scratch, making the jump, started RDM automatically but it didn't pick up the session.
Error :


System.Threading.ThreadAbortException: De thread is afgebroken. (translated : the thread is disconnected)
bij Devolutions.RemoteDesktopManager.Business.HttpBrowserLinker.c36e11a71b2027cacbbca5f70b6ed33df()
bij System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
bij System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
bij System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
bij System.Threading.ThreadHelper.ThreadStart()



I really hope you have a solution for this.

Clock3 mths

Another finding :

When starting a session from my laptop, the jump (as said) to the jump host is made but the session won't be picked up by RDMAgent.

However....when manually starting the *.rdmj session in my TEMP folder (which should be picked up by RDM or RDMAgent), the sessions starts and works correctly.

Clock3 mths

And I think I have found the solution !

Problem doesn't occur when I use the 32 bit version of RDM
I changed the shortcut (in Windows autostart) to the 32 bit version and tested 2 different sessions.
Both of them work.

After the weekend I am going to test a little more, also on our other jump hosts.

I'll come back to you about this.

Clock3 mths

Amazing find. I'm not sure why that would be the case, we will investigate on our end. Looking forward to see if that resolves it for all or your hosts & sessions. Please keep us posted. Have a good weekend.

Stefane Lavergne

signaturesignature

Clock3 mths

I've tested some more and can tell you that the 32 bit vs 64 bit is not the problem.

I have found out that the problem is related to my login on the jump host.
When I use another login (test-user) account, exactly the same sessions works perfectly and I haven't changed anything (just the login credentials).

My account is local admin on all virtual machines (jump hosts) and DB owner/administrator in RDM.
When I start RDM with my Windows credentials and start the session, it will automatically log on to the jump host with my Windows credentials and start RDM on the jump host. After the jump, the session is not being picked up by RDM (agent).

When I start RDM on my laptop using different credentials (SHIFT - logon as different user) and log on as a test user (domain user, read-only user in RDM), and start exactly the same sessions --> jump is made, RDM starts as test-user and proceeds without any problem.
Tested this with multiple test accounts, even with another RDM administrator account (a colleague is also administrator in RDM).

It is like my own account is holding wrong information in some kind of cache.

So I tested even more to delete my Windows profile on the jump host in C:\users
When I tried to log back on to the jump host, I got the error that Windows is using a temporary profile to log on.
So it seems that my profile was corrupted.

I corrected that, by editting the registry and delete the pointer to my profile.
Re-started the remote session in RDM which logged me back on to the jump host, my Windows profile was re-created on the jump host and RDM was automatically started.
Once RDM was started, the jumped session was working perfectly again !

So it strongly points to a correct Windows profile and not a RDM (Agent) issue

Clock2 mths

I would have never found that on my own. We will add it to our knowledge base of RDMAgent/Jump issues.

Best regards,

Stefane Lavergne

signaturesignature

Clock2 mths