Forum / Remote Desktop Manager - Feature Request

sftp connection doesn't allow me to edit files

  • Create an Issue
  • Cancel

I am trialling the remote desktop manager free version.

I have created an sftp connection to a server, which opens fine. I then right click on a file and choose 'view'. This opens the file using my local text editor (notepad++).

I make a change and click save. However, the change is not saved when I re-open the file.

The connection was originally imported from winSCP, and then I changed the type to Built-in SFTP. I have also tried setting up the connection from scratch.


If I do the same thing in winSCP directly it works fine (except winSCP calls it edit rather than view). This uses the same login details.

Do I need to enable something somewhere to enable me to edit files?

Clock6 mths

Hello,

This is would actually be a feature addition. I will move your topic to our feature requests section.

An engineer has been assigned to it.


Best regards,



Mark Beausejour

signaturesignature

Customers that use Devolutions Password Server are provided free remote sessions for performing upgrades. Please send a request to the Devolutions Service Desk to get the process started.

Clock6 mths

I'll add a +1 to this feature request. I'm liking what I see so far of RDM - but I also expected (hoped) to see a way to edit files directly using the SFTP connection. This is how a few other SSH clients work (e.g. MobaXTerm) and I'd really appreciate that capability being added. It comes down to some nifty work to allow the remote file to be downloaded.. loaded in to the assigned editor... and when the file is saved back to disk to then push that change back via SFTP.

Clock2 mths

This is in RDM beta and it will be in RDM 14

Regards

David Hervieux

signaturesignature

Clock2 mths