Forum / Devolutions Password Server - Support

Backup error after upgrade to Server 5.0.2.0

  • Create an Issue
  • Cancel

Hello Support,

since i updated Devolutions Server to version 5.0.2.0 im unable to make backups from this machine.

I got this error in Veeam:
30.04.2018 12:07:42 :: Unable to release guest. Error: Unfreeze error: [Backup job failed.
Cannot create a shadow copy of the volumes containing writer's data.
A VSS critical writer has failed. Writer name: [SqlServerWriter]. Class ID: [{a65faa63-5ea8-4ebc-9dbd-a0c4db26912a}]. Instance ID: [{0f9d8991-ff33-48d2-8272-8c6e6f9beba9}]. Writer's state: [VSS_WS_FAILED_AT_PREPARE_SNAPSHOT]. Error code: [0x800423f4].]

I tried to repair the SQL Server installation but this doesn't help.
https://www.veeam.com/kb2326

Do you have any suggestions what i can try to get this fixed?

Thanks,

Ben

Clock2 yrs

Hello,

Are you able to backup the database with SSMS?

Best regards,



Érica Poirier

signaturesignature

Clock2 yrs

Hi,

yes, backup with SSMS works.

Best Regards,

Ben

Clock2 yrs

Hi Ben,

This is a Veeam error so your best bet would be to search the Veeam forums/KB articles for help:

You could try this:
https://forums.veeam.com/microsoft-hyper-v-f25/the-infamous-vss-ws-failed-at-prepare-snapshot-problem-t45123.html

or maybe

https://forums.veeam.com/microsoft-hyper-v-f25/vss-error-0x800423f4-t21720.html

Best regards,

Stefane Lavergne

signaturesignature

Clock2 yrs

Ok, thx.

Clock2 yrs

I installed a new Server and migrated the SQL database to the new server. Backups are working fine now.

But i have some other problems:
I dont recieve any notification emails.
Emailing is configured correctly, i recieve the test email, error emails are working too. And i get notified when i change a emailaddress from a user. But no notifications... scheduler is activated
When I try to activate User --> Add Checkbox it will not save this change.

image

Another thing is, that authentication takes very long. But we had this also before on the old server.
Very long means on windows machine around 30 seconds. And on MacOS sometimes a few minutes.
Do you have any advise where to begin troubleshooting this?

We have over 4500 entries in the database and use AD Groups excessive (over 200 AD Groups).

Thanks,

Ben

Clock2 yrs

Hello,

Could you please try to restart the DevolutionsSchedulerService service to see if this will help to received email notifications?

image

Best regards,



Érica Poirier

signaturesignature

Clock2 yrs

No doesn't help upset
I've setup a new server to investigate our performance issues. And on this fresh installation with Devolutions Server 5.0.2.0 und SQL 2017 i also dont recieve notifications.

Maybe im doing something wrong..... or its a bug.

Clock2 yrs

Hello,

Have you configured the email address of the user account who should receive the email notifications?

Best regards,



Érica Poirier

signaturesignature

userproperties.jpg
Clock2 yrs

yes, there is a email address configured for the users.
On production server notification works until i upgraded from 4.7.0.0 to 5.0.2.0. Didn#change anything and i cannot find the problem.

BR,

Ben

Clock2 yrs

with which account muss the schedule service run? LocalServer or a DomainUser?

Clock2 yrs

ok works. Seems that it needs to be a domainuser with database privilege.

Clock2 yrs

Hello,

You are right, depending on the topology of the DVLS installation, the service account may need database access.
The online documentation has been updated.

Best regards,



Érica Poirier

signaturesignature

Clock2 yrs