Forum / Remote Desktop Manager Android - Feature Request

Support for SQL Azure data source

  • Create an Issue
  • Cancel

Is there a roadmap to add support for a SQL Azure data source?

Clock2 yrs

If I remember correctly the problem is in the Microsoft hands. Xamarin (cross-platform framework from them) does not support encrypted SQL connection which is mandatory on Azure. I could double check the status about that.

Regards

David Hervieux

signaturesignature

Clock2 yrs

Microsoft SQL Azure data sources are currently supported in both the Android and iOS apps. While they don't appear in the list when creating a new data source, you can create a Microsoft SQL data source and then change the server type to SQL Azure. Alternatively you can use the data source export/import feature to import an existing SQL Azure data source from Windows/Mac.

Note that Active Directory logins are not supported for now. It is a limitation of our framework at this time, we do not know when we will be able to support it.

Please tell us if you encounter any issues trying to connect to an SQL Azure data source from a mobile device.

Best Regards,

Benoît Racine

signaturesignature

Clock2 yrs

It seems to allow me to import my data source from RDM Enterprise export (from my desktop) but no connections show up. No errors, but nothing shows up. I can select the data source without errors. So maybe it's the encrypted connection requirement issue.

Clock2 yrs

Hi,

We have created a new SQL Azure database, have upgraded it with RDM Windows and we were able to connect to the database with both RDM Windows and RDM Android.

We have successfully created a SQL Azure data source manually from RDM Android and we can see the connections that we have created in RDM Windows.
We have also tried an export/import of the same SQL Azure data source and we can also see our connections in RDM Android.

There is a firewall setting that you can set on your database on the Azure portal.
Allow access to Azure services has to be turned on and you also have to specify the range of ip addresses that are allowed to access your database.

Have you configured this setting?

Without that setting we were not able to access the database and see our connections from RDM Windows and RDM Android.

As Benoît mentioned, Active Directory Login is not supported on Android so we suggest using the Database Login mode.

Can you try to connect one more time to your existing database and verify if the firewall settings are properly set?

If you still can't connect to your existing Azure database, can you try to create a new SQL Azure database (if possible) and try to connect to that database and let us know if it works?

Best Regards,

Nicolas Dufour

signaturesignature

Clock2 yrs

I know the firewall settings in Azure are correct as the phone is on the same network as our computers, which are all connecting fine to that data source with RDM Enterprise on the desktop. I don't have time to go set up a test SQL but if the firewall setting wasn't correct on the desktop app we get a warning and aren't able to connect at all. On the phone I have no warning... looked at it again and I see that it shows "Not connected".

I clicked "Force refresh" and I get the warning about clearing the cache, then we're back to the white screen with "Not connected" showing up. On the desktop version if it doesn't connect there's always a pop-up explaining why (i.e. this IP is not allowed in the Azure firewall). Is there someplace to go to see errors on the Android version?

We don't have AD logon on the phone, and with this data source logon is in it already.

Clock2 yrs

Oh, and in Settings, Data Source I see that "Data source is online" though it's grayed out. Also, "My Data Source Information" is grayed out.

Clock2 yrs

Ah, went into the Azure data source, clicked Test Database and got an error that "SSL encryption for data sent between client and server is not implemented." So it's not supported on the phone app then?

Clock2 yrs

Hi,

If you are not able to connect to Azure due to firewall settings,
RDM Android will also display a message similar to RDM Android.

As for the errors, you cannot see them but they can be sent to us.
After an unsuccessful connection to Azure, just go in the Help and
Support section of the application drawer, select Report a Problem/Send Logs
and Fill in the form and send us the information.

When you say: "We don't have AD logon on the phone, and with this data source logon
is in it already", which login mode is used?

For the grayed out part in the settings, this is the normal behavior when
you cannot connect to a data source.

You won't be able to connect to an SQL Server that has SSL. The framework doesn't support it.
As for SQL Azure, since it only accepts secure connections, it should not work.
However, as previously mentionned, it works with a new test database that we have created
but this is not the expected behavior.

It would be interesting to know:
1 - Which login mode are you using?
2 - If you connect to your database with Microsoft SQL Server Management Studio (with the same user)
and you open the property window of your connection (after the connection has been established),
under Connection details you should see a property
named Connection encryption. What is the value of that property?
3 - If you are able to connect to a new SQL Azure database?
4 - If you use the SQL Azure master database user, are you able to connect to your database?

Best Regards,

Nicolas Dufour

signaturesignature

Clock2 yrs