Forum / Remote Desktop Manager Android - Bug Report

Port Forwards and SSH Tunnel: error -17

  • Create an Issue
  • Cancel

I was directed here from the Google Play Store to post the issue that I'm having with both Port Forwards and SSH Tunnels on my Android devices. I have my sessions saved in the Devolutions Drive and use that to sync them between devices but I have also tried creating the session on the device with the same settings to no avail. It should be noted that the sessions work on both my Desktop and Laptop and that other sessions such as SSH Shell and SFTP work on the Android devices.

Upon trying to open my port forward session I get asked for and enter my SSH Key passphrase and a black screen appears with the text

Unable to listen for tunnel: error -17 Unable to create tunnel: error -17
which repeats for all 4 of my port forwards, but I eventually receive a toast message saying the connection was a success (even though none of the port forwards work afterwards). I have also tried creating an SHH Tunnel for just one port but the same issue occurs.

I originally thought it might just be my Android device (LG G4) so I have tried the sessions on another phone and an Android tablet which results in the same error. I know my devices can support Fort Forwards as I can use another app (JuiceSSH) which forwards the ports without issue. I have tried both with this app installed and uninstalled with the device being rebooted frequently to ensure there are no potential issues.

Please let me know what information is needed but if you require logs that may contain information about my sessions I would have to ask that I send it privately.

Clock2 yrs

Hi Alan,

Thank you for taking the time to report the problem that you are experiencing on our forum.

Do both sessions that work (SSH Shell and SFTP) use a private key with a passphrase?

If so, do you use the same private key for the sessions that do not work (Port Forward and SSH Tunnel)?

If the SSH Shell and SFTP sessions do not use a private key with a passphrase, can you try to use the same private key as
the one you use for the Port Forward and SSH Tunnel sessions and test if they work with the private key?

One other thing, if you get a prompt to enter your passphrase, your passphrase must be blank in you private key configuration.
Can you try to enter the passphrase in your session and test if you can connect when the passphrase is saved in your session?

Ideally, we would like to try to reproduce the problem in our lab. In order to do so, can you export your SSH Tunnel session via RDM Windows and send it privately to

We understand that for security reasons, you may not be able to send us the information.


Nicolas Dufour


Clock2 yrs