Forum / Remote Desktop Manager Mac - Bug Report

Iterm session closes on reconnect

Steps to reproduce:

1) Open ITerm session
2) Choose "Reconnect" in context menu

Result - session is renewed but window is closed almost right away.


Also when I open Iterm session (stored one), close it right away and open again - the same result.

Please let me know if I can provide you more details

Clock5 mths

Hi Sergii,

The iTerm session is an implementation of the iTerm application. This sort of implementation is quite hard to efficiently maintains, I'll file a bug report but this could prove difficult to fix.

We're really trying to push hard for people to use the SSH Shell/Telnet sessions. It might be a good idea to post the features of the iTerm session you're using so we could get them implemented in the SSH Shell and/or Telnet sessions, this could prove a better long term solution.

That being said, I'll see what can be done for the iTerm session.

Best regards,

Xavier Fortin

signaturesignature

Clock5 mths

Hi Xavier,

thanks

internal "ssh shell" session looks promising, the only thing i miss there is "Broadcast input", it just does not work for this type.

Should I post a new thread for that? Or we'll keep it here?

Clock5 mths

No need, I'll just point to this thread. I'll file the feature request.

I don't think it should be much of an issue to implement our version of Broadcasting in SSH Shell.

I'll post back here for any news on both the iTerm bug and the Broadcast input feature in SSH Shell.

Best regards,

Xavier Fortin

signaturesignature

Clock5 mths

Thanks a lot!

Clock5 mths

Hi Sergii,

As mentioned here: https://forum.devolutions.net/messages.aspx?TopicID=29093&MessageID=115825#post115825, we've added our implementation of the broadcasting to our SSH Shell session. Could you try it and tell us if it works as expected?

Best regards,

Xavier Fortin

signaturesignature

Clock4 mths

Broadcasting works just fine! Thanks. Another issue that took me a bit to find a reason smile If you put extra space in the host name in the connection app says "error -15 Host not found" Could you please add trimming extra spaces. Thanks

Clock4 mths

Hi Sergii,

Should be easy to add.

Best regards,

Xavier Fortin

signaturesignature

Clock4 mths

Thanks a lot!

Clock4 mths