Forum / Remote Desktop Manager Mac - Support

Unable to Connect - Error 131084

  • Create an Issue
  • Cancel

I am on 5.1.0.0 on OS X 10.13.4

It works if I use "external" rather than "embedded"

Searching the forums I tried the following:

-Ensure I am using RDP engine 4 (and I tried 5)
-Uncheck the box for TLS
-Checked resolve hostname before attempting to connect
-Changed my connection from using the FQDN to IP

None of the above worked.

I am able to ping the host I'm trying to RDP to fine.

I have Remote Desktop Manger for Windows running in a VM and it connects fine.

Clock2 yrs

Hello,

Could you try RDM Mac 5.2.0.0?
https://mac.remotedesktopmanager.com/home/download

If you still receive the error 131084, please consult this help article
https://helpmac.remotedesktopmanager.com/troubleshooting_rdp.htm

Best regards,



Jeff Dagenais

signaturesignature

Clock2 yrs

Ok, I updated to 5.2.0.0. (interesting that I did "check for updates" earlier when I was on 5.1.0.0 and it said I was up to date.) Either way I was manually able to download 5.2.0.0

No fix.

So I moved on to the article. It had a few things:

•Validate that you have entered the appropriate username, password and domain to establish the connection or select the appropriate Credential Entry
•Validate that no User Specific Settings or Local Machine Specific Settings has been enabled by mistake or with the wrong credential
•If you are using a different username format to connect, select the appropriate one to use in the Advanced - Username Format field
•Enable/Disable the Network Level Authentication (NLA) option in the Connection tab of the RDP session
•Enable/Disable the Transport Layer Security (TLS) option in the Connection tab of the RDP session


I checked, my credentials are correct.
I have no user or machine specific settings mentioned that are applicable.
I am not using a different username format.
I had already tried both enabling and disabling both NLA and TLS in all combination.


Unfortunately none of these have fixed my issue.

Clock2 yrs

Hello,

Could you send us your RDP logs. Please do by doing the steps in this article
https://helpmac.remotedesktopmanager.com/howto_rdplogs.htm

Best regards,



Jeff Dagenais

signaturesignature

Clock2 yrs

Yep, captured logs and emailed in. I did a log capture with TLS enabled and one without.

Clock2 yrs

Hello,

Thank you for the logs. They have been transmitted to our engineering department.

Best regards,



Jeff Dagenais

signaturesignature

Clock2 yrs

Hi,

I've looked through your log and both of them seems to indicate the MS March Security Update issue, which should be fixed in 5.2.0.0. Could you look in the app About window to make sure you're on the 5.2.0.0. We've had had multiple users who tried to manually install the new version, but were still stuck with the previous one (5.1.0.0).

About

If it is still with 5.1.0.0, could you try deleting the app manually before installing the new one?

Best regards,

Xavier Fortin

signaturesignature

About.png
Clock2 yrs

I just checked ... went to Remote Desktop Manager -> About. I have 5.2.0.0 with my Enterprise License active. Same problem.

I then deleted the app and re-downloaded 5.2.0.0 enterprise from your site just to be sure. Same problem.

Clock2 yrs

Hi,

Can you get me the log with NLA and TLS enabled? In your log with TLS we can see HYBRID_REQUIRED_BY_SERVER, which implies that it need both NLA and TLS (don't know how I've missed it initially).

You can send it to me directly: xfortin@devolutions.net

Best regards,

Xavier Fortin

signaturesignature

Clock2 yrs

O hey! ... with both enabled it worked! (it did not work with both enabled on 4.1.0.0, so it appears a combo of the checking both and the update was the fix)

Do you still want the log?

To be clear, this was due to a recent Windows Update?

Clock2 yrs

No, no need for the log if it works.

Yes, there had been a security update on Windows operating systems regarding RDP. This was fixed on our side on RDM 5.2.0.0.

Best regards,

Xavier Fortin

signaturesignature

Clock2 yrs

Thank you for all the help!

Clock2 yrs