Forum / Remote Desktop Manager Mac - Bug Report

Unable to connect after March 13 patches

Glad to hear the situation is resolved!

Best regards,

Xavier Fortin

signaturesignature

Clock6 mths

Hi Xavier,
I'm sorry, it didn't resolved.
I'm using 5.1.0.1521122932
I needed to set Active Sandboxing to False.
Instead of my earlier reply, Setting Sandbox to True does not work.

Dit you created a later version than I'm using? So I can try again.
King regards


Kind regards

Clock5 mths

Hi Gerard,

You're using the latest version that I build. Just to be sure I understand, disabling the Sandboxing made your sessions work?

If so you might be hitting that bug: https://forum.devolutions.net/topic29338--issues.aspx#post114178

Does switching to the Lecacy engine (while enabling Sandboxing) also work for you.

Best regards,

Xavier Fortin

signaturesignature

Clock5 mths

Hi Xavier,
Yes, disabling Sandboxing made sessions work.
With that setting I was running in some RDP hanging sessions and RDM crashes.

Now , I changed back the entries in "Default"
Also set RDM preferences: "Active Sandboxing" = "True" and "RDP Engine" = "Legacy"
I tested well with a lot of sessions : happy times are back again.

Hopefully the " RDP Engine" setting will work soon.
Kind regards,
erard

Clock5 mths

Hi Gerard,

Just to clarify again. The Legacy Engine + the Sandboxing Enabled is the configuration that works for your?

With the Modern Engine + the Sandboxing Disabled, you were able to launch your sessions, but you were getting hangs and crashes while using them?

Best regards,

Xavier Fortin

signaturesignature

Clock5 mths

Xavier, any idea on when you are releasing? These interim builds are unstable on my system, causing CPU spike, beach balls etc. so I'm really looking forward to the released version...

Clock5 mths

Hi Jesper,

The version are built, but they still have to go through QA. Do you know what seem to cause those CPU spikes and hangs?

Best regards,

Xavier Fortin

signaturesignature

Clock5 mths

Hi Jesper,

https://www.dropbox.com/s/djhqy4ugw7d8hwf/Devolutions.RemoteDesktopManager.Mac.5.1.0.1521483581.dmg?dl=0

Could you try this one and tell me if it is any better?

Best regards,

Xavier Fortin

signaturesignature

Clock5 mths

It quickly starts to use CPU and the RDP session (singular - I can forget about multiple sessions) becomes slow to unresponsive, then it would eventually either beach ball or just quit, after which the Apple error reporting dialog would show to which I click ignore. Then I would start it again. It has happened with these developer builds in the past, but never with the QA'ed build.

I will download the above version and let you know.

Clock5 mths

Just happened again - beach ball after having been online for approx. 5-6 minutes with the build you gave me above.

Clock5 mths

When will be a patch available for the Free version?

Clock5 mths

Hi Ulrich,

Here it is: https://www.dropbox.com/s/z45y93ak2rhq2cc/Devolutions.RemoteDesktopManager.Free.Mac.5.1.0.1521548200.dmg?dl=0

Best regards,

Xavier Fortin

signaturesignature

Clock5 mths

Hi Xavier,

THX. It works fine .

Regards,

Ulrich

Clock5 mths

Hi Xavier,
You had 2 questions:

1 Just to clarify again. The Legacy Engine + the Sandboxing Enabled is the configuration that works for your?
Yes, I'm using it now for a few days. This combination works.

2 With the Modern Engine + the Sandboxing Disabled, you were able to launch your sessions, but you were getting hangs and crashes while using them?
Yes, able to launch but I was getting hangs and crashes.


Kind regards,
Gerard

Clock5 mths

Hi Gerard,

Thanks for the clarification. We'll keep this in mind.

Best regards,

Xavier Fortin

signaturesignature

Clock5 mths

after updated to 5.2, all seem good.


i have 131084 issue again after new RPD session added.

logs attached.

jyang.log
Clock5 mths

Hi James,

Does your session requires NLA? You get a "Protocol Security Negotiation Failure" in your log. I'd suggest trying to disable NLA and see if this helps.

Best regards,

Xavier Fortin

signaturesignature

Clock5 mths

NLA was disabled, still have same error. please see attachment.

jyang.log
Clock5 mths

Hi James,

To get this out of the way, can you try the last two remaining combinations of Security Negotiation settings (A.K.A. TLS: Off + NLA: Off and TLS: Off + NLA On).

Best regards,

Xavier Fortin

signaturesignature

Clock5 mths

please ignore it, it worked after reboot my laptop.

thanks!

Clock5 mths

Glad to hear it!

Best regards,

Xavier Fortin

signaturesignature

Clock5 mths