Forum / Remote Desktop Manager Mac - Support

SSH Shell Mac version 5.0.0.0

  • Create an Issue
  • Cancel

My SSH shells used to work fine, but now none of them connect.

I get either of the following 2 errors:

Error: FAIL

Code: -1

Error: FAIL_PERMISSION_DENIED
Code: -3

Clock2 yrs

Hi Craig,

There has been changes to the SSH sessions underlying component between the 4.6.2.0 and 5.0.0.0. You're most likely hitting an issue with this. Could you tell me as much information as you can on your sessions. To what server are they connecting to? Are you using Private Keys? Or SSH Gateways?

Could you try this version and see if this fixes your issue: https://www.dropbox.com/s/eeriknr455t30gz/Devolutions.RemoteDesktopManager.Mac.5.0.0.1518444221.dmg?dl=0

If it does not, could you setup a log file in your session (with the version I've sent you, this will be new to the 5.1.0.0) reproduce the issue and check if anything was log to the file? If so, could you send me that file?

Best regards,

Xavier Fortin

signaturesignature

Clock2 yrs

I almost forgot, here is how to setup the log file:

SSHLogFile

Check both Verbose and Logging path, set Verbose level to 4 and set the path to where you want the log file to be created.

Best regards,

Xavier Fortin

signaturesignature

SSHLogFile.png
Clock2 yrs

Thanks for the quick reply Xavier.

The new version fixes the SSH problem.. my sessions are fine now.

All the sessions are to IBM AIX, standard SSH keys, no gateway. Just a very simple ssh.

Let me know if you want any logs, but everything works as expected now.

Thanks.

Clock2 yrs

Hi Craig,

Glad to hear it. No need, the log would have been needed had it not resolved the issue.

This fix will be in an official version getting release during the week.

Best regards,

Xavier Fortin

signaturesignature

Clock2 yrs

One thing I noticed though is my "after login command" does not run.

I do a simple "export TERM" on login, but it doesn't run. In the Windows version, this executes fine.

Not a showstopper for now, but just letting you know.

Clock2 yrs

This is weird. Was it working before the RDM 5.0.0.0?

I'll look into this.

Best regards,

Xavier Fortin

signaturesignature

Clock2 yrs

Yes it used to work fine before.

I attached a log file of the connection.

SSH.log
Clock2 yrs

Hi Craig,

I've found and fixed the issue. You can expect in fixed in the next release.

Best regards,

Xavier Fortin

signaturesignature

Clock2 yrs

cool thanks.

Clock2 yrs

I'm getting the same error on all of my SSH sessions in RDM 5.2.0.0...they were working previous to this version?

Clock2 yrs

Xavier Fortin wrote:

Could you tell me as much information as you can on your sessions. To what server are they connecting to? Are you using Private Keys? Or SSH Gateways?

[...], could you setup a log file in your session [...], reproduce the issue and check if anything was log to the file? If so, could you send me that file?

Could you get me this information?

The instruction to setup a log are in one of the previous post of this thread.

Best regards,

Xavier Fortin

signaturesignature

Clock2 yrs