Forum / Remote Desktop Manager - SDK

Corrupted debugging installation

  • Create an Issue
  • Cancel

Recently I have started development on a datasource add-on for RDM. While doing so I seem to have corrupted some part of the debug installation. That is the version of RDM I copied from the normal installation to my visual studio project.

No matter what I do, and this is includes completely removing the installation and the configurations in the Appdata folder, when I start the application it attempts to load the local data store and consequently crashes.

Visual studio reports a stack overflow exception in external code so I can't see what's going on precisely. Does anyone have any idea on how I could repair this installation.

Clock2 yrs

Ronan Vonk wrote:

Recently I have started development on a datasource add-on for RDM. While doing so I seem to have corrupted some part of the debug installation. That is the version of RDM I copied from the normal installation to my visual studio project.

No matter what I do, and this is includes completely removing the installation and the configurations in the Appdata folder, when I start the application it attempts to load the local data store and consequently crashes.

Visual studio reports a stack overflow exception in external code so I can't see what's going on precisely. Does anyone have any idea on how I could repair this installation.

On RDM 12.6.8.0

UPDATE: reinstalled everything on a virtual machine and I am still having the same issue. The problem is the application enters a break state and does not seem to report any usefull information. It is not my own code that causes the problem.

UPDATE 2: I think it may be caused by a dependency I have in my project. I am using JWT.dll for encoding purposes. Could this be an issue for RDM?

Clock2 yrs

Ronan Vonk wrote:

Ronan Vonk wrote:
Recently I have started development on a datasource add-on for RDM. While doing so I seem to have corrupted some part of the debug installation. That is the version of RDM I copied from the normal installation to my visual studio project.

No matter what I do, and this is includes completely removing the installation and the configurations in the Appdata folder, when I start the application it attempts to load the local data store and consequently crashes.

Visual studio reports a stack overflow exception in external code so I can't see what's going on precisely. Does anyone have any idea on how I could repair this installation.

On RDM 12.6.8.0

UPDATE: reinstalled everything on a virtual machine and I am still having the same issue. The problem is the application enters a break state and does not seem to report any usefull information. It is not my own code that causes the problem.

UPDATE 2: I think it may be caused by a dependency I have in my project. I am using JWT.dll for encoding purposes. Could this be an issue for RDM?


I solved the problem. It was indeed the JWT assembly that caused the problem. This is however a little bit of an issue. I would love to be able to encode some of the data that is going to be handled by my add-on.

Clock2 yrs

Could you try to use a version in .NET 4.0 of this dll?

Regards

David Hervieux

signaturesignature

Clock2 yrs

I will try to find a version that supports this version of .NET. I cannot find one at the moment. Do you have a link by chance?

Clock2 yrs

Unfortunately I don't know this dll. Do you know if newtonsoft can do the same?

Regards

David Hervieux

signaturesignature

Clock2 yrs

No newtonsoft cannot encode its only use to me is json de/serializing.

Clock2 yrs