Forum / Remote Desktop Manager - Support

Powershell : WARNING: Data source not found

  • Create an Issue
  • Cancel

When running the Set-RDMCurrentDatasource I get the message "WARNING: Data source not found".

  • Get-RDMDataSource does not show any available datasources except SQLite Local Data Source
  • Deleting the default SQLite connections.db file and running Get-RDMDataSource recreates the file
  • Verified that the base64 encoded command is passing the proper ID when running (RDM CmdLet)
  • Completely uninstalled, deleted program and profile directories, reinstalled (even went to the latest beta)
  • Occurs for all user profiles on the system

I'm able to run the CmdLet from another system without a problem so this isn't a show stopper. Unfortunately, I have all of my development tools installed on this box and would rather not re-image it.

Clock3 yrs

Hello,

The data sources exist only in the current logged user profile. Are you connect with the same user on this machine when using PowerShell?

What data source type are you trying to connect to?

Could you please try to disable the Caching mode to see if this could help?

image

Best regards,



Érica Poirier

signaturesignature

Clock3 yrs

Thanks Erica, I disabled the cache but the error persists.

It does not matter what type of data source I try to connect to as I've tried creating new datasources with Devolutions Server, SQL, SQLite, and Access. None of the datasources are returned when running Get-RDMDatasource (except default SQLite Local Data Source - which is recreated and not shown in the navigation pane)

Clock3 yrs

Hello,

What version of PowerShell is installed on this computer?

Could you please post a print screen of the data source list on this machine when connected with the same user you use with PowerShell?

Best regards,



Érica Poirier

signaturesignature

Clock3 yrs

Version 5.1 - Attached is a screenshot of the issue

RDM_error.jpg
Clock3 yrs

Hello,

Could you please go in File - Data Sources and check what is the setting for the On start up option? Is it possible that this option is set to Use default data source and the default data source it should connect to doesn't exist anymore?


image

Best regards,



Érica Poirier

signaturesignature

Clock3 yrs

This was set to 'Last used data source'

Clock3 yrs

Hello,

Are you available for a remote session?

Please send us an email at support@devolutions.net and we will send you our online calendar to schedule an appointment.

Best regards,



Érica Poirier

signaturesignature

Clock3 yrs

I was able to identify that the issue was caused by the enablement of FIPS compliance. Once I had the server removed from that OU, the powershell CmdLets are functional again. This will likely be an issue at some point as the terminal servers will be classified as PCI1B and will require FIPS.

Clock3 yrs

Hello,

I'm glad that removing the server from this OU has fixed the issue.

Thank you for your feedback.

Best regards,



Érica Poirier

signaturesignature

Clock3 yrs