Forum / Remote Desktop Manager Mac - Bug Report

V5 Engine makes the RDP session unresponsive

After going to another window, then coming back to the RDP window a few times, the RDP window becomes unresponsive. I tried capturing a video, but it went up to 10 minutes and ~485MB before it happened, so I'm not sure how to reproduce.

Want a log file instead to see if you can see anything?

Clock11 mths

Please see attached video, perhaps this helps?

V5 Becomes Unresponsive.mp4
Clock11 mths

Getting us the RDP log could indeed be helpful (though we won't be sure until we see it).

We'll definitely look into this.

Best regards,

Xavier Fortin

signaturesignature

Clock11 mths

Can it only do one log at a time? I enabled the filter + specified 2 different files for 2 different RDP sessions, but only one of them is producing a log file.

Clock11 mths

This shouldn't be an issue. I've just tested and both of my log files get created. Were you using V5 on both of those sessions?

Best regards,

Xavier Fortin

signaturesignature

Clock11 mths

Yes, I'm using V5 on both sessions. Strange thing is that the performance issue hasn't happened since I put the com.freerdp.*Big Grinebug filter on there, but no logs... Things that make you go hmmm...

I will try to fiddle with it and get you some logs.

Clock11 mths

Looks like my problems only happens when I have 2 or more sessions open. Does that make sense? I will do further testing in the morning.

Clock11 mths

And if I catch it before the beach ball comes, I still have to Quit RDM and start it again, otherwise the bad performance continues, even though it's sandboxed.

Clock11 mths

Are you talking about the the RDP session becoming unresponsive when you say it only happens if you have 2 or more sessions open? I can't say if this makes more sense or not, but this is definitely an helpful clue.

Xavier Fortin

signaturesignature

Clock11 mths

It happened overnight with only one session open. When I came back to my laptop this morning, it was also unresponsive, had to disconnect and reconnect. So, unfortunately it's not only when 2 or more sessions are open.

Clock11 mths

Hi Jesper,

We've been able to reproduce your issue. We'll work on this and inform you of our progress.

Best regards,

Xavier Fortin

signaturesignature

Clock11 mths

Fantastic, thank you!!!

Clock11 mths

Just an FYI: v4.5.3.0 has not fixed this, correct?

Clock11 mths

Hi Jesper,

You're right, this hasn't been fixed yet. The 4.5.3.0 only addressed issues related to crashes on macOS High Sierra.

Best regards,

Xavier Fortin

signaturesignature

Clock11 mths

Xavier Fortin wrote:

Hi Jesper,

You're right, this hasn't been fixed yet. The 4.5.3.0 only addressed issues related to crashes on macOS High Sierra.

Best regards,

Xavier, when can we expect to get a fix released for this issue? I'm willing to be added to a beta if it means getting a fix faster. Right now I had to revert back to using Royal TSX upset

Merci!
Francis

Clock10 mths

Hi Francis,

We're still looking into this, but we don't have a solution for it yet. Are you also having this issue with the V4 engine? If it is the case, the provisional solution for this would be to change it to V4 until this is fixed.

Best regards,

Xavier Fortin

signaturesignature

Clock10 mths

Xavier Fortin wrote:

Hi Francis,

We're still looking into this, but we don't have a solution for it yet. Are you also having this issue with the V4 engine? If it is the case, the provisional solution for this would be to change it to V4 until this is fixed.

Best regards,


All my RDP sessions are set to Default. So the temporary solution would be to force them to V4?

Francis

Clock10 mths

What's the RDP Engine set in the Preferences under Session Type -> RDP -> General? If it is V5, change it to V4 and you will not have to change all your sessions (the Default value fallback to the Preferences option). If it is V4, you're probably having a different bug.

Best regards,

Xavier Fortin

signaturesignature

Clock10 mths

It was V5. Set it to V4 and will see how it behaves! Thanks!

Clock10 mths

Xavier Fortin wrote:

What's the RDP Engine set in the Preferences under Session Type -> RDP -> General? If it is V5, change it to V4 and you will not have to change all your sessions (the Default value fallback to the Preferences option). If it is V4, you're probably having a different bug.

Best regards,


It solved the issue for me too smile Thanks!

Clock10 mths