Forum / Remote Desktop Manager Mac - Support

RDM for Mac 4.4.2.0 seems to mess up ESC, DEL, Backspace keys in vi, SQL*Plus

  • Create an Issue
  • Cancel

After installing the latest Remote Desktop Manager for Mac (Free Edition), I am having troubles with my ESC, DEL/Backspace keys when using SQL*Plus and vi editor from a Linux server connected via SSH. Prior to the updates, I do not have such issues. I have to type "stay erase ^H" before logging into SQL*Plus so that DEL/Backspace key can work properly. For vi, since ESC does not work, I have to press CTRL-C to switch out of editing mode.

Anyone having the same issue? Mac OS is 10.11.6 (El Capitan) and Renote Desktop Manager for Mac (Free Edition) is 4.4.2.0.

How/Where can I download an older RDM version?

Thanks.

Clock3 yrs

I found an older version of RDM 4.3.0.0 on my laptop and will try that.

Clock3 yrs

So far, I have no issues with ESC, DEL/Bksp on older RDM 4.3.0.0.

I would like to try RDM 4.4.1.0 or 4.4.0.0 to see if there are any issues. Anyone knows where I can download them? Thanks.

Clock3 yrs

Hello,

Here's the download links that you are looking for

- RDM Free 4.4.0.0 - http://cdn.devolutions.net/download/Mac/Devolutions.RemoteDesktopManager.Free.Mac.4.4.0.0.dmg
- RDM Free 4.4.1.0 - http://cdn.devolutions.net/download/Mac/Devolutions.RemoteDesktopManager.Free.Mac.4.4.1.0.dmg

Best regards,



Jeff Dagenais

signaturesignature

Clock3 yrs

Thanks, I will try those versions and provide an update.

By the way, the keep alive in Mac doesn't work. I'll open a separate thread on that later.

Clock3 yrs

Hi,

The ESC key issue is already known and has been fixed internally. I'm building a version right now, so you should be able to confirm yourself. Could you look for those other keys issues too when it gets released?

As for the keep alive issue, we'll have to investigate this further.

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

Hi,

I've spoken with my colleague responsible for the SshTerminal and he think he might have found a solution for the keep alive timer. I'll get back to you when the version is released, so you can test it.

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

RDM 4.4.1.0 and 4.4.2.0 have issues with ESC, DEL/BKSP keys in vi (Linux), SQL*Plus.

RDM 4.4.0.0 does not have issues with the above keys.

Please let me know once latest version is released so I can test the keys and keep alive. Thanks.

Clock3 yrs

Hi,

The last version of RDM (4.5.0.0) is out. You can download it here: https://mac.remotedesktopmanager.com/Home/Download

Could you test your key issues in SSH and tell me if they are fixed?

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

Thanks, Xavier. I've downloaded RDM 4.5.0.0 for Mac.

I have good news & bad news.

Good news is ESC, DEL/BKSP keys are working fine now in vi editor.

Bad news is DEL/BKSP still doesn't work in Oracle SQL*Plus. If I typed a mistake, DEL/BKSP key will display ^H.

SQL> select naem ^H^H^H^H^H^H^C
SQL> exit

The temporary solution is to set stty before logging into SQL*Plus.

$ stty erase ^H
$ sqlplus / as sysdba
SQL> select name from v$database;

Is there a way to make auto-copy works when highlighting a text (so there is no need to press right-mouse button to choose Copy)? Also in PuTTY, when I pressed right-mouse button, it will do a Paste, is that keystroke behaviour possible in RDM?

Any news on keep alive? Is it fixed in 4.5.0.0?

Clock3 yrs

Hi,

I'll talk to the SSH Terminal dev about Oracle SQL*Plus. We'll look into fixing this.

As for the keep alive, we've tried something different to keep the session alive. It should work, but your feedback on this will be most appreciated.

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

Another good news : the keep alive in RDM 4.5.0.0 for Mac is working well ! Hurray ! Thank you so much !

Hope you guys can fix the Oracle SQL*Plus DEL/BKSP keys soon.

Clock3 yrs

Hi,

I think I know the answer, but just to be sure, what happens if you do ctrl+h in your terminal to Oracle SQL*Plus?

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

When I type Ctrl-H, it behaves like pressing the DEL key on my Mac.

SQL> select neam^H^H^H^H^H^H^H^H^H

Clock3 yrs

Hi again,

We think we've found the issue. This seems to have to do with the backspace character we were using. We'll change that and it should be fixed in the next release.

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

I've tried the latest RDM release 4.5.1.0 for Mac, the DEL/BKSP key issues in SQL*Plus are now resolved.

However, the "keep alive" feature doesn't work again. It was working previously in RDM 4.5.0.0, but it shows a bunch of repetitive prompts on screen (see below). I wish you guys can find a way to suppress it.

user@testserver1$
user@testserver1$
user@testserver1$
<... endless repeat>

Thanks.

Clock3 yrs

Hi,

I've completely forgot to mention it, but we were having issue with our fix to the keep alive, so, until we find a better solution, I've brought the old behavior as the default and set an option that brings mentioned fix (and all of its drawbacks). You can find the option in the SSH Shell properties: SSH Shell -> Advanced -> Locally managed.

To make this short, we don't have a reliable way to ensure the Keep Alive per session yet. The "Locally managed" option make us send a <null> character to the remote server to keep it alive. This cause multiple services (like nano) to print the character at the set interval.

For what I've been told as of now, the standard keepalive seems to be global to all sessions on your client. You can try changing them with those commands:

sudo sysctl net.inet.tcp.keepidle=7200000
sudo sysctl net.inet.tcp.keepintvl=75000

The first command set the amount of time (in milliseconds) of idleness before sending the first keepalive signal. The second one is the amount of time (also in milliseconds) between each subsequent keepalive signal.

I haven't confirmed that this work, but it is worth a try.

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs