Forum / Remote Desktop Manager - Feature Request

Simulated Typing for Web Forms

  • Create an Issue
  • Cancel

Many sites detect if a user has typed their username and password by using Javascript methods like onkeypress or onkeydown.

Due to this, when RDM autofills the username and password field, sites designed this way throw an error that no username or password was entered.

Obviously this is a problem with the design of the sites, but it is easier to change RDM than every poorly designed site on the Internet.

A solution to this could be if there were an option in RDM to simulate the actual typing of the username and password in the forms, which would trigger Javascript functions on the sites.

UniFi Controller web admin and CenturyLink Business login both use this mechanism, and therefore don't work well with RDM.

Clock2 yrs

Hello,

It's possible to authenticate on those type of websites by using a typing macro to perform the authentication.

Please consult this help topic for more information
https://help.remotedesktopmanager.com/howto_typingmacro.htm

Best regards,



Jeff Dagenais

signaturesignature

Clock2 yrs

Jeff,

That was exactly what I was looking for. I did check the documentation for AutoFill of web forms, but I didn't think about an after connection macro.

I am running into an issue now where both the embedded Internet Explorer and Chrome browsers the "autofocus" HTML input field attribute is broken.

Autofocus works for approximately a second when the page first loads, then the form field loses focus, causing the macro to fail to process usefully.

I've found that disabling "Show Favicon" resolves this problem.

There must be something about the process of rendering the favicon that is causing the form field to lose focus.

Thanks!

Clock2 yrs

The above is bug is using RDM version 12.6.6.0.

Clock2 yrs

Looks like I also needed to disable "Show toolbar" under the Advanced tab settings.

Clock2 yrs

Hello Austin,

Thank you for your feedback.

As I understand, you have been able to make this work by disabling the Show Favicon and Show toolbar option?

Best regards,



Jeff Dagenais

signaturesignature

Clock2 yrs

Jeff Dagenais wrote:

Hello Austin,

Thank you for your feedback.

As I understand, you have been able to make this work by disabling the Show Favicon and Show toolbar option?

Best regards,


Yes, disabling both of those options seems to cause autofocus to be treated normally. It is currently working for me, just wanted to let you guys know in case it was a bug.

Clock2 yrs