Forum / Remote Desktop Manager Mac - Bug Report

White blurring on screen in latest RDM

When connecting to Windows Server 2008 R2 with the latest version (R4.4.2.0), there is white blurring of certain buttons, menus etc. (see attached picture) if using RDP v4.

When turning off OpenGL, this gets resolved, but that's a performance issue, correct?

When using RDP v5, this goes away, but everything becomes really slow, and in some regards unusable when connecting with the multi-colored beach ball.

RDP v5 also has an annoying "Disconnected" box when logging off.

v4-OpenGL.jpg
v4-No-OpenGL.jpg
Clock12 mths

Hi Jesper,

We'll look into both the OpenGL issue and the RDP engine V5 performance issue.

As for the "Disconnected" box, I can't seem to reproduce it. Do you mean you're being shown a Disconnected message window when you do a LogOff on the session? If so, can you send me a print screen of that window?

Best regards,

Xavier Fortin

signaturesignature

Clock12 mths

Hi again,

One other thing. Do you have the white blur issue in RDP v5 with OpenGL enabled?

Best regards,

Xavier Fortin

signaturesignature

Clock12 mths

I do have the same issue with RDP v5, and it's actually worse - I have attached a screen shot.

v5-OpenGL.jpg
Clock12 mths

Disconnected Box screen shot attached. OpenGL was turned on, not sure if that makes a difference, since it crashed (Force Quit/Beach Ball stage) RDM completely.

Xavier Fortin wrote:

Hi Jesper,

We'll look into both the OpenGL issue and the RDP engine V5 performance issue.

As for the "Disconnected" box, I can't seem to reproduce it. Do you mean you're being shown a Disconnected message window when you do a LogOff on the session? If so, can you send me a print screen of that window?

Best regards,

v5-Disconnected.jpg
Clock12 mths

Thank you.

This is actually quite bad.

We'll look into it.

Best regards,

Xavier Fortin

signaturesignature

Clock12 mths

Xavier, I justed tested the previous releases, and it started happening in 4.4.1.0. Hope that helps.

Clock12 mths

Hi Jesper,

Thank you for providing more information. I think this is just due to the fact the default value of OpenGL changed around that time. I think if you make sure the value is set to OpenGL in 4.4.0.0, it is very likely the issue will be there.

As of now, we've been unable to reproduce it on our side. While it is still on the TODO list. The currently suggested workaround will be to disable OpenGL on sessions displaying this behavior.

Best regards,

Xavier Fortin

signaturesignature

Clock12 mths

I disabled OpenGL, but it caused all kinds of performance issues (beach ball, high CPU usage), so I am for now back to 4.4.1.0 until you find a permanent solution.

Clock12 mths

Were those performance issues in V5 or V4? Because, as mentioned, OpenGL became the default only recently. And except if you had changed it earlier manually, it should have been off. I'd really like you to check your Preferences in the 4.4.1.0 under Session Type -> RDP and confirm to me if the Use OpenGL is checked or not.

There have been no significant changes made to the V4 engine (especially it's rendering part) in the last few months. The last time the framework of the V4 engine was modified date to March, well before the release of 4.4.1.0.

Has for the OpenGL rendering, very few changes have been made except for a few bug fixes. I'll check those out though.

As for the performance issues in the Engine V5. One of my colleague think he might have an idea and is currently looking into it.

Best regards,

Xavier Fortin

signaturesignature

Clock12 mths

OpenGL is enabled. I think that was Benoit that told med about that option a long time ago. I just turned it on, and immediately my next connection is hanging with a beach ball, and I have to Force Quit.

I'm running with Sandboxing turned on, OpenGL turned on.

I did notice, however, that the bug with a white screen in one session when another session logs off is no longer there post 4.4.1.0, so that's a good thing with the new version... :-)

Clock12 mths

Sorry, I'm actually back to 4.4.0.0, not 4.4.1.0, my bad... 4.4.1.0 also had the issue.

Clock12 mths

I will install 4.4.2.0 and play with the Sandboxing and OpenGL options a bit.

Clock12 mths

Tore down the entire application when turning off Sandboxing, so for now 4.4.2.0 seems to have a bit of a performance problem with OpenGL turned off, but I will try to live with that using V4 until you get the next update out.

Clock12 mths

If you were already using OpenGL before, you can indeed notice a difference in performances when switching it off. While this is said, have you noticed the white blur in other RDP sessions or is it limited to that Windows Server 2008R2?

Could you export your faulty session, open the resulting file with a text editor, remove any sensitive information and send it to me via private message? I'd like to see if the reason we can't reproduce the issue on our side is because of a differences in settings.

Best regards,

Xavier Fortin

signaturesignature

Clock12 mths

It is attached. Works fine with OpenGL = Off.

REMOTESERVER.rdm
Clock12 mths

Hi Jesper,

I think I might have reproduced your issue. Or at least something extremely similar.

Just to confirm. Could you try to drag you undocked window to your primary monitor and see if the white blurs disappears?

I'll start working on a solution in the mean time.

Best regards,

Xavier Fortin

signaturesignature

Clock12 mths

Bingo! It disappeared... :-)

Clock12 mths

Good to hear.

I think I've found the fix. To be sure I'll build a test version that I'll send you.

Best regards,

Xavier Fortin

signaturesignature

Clock12 mths

Hi Jesper,

Here is the version I mentioned: https://www.dropbox.com/s/o4osbdtt4lqrlsy/Devolutions.RemoteDesktopManager.Mac.4.4.2.1504271096.dmg?dl=0

Could you try it and tell me if this resolve your issue?

Best regards,

Xavier Fortin

signaturesignature

Clock12 mths

That works! Does this version still have performance issues in RDP V5, or has that been fixed?

Clock12 mths

I still get that annoying "Disconnected" dialog box after logging off the terminal server though...

image

Clock12 mths

Hi,

This is good news.

As for performance issues, they are still under investigation. My colleague, that I previously mentioned, is not so sure that what he found would improve performance for you. This will require more testing and tweaking. I'd recommend staying with the V4 engine.

Best regards,

Xavier Fortin

signaturesignature

Clock12 mths

I've still been unable to reproduce the Disconnect box when logging off. Is it with the same server (Windows 2008R2)? And is it still specifically on the V5 engine?

I think I'll add logging to know if we have more details on the error we get when showing that box and why we're showing it to you.

I'll come back to you with this.

Best regards,

Xavier Fortin

signaturesignature

Clock12 mths

Forget what I said earlier. I'm reproducing the Disconnect box issue.

In my previous test I was logging off using the menu item provided in RDM, which did not reproduce the issue. If I logoff in the RDP session directly, I do get the Disconnect box.

I'll look into how to fix it.

Best regards,

Xavier Fortin

signaturesignature

Clock12 mths

Hi Jesper,

The Disconnect view being shown on a user initiated logoff has been fixed internally.

You can expect it in the next release of RDM Mac.

Best regards,

Xavier Fortin

signaturesignature

Clock12 mths

:-) Thank you!

Clock12 mths