Forum / Remote Desktop Manager - Support

RDM installation on Jumphosts for multiple Users

  • Create an Issue
  • Cancel

Hello,

I am trying to get the following configuration running without success.

-Devolutions Server with advanced datasource (SQL Server) on Server 2012R2 -> running fine
-RDM on my local machine (Windows 10) with access to the datasource -> running fine
-RDM Client and Agent on another 2012R2 server as a jumphost for multiple users -> not working

I install the RDM Client and Agent on this jumphost with a user with administration rights. If I try to connect to a configured system behind the jumphost with the same user I installed the RDM Client with everything is working fine. For this test I use the RDM Client on my local machine. If I try the same connection with a different user, I am prompted with the attached message. If I click ok it tries to install from the RDM .msi file which is located in the AppData\Roaming folder of the user which I installed RDM with.

If we would have to expect this behaviour for every user on every jumphost, that won't be useful. What can we do to solve this problem?

Best regards
Jan

Error_jumphost.JPG
Clock3 yrs

Hello,

Well, its the topic du jour as I was looking into this for other support calls, but I had not though it would occur also on jump hosts.

I am in the middle of updating the documentation for Terminal Services deployment, as this problem seems to be popping up mostly in that area.

I have a dozen tabs opened in my browser, and the reasons are varied and depend on so many factors, but the conclusions are that:

  • we must force deployment for ALL USERS
  • all of the installations/upgrades must be performed with elevated privileges.
  • you must always choose the Complete setup type

My current recommendation (I'm looking for an easier method...)

For NEW installs, run the installer from an elevated command prompt by using the ALLUSERS=1

msiexec /I Setup.{APP}.{Version}.msi ALLUSERS=1

In your case, we have to fix the Windows Installer Database. I need to get this tested on a mix of machines with/without our apps, but according to the MSI documentation, again from an elevated command prompt:
msiexec /I Setup.{APP}.{Version}.msi ALLUSERS=2

using the 2 means that

MicrosoftHelp wrote:

If the value of the ALLUSERS property is set to 2, the Windows Installer always resets the value of the ALLUSERS property to 1 and performs a per-machine installation or it resets the value of the ALLUSERSproperty to an empty string ("") and performs a per-user installation. The value ALLUSERS=2 enables the system to reset the value of ALLUSERS, and the installation context, dependent upon the user's privileges and the version of Windows.

I do not like the dependent upon the user's privilege in there, hence my recommendation to run from an elevated command prompt.
I must also recommend that you disable our automatic check for upgrades for those machines, plain users should not try to upgrade them.

I will follow up as needed if my conclusions change.

Best regards,



Maurice Côté

signaturesignature

Clock3 yrs

update 1:

Well, on my Windows 10 workstation it does install for all users by default, it even pops up the confirmation to elevate the privileges. We will move on to server OSes for further investigations.

Maybe a fourth recommendation to add though, install from a "persistent" source that is accessible to all users e.g. c:\deploy. The Windows Installer technology does copy the msi under another name to an internal folder, but we have seen too many support cases for missing packages that we've grown not to trust that historical file to always be there.



Maurice Côté

signaturesignature

Clock3 yrs

Hi Maurice,
thank you for your answer!
I tested your approach with slightly success, but I have follow up problems.
First of all I have to admit that we do not have roaming profiles in that environment and cannot use them in any case. Currently we have about 70 jumphosts and more than 50 users.
I had a clean deinstallation of RDM and the Agent and reinstalled both from the .msi file with given parameters. Then I started RDM locally on the jumphost with my administration user and entered the license key. I then first tried from my local machine with the administration user, this works fine.
Then I started RDM locally with the non administration user and got the installation prompt as well when trying to start RDM on the jumphost. Now this works in the user context, it finds the sources and runs the installation even the user has no local Administration rights, but I expected this prompt to disappear completely. It forces a reboot too and the user has to enter the license key on the jumphost again!
So in our Environment every of the 50+ users would have to install the RDM 70 times and has to enter the license key 70 times as well.
Is there any possibility to deploy in this Scenario without having every user to run though that manual tasks?


Another problem is, that users have to enter the license key even if we have supplied it within the datasource. So a user starts a freshly installed RDM, clicks on cancel when asked for the license key, adds the datasource which contains the license and does not get it working. Maybe this is because we are still on evaluation?


Thanks in adavance for you help!
Best regards
Jan

Clock3 yrs

Hello,

First issue, the installation:

How did you install the agent? Have you used the separate installer or you are simply using the Tools - RDM Agent command?

Best regards,



Maurice Côté

signaturesignature

Clock3 yrs

Hi Maurice,
I used the MSI file for the installation of the agent with the same parameters you named for RDM client installation.
Best regards
Jan

Clock3 yrs

Hello,

I guess we need to enable logging and look at the logs.

Could you add those options to your command line?

/l*v "log.log"


Best regards,



Maurice Côté

signaturesignature

Clock3 yrs

Hello,

I had exactly the same problem.

The users points on the file C:\Users\AdminUsername\AppData\Local\Devolutions\Install\RDMInstall.xml

I copied it to another "public" location on the server and searched all occurences of this path in the registry in order to update it.

In Exemple :

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Components\7B32D57D57B5297488EAD9B0F04F0493]
"37A15607434EFD148837A7AF1349D541"="C:\\Users\\AdminUsername\\AppData\\Local\\Devolutions\\Install\\"


The problem occur again at each update


Regarding the licence key I exported the configuration of a licenced RDM to a default.cfg file in c:\Program Files (x86)\Devolutions\Remote Desktop Manager

Hope it can help

Best regards

Clock3 yrs

Hello,
as my colleague Jan is in vacation I will go on troubleshooting our problem.
I've downloaded the latest Version of RDM (12.6.6.0), removed the old Version and installed this one with following Parameters in elevated prompt:
msiexec /I Setup.RemoteDesktopManager.12.6.6.0.msi ALLUSERS=2 /l*v "log_RDM.log"
Please find attached log file of this installation.


Same procedure for the agent installation. Log is attached as well.


Still same problem. I installed the product with my adminstrative account. Can run RDM manually and as Jumphost with this account. When I run it with my non-administrative account I can run it manually but when I use the jumphost-function I receive the installation prompt with pending reboot.


I have not yet tested the licensing problem further. If we can fix this with the Default.cfg I guess this would be okay.


Best regards
Roman

log_RDM.log
log_Agent.log
Clock3 yrs

Hello,

Thank you for going ahead with this. I will look at the logs and get back to you.

Best regards,



Maurice Côté

signaturesignature

Clock3 yrs

Hello,

I cannot find anything wrong. We have a RD Session Host session standing by to perform deeper tests, hopefully we can address this tomorrow.

Thank you for your patience



Maurice Côté

signaturesignature

Clock3 yrs

Hello,

Just a note to mention that I am unable to find the root cause at this time. We do get MSIInstaller messages in the event log with codes 1001 and 1004 which indicates that the Auto-Repair feature of Microsoft Installer is being triggered. No reason as to why.

The problem does not appear when launching RDM itself, but rather when one of the file extensions associated to our products are used. (rdmj, rdm, and rdp)

This means that there is a workaround, namely to reset the file associations using command line tools. We will test a script tomorrow and post the details here.

Best regards,



Maurice Côté

signaturesignature

Clock3 yrs

Hi Maurice,

you wanted to share details here. Did you get any?

Thanks in advance and best regards
Roman

Clock3 yrs

Hello Maurice,

I support my colleagues Roman and Jan. The workaround of Gabriel Maret works. But unfortunately only partially. On some hosts the Jumphost function works. Not on others. Furthermore, it is not a practical solution for us to customize the registry on every host.

Best regards,
Julian

Clock3 yrs

Hello Maurice,

i have a short Question: What is the Purpose of the RDMInstall.xml in %localappdata%? Can there be conflicts with this file if several people access it at the same time?

Thanks in advance and regards,

Julian

Clock3 yrs

Hello,

A workaround is not a permanent solution, its meant to allow you to work while we resolve the issue.

We have found a solution to test out, we will perform these tests internally.

In the mean time, if you cannot wait for an official build, please run the following commands in an elevated command prompt.


FTYPE Devolutions inc..Remote Desktop Manager.rdd="C:\Program Files (x86)\Devolutions\Remote Desktop Manager\RemoteDesktopManager.exe" "%1"
FTYPE Devolutions inc..Remote Desktop Manager.rdm="C:\Program Files (x86)\Devolutions\Remote Desktop Manager\RemoteDesktopManager.exe" "%1"
FTYPE Devolutions inc..Remote Desktop Manager.rdmj="C:\Program Files (x86)\Devolutions\Remote Desktop Manager\RemoteDesktopManager.exe" "%1"
FTYPE Devolutions inc..Remote Desktop Manager.rdp="C:\Program Files (x86)\Devolutions\Remote Desktop Manager\RemoteDesktopManager.exe" "%1"

Best regards,



Maurice Côté

signaturesignature

Clock3 yrs

and for the RDMInstall.xml, it is installed in the local user data (%LOCALAPPDATA%), other users do not have it.

The installer project had an inconsistancy, we are testing out the solution as we speak.

Best regards,



Maurice Côté

signaturesignature

Clock3 yrs

Hello, Maurice,

thank you for your response. Is there any prospect of when the patch will be available?

Regards, Julian

Clock3 yrs

Hello,

I have just tested and RDM beta v12.9.7 worked correctly with our changes.

Best regards,



Maurice Côté

signaturesignature

Clock3 yrs

Hello,

Just for Information, on a Remote Desktop Jump host it work fine with last stable version (13.0.6.0), but with the last beta (13.0.17.0) the same issue occurs again (Windows installer start for each user before the Remote Desktop Manager Windows with "please wait while windows configure Remote Desktop Manager).

Best regards

Gabriel Maret

Clock2 yrs

Hi Gabriel,

Could you please try the attached version of the RDMAgent?

It has an option to disable (.rdmj) file association and call the .exe directly.
2018+03+08+8+56+56

This should resolve the issue. This option will officially be in the next RDM & RDMAgent releases.

Best regards,

Stefane Lavergne

signaturesignature

2018-03-08_8-56-56.png
RDMAgent.zip
Clock2 yrs

Hello,

It seems to be working with this checkbox in the agent. Thanks

Is there a way to ckeck this option by default for all of our users ?

Best regards

Gabriel

Clock2 yrs

Not at this time.

I will discuss it with David, either we change the default to be checked or provide a way to push the setting to all jump servers.

Best regards,

Stefane Lavergne

signaturesignature

Clock2 yrs

Default value has been set to checked, will be available in the next build.

Stefane Lavergne

signaturesignature

Clock2 yrs