Forum / Remote Desktop Manager Mac - Support

Mac clipboard and login problems with RDP

  • Create an Issue
  • Cancel

I am running version 4.3 of RDM Free on the current version of MacOS attempting to RDP to Windows Server 2012 R2.

When using an embedded session, it is able to automatically log in with the provided credentials in the entry. Items copied from the host OS are not available to paste in the session and vice versa. Clipboard is enabled in the entry configuration. I have attempted to restart rdpclip on the session. I am using a clipboard manager on my Mac.

When using the external session, it does not automatically log in with the provided credentials. Username and domain are filled but, not password. Clipboard does function properly using the external session.

Is it possible to resolve one of the two issues? My primary use case for this tool is to better organize my sessions for multiple sites by using folders rather then the flat structure of the default RDP client on Mac.

Clock3 yrs

Hello,

Clipboard issue
Are you trying to copy/paste text or a file via RDP? Only text can be copy/pasted via RDP in embedded mode. If you want to transfer files, please consult https://helpmac.remotedesktopmanager.com/troubleshooting_rdp.htm

Password not filled in external mode
In external mode, RDM Mac is launching Microsoft RDP and Microsoft doesn't allow us to send the password, this is why you need to enter it manually in external mode. If someday Microsoft allow us to do it, it will be possible for us to send the password to the remote session.

Best regards,



Jeff Dagenais

signaturesignature

Clock3 yrs

Thanks for the note on password filling.

I am only trying to copy and paste text. After copying a line of text from my mac I right click in a text box on the session. The paste option is grayed out.

Clock3 yrs

Hi,

What RDP Engine are you using.

You can find this in your session settings at Microsoft Remote Desktop (RDP) -> General -> RDP Engine.

If the value is set to Default, it's using the Preferences setting. You can see it at Preferences -> Session Type -> RDP -> General -> RDP Engine.

There seems to be an issue with the shared clipboard feature and the Engine V5. If this is your issue, switching to V4 should solve it.

Best regards

Xavier Fortin

signaturesignature

Clock3 yrs

Thanks, changing the RDP engine to V4 worked.

A few notes to added, after changing the engine to V4 I started receiving the following error:

Failed to connect to Host (131084)

This error was resolved by disabling TLS on the connection tab of the session entry.

Clock3 yrs