Forum / Remote Desktop Manager Mac - Support

Problem with password inherited and Mac Client

  • Create an Issue
  • Cancel

We have DVLS 4.5.0.0 , SQL 2016 DB and RDM 12.5.4.0 / 4.3.0.0

If we in a session set "Credentials" to "Inherited" and on the above Group/Folder specify the user and password , or if we point put a entry in "Credential repository" we cannot use the session with Mac clients. It won´t log in and giving the error message "Error: Password authentication denied"

Using RDM client on windows this works fine.

It also seems to be working fine in our old RDM environment with Mac client , but there we use SQL (2005) database directly instead of DVLS

Clock3 yrs

Hi,

I just want to make sure I understand correctly. You have sessions in a DVLS data source and when you set the credentials of one of those sessions to inherited, it doesn't use the parent credentials when connecting?

You mentioned both putting the username/password and a Credential repository on the parent. Is it failing for both?

I'll have to investigate this further. I'll come back to you as soon as I find something.

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

Yes that is correct.

This is for Mac clients, using Windows client it works

Clock3 yrs

Hi,

I've been unable to reproduce your issue.

I created a group on a DVLS server 4.5.0.0 in which I added my RDP session. I've entered my RDP credentials in said group and set the RDP credentials to inherited. I connected without issue. I also tried with a credential entry by setting the group credentials to Credential repository. Still no issue this way.

Could you make sure you do not have the Override credentials checked in the Local Specific settings of your session, group and credential entry (Right click -> Edit -> Edit Entry (Local Specific Settings)?

Just to make sure this is really an issue with the way the credential are set and not an issue between FreeRDP and your session, could you try your session with your credentials set directly in it?

Sending me screenshots of the session, group and credential entry general tab and credentials section and their hierarchy in the tree might help me better understand your setup. Don't hesitate to hide any sensitive information. I just need to see what options are set.

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

Hi

I missed a important thing maybe, but this is a putty (SSH) session.

Yes, assigning the username/password directly on the session or using credentials from credential repository works, but not when I use inherit from parent

Local Specific Settings is disabled from Data Source, but that setting in User Specific Settings is blank

Attaching screenshot

I can do tests with RDP also if you like

RDM GroupFolder.jpg
RDM Putty session.jpg
RDM User Specific.jpg
Clock3 yrs

Hi,

Sorry, for some reasons, I assumed you were referring to RDP session. Though it shouldn't matter, I'll focus my effort testing with the Putty connection. We do have to convert the Putty session to our SSH Protocol (the same as the one used for the SSH Shell/SSH Tunnel/Port Forward sessions). Maybe something weird happens while doing the conversion.

I'll come back to you as soon as I find something or if I need any further information.

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

Hi again,

I'm really unable to reproduce the issue. Just to make sure we're talking about the same thing, I'll show step by step what I did. Tell me if anything is different than what you did.

First, I create my group and set its credentials:

CreateEditGroup

Then, I create my putty session inside the group:

CreatePutty

I setup my Putty session and make sure to set it's credentials to inherited:

EditPutty

This is what I end up with in my tree:

Tree

Finally, opening this session on Mac succeed.

Is this pretty much what you're doing? Do you have any additional step?

Could you try opening the session in external mode (Right click -> Open with Parameters -> Open (External))? It will open the session in a new Terminal.app window. This way we will see the command and confirm if at the very least the username is correctly resolved.

Alternatively, creating an SSH Shell session, with the same settings, while enabling the Verbose mode and setting it to level 4 (only possible in Mac: SSH Shell -> SSH Settings -> Verbose) and sending me the terminal output (via private message) might also help me.

Best regards,

Xavier Fortin

signaturesignature

CreateEditGroup.png
CreatePutty.png
EditPutty.png
Tree.png
Clock3 yrs

Hi
Yes, thats exactly what I did.

So I set up a new database and made group and session like your pictures and it worked. So i started to set up the Security Groups and Roles that we use in PROD database, and it still worked.

Then I remembered that I have done some settings to the ROOT folder, and there it was. I have set "Credentials" to "None" there in PROD , changing this to "None" in test database also give me the error in MAC client but still working in Windows client.
Setting it back to "Default" makes it work again!

Clock3 yrs

Hi,

Great! I'll look into why the behavior is different than Windows.

Thank you for your cooperation!

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

Hi again,

This has been fixed and will be available in the next release of RDM Mac.

Best regards,

Xavier Fortin

signaturesignature

Clock3 yrs

Thanks for the info and good work

Clock3 yrs